Chevy Astro and GMC Safari Forum banner

04 Astro new fuel pump not priming, gas gauge not working

454 Views 13 Replies 6 Participants Last post by  AstroWill
I had a breakdown issue in the Walmart parking lot. 04 Chevy Astro 2WD. Put $40 worth of gas in it and had about 1/2 a tank. Drove just fine and parked in the parking lot. Went in and did my shopping and came back out and gas gauge dropped to E, Miles left to E screen went to dashes, and fuel pump wouldn’t prime. Relay clicks when you turn the key on. Went and purchased a new fuel pump, dropped the tank, installed it, and swapped out the fuel filter. ECM-B fuse is good. Cleaned fuel pump ground above tank. Still not showing gas in the tank and still won’t prime. Also have a P0452 code, (Fuel tank pressure sensor circuit low voltage.) Another note, the day before it did the same thing on a slight incline. I put it in neutral and let it roll back and slammed on the brakes and it went back to normal. Didn’t work this time around. I’m completely stumped on what it might be.
1 - 7 of 14 Posts
You bought a new pump and replaced the old pump without knowing for sure if the old pump was actually bad? What if it was just a bad connection or ground? The issue with the gauges might have been a clue, since they are usually not affected by the pump itself.

The fact that you jerked the vehicle which got it going tells me something may be loose, or possibly corroded. The fuel pump AND fuel gauge sender share the same common connection. That's probably where I might start looking.. assuming there is 12v coming out of the relay
I replaced the fuel pump because I assumed that was the issue because the last one I put in was a cheaper aftermarket pump. And I figured that the fuel level sensor on the pump wasn’t sending a reading to the gauge. I’m sorry I've just been trying the easiest and fastest things to start out with because I need the vehicle back on the road. Where exactly should I test first?
Update: just jumped pin 30 and 87 on the relay, pump primed, put relay back in while it was running, now it starts every time???
Update# 2, Issue came back. Put new fuel pump relay, cleaned all contacts in fuse block with electrical parts cleaner and a toothbrush, and it just happened again. Ground by tank is clean, ground on firewall is clean, I don’t know where to start looking.
Did you replace the pump and sending unit or just the pump?

Personally I would suspect the connector that plugs into the sending unit since both pump and gauge are affected.
Are they separate on these? I thought the fuel pump and sending unit on the 04 is all in one.
Simple diagnosis..

When it's NOT working, do you still have voltage coming out of relay?
When it's NOT working, do you have voltage at fuel pump?

This will tell you at what point to start looking.
Get a test light

Assuming connections are good:
You might have an intermittent break in a wire
If so, easiest would be to run a new one

Same could apply to ground if 12v is good
Getting voltage into relay on pin 30, but with vehicle on there is no voltage at pin 87. Used a test light. With relay out and vehicle key on or off, I’m getting constant voltage at pin 30 and 85
Solved! Used JustAnswer, and talked with a mechanic. Apparently there was a break between the pink wire on the ignition switch and ECM-1 fuse. Ran a new lead and we are up and running!
1 - 7 of 14 Posts