Chevy Astro and GMC Safari Forum banner
21 - 37 of 37 Posts

·
Registered
1999 AWD Safari, 1995 Astro 5-speed
Joined
·
750 Posts
Discussion Starter · #23 ·
The bad core support is out and what a PITA job that was. I also need a new battery tray . The heavy rot in the core support and battery tray had made it almost impossible to find the spot welds on the drivers side in the lower section, so i ultimately had to rip the thing off to find all the welds.

Fortunately its done and the condition of the subframe is better than i expected. Repair needed but not destroyed
 

Attachments

·
Registered
1999 AWD Safari, 1995 Astro 5-speed
Joined
·
750 Posts
Discussion Starter · #24 ·
The subframe needs some welding, but not as rotted as i feared, i can work with this

The body was sitting on the inner fender as shown on attached picture, if it rots this bad it does have a kind of built in safety
 

Attachments

·
Super Moderator
05 Astro AWD
Joined
·
14,158 Posts
Phew - that is much, much better. Good job!
 

·
Registered
1999 AWD Safari, 1995 Astro 5-speed
Joined
·
750 Posts
Discussion Starter · #27 ·
Update i failed to post

I was feeling suspicious of my welding, so decided to test them with a large hammer. I was not happy to learn that i have lost my welding skills through lack of use. I then decided to do this whole repair with bolts.

I cut the bottom out of two bolt on stake pockets which are about the right size, bolted my "welded" reinforcements to the core support, then twisted them a little to bolt to the stake pockets. This allowed me to mark and remove the part of the mount that will bolt to the bushing.

I also bolted the whole core support in, 16 total bolts. Luckily this was straight forward and there was tons of room for bolts, not necessary to weld at all when replacing the core support.

Couple pics of installing the core support and the stake pocket bodge repair.
 

Attachments

·
Registered
1999 AWD Safari, 1995 Astro 5-speed
Joined
·
750 Posts
Discussion Starter · #29 ·
Finally running and driving, installed an amazon sourced bumper skin that fit really well actually.

I ended up having to replace the heater control valve which broke, and my "new" core support common ground completely failed and ripped out annoyingly. I attempted to make a new one but its not working properly as the horn, head lights, and wiper switch all turn on the wipers only, and nothing else. Still need to fix that.

Also were i to do this again i would not settle for such a crispy source panel, the poor quality is causing other issues.

Huge improvement in the bumper fitment, no more dragging tires, no more bashing noises in bumps, pretty psyched
 

Attachments

·
Registered
1999 AWD Safari, 1995 Astro 5-speed
Joined
·
750 Posts
Discussion Starter · #30 ·
My new battery tray fit nicely, i had to make that modification detailed elsewhere on the forum for the engine computer bracket since the later generation tray is the only one available, but pretty straight forward to modify. The inner fender was in good shape under the tray, just needed a little paint

I also replaced the coolant and washer fluid reservoir, for the first time the tabs arent broken. The aftermarket reservoir tabs needed a little heat to conform, hopefully they will stay unbroken for a while
 

Attachments

·
Registered
1999 AWD Safari, 1995 Astro 5-speed
Joined
·
750 Posts
Discussion Starter · #31 ·
Electrical issue for accessories resolved, bad passenger side ground

Now i will finally perform a much overdue tune up and front and rear brakes before tackling the pile of codes, maybe some will go away.

Prior to the core support job the van was displaying the following codes-

C0226. Left front sensor missing
C0235. Open rear speed signal
C0265. EBCM internal malfunction
P0131. Low voltage 02 circuit bank 1 sensor 1
P0143. O2 sensor low voltage bank 1 sensor 3
P0171. System too lean bank 1
P0300. Random misfire
 

·
Registered
1999 AWD Safari, 1995 Astro 5-speed
Joined
·
750 Posts
Discussion Starter · #32 ·
Since ive only been able to tinker with the van in small time increments recently ive been trying to do something about the awful cracking in the vinyl trim around the windows. Wow does it look horrible, and it sort of exploded over the last year and a half, they were just fissure like lines originally.

If you put this off like i did your paint will be ruined. The cracking vinyl also cracked and damaged paint on both sides. I was able to marginally improve the appearance removing the vinyl from the worst area on the passenger door. I was hoping to just leave it body color but it will have to be redone in black paint.
 

Attachments

·
Registered
1999 AWD Safari, 1995 Astro 5-speed
Joined
·
750 Posts
Discussion Starter · #33 ·
This is probably my CO226, ABS sensor wire on driver side has been sanded right through by the rusty subframe here. New ABS wire on order for both sides. I will put some wire loom on the new wire, the subframe feels like 40 grit sandpaper.
 

Attachments

·
Registered
1999 AWD Safari, 1995 Astro 5-speed
Joined
·
750 Posts
Discussion Starter · #34 ·
Opened pandoras box trying to do the front brakes. Not sure these functional but exceedingly rusty calipers are worth saving, bleeders are very unlikely not to break. Was a battle to remove requiring new hardware ultimately

Currently the issue is rotted out hub bolts with minimal purchase for tools. i will likely need to cut them off to replace so i can deal with the ruined dust shield.

Fluid film is worth it.
 

Attachments

·
Registered
1999 AWD Safari, 1995 Astro 5-speed
Joined
·
750 Posts
Discussion Starter · #35 · (Edited)
Its already july? The slowest brake job in history is finally complete. So slow that my new calipers actually rusted before i even test drove the van. That is acceptable as it is in keeping with the feng shui of the vehicle.

Also did the tune up, considerable corrosion on the contacts of the cap and rotor. Surprised it ran as well as it did.
 

Attachments

·
Registered
2004 Safari RWD, 2002 Astro AWD
Joined
·
257 Posts
Thanks for posting all those pictures.
All I can say is WOW, a lot of work you are doing.
Looks like it is coming along nicely.
 

·
Registered
1999 AWD Safari, 1995 Astro 5-speed
Joined
·
750 Posts
Discussion Starter · #37 ·
Thanks! Very slow improvements

I have 2 months left on a special inspection extension and now its finally drivable. Before i got into the core support i was having a very rough idle issue.

The tune up has not resolved this, so im thinking possible spider injector. It is a bit intermittent, for example i put about 50 miles on the van yesterday doing errands, and it ran very smooth for about 25, but then started to develop the rough idle again, and things started to get rough even driving at low speeds.

Reading up i did have a few misfire codes that others have had that indicated the spider injector, PO300 and PO171, so i may do this next.
 
21 - 37 of 37 Posts
Top