Chevy Astro and GMC Safari Forum banner
121 - 140 of 148 Posts

·
Super Moderator
05 Astro AWD
Joined
·
14,051 Posts
Yeah, yikes. A good reason for a plastic tank.

A couple guys have replaced their metal tanks with, I think, Dorman metal tanks. Pretty sure they bought them at their LAPS. I think.
 

·
Registered
Joined
·
135 Posts
Discussion Starter · #124 ·
So after all this.... Van still turned off.

Feels like the idle went so low and it just cut off.
Might need to replace the IAC
 

·
Registered
01 Astro Cargo RWD, 97 Astro Mark III AWD
Joined
·
1,827 Posts
Random engine shutdown sounds likes coil going bad, A common issue with GM.
Should be considered a service item.
 

·
Registered
Joined
·
135 Posts
Discussion Starter · #128 ·
MI_Ghost said:
Random engine shutdown sounds likes coil going bad, A common issue with GM.
Should be considered a service item.
I just replace the Coil with a new GM (delco)
 

·
Registered
Joined
·
135 Posts
Discussion Starter · #129 ·
AstroWill said:
By the time you are done, all the wear parts will have been replaced.

Is it only shutting down at idle? Randomly?
It only shut one once so far at Idle, Since the New Spider and Fuel Pump it's only done it once now. Although I did feel the idle drop really low and the engine struggled a bit to stay on then it cut out.
 

·
Administrator
Common Sense + Critical Thinking
Joined
·
12,417 Posts
Was that directly after the replacement?

I would give it some time, could have been trying to adjust fuel/air based on the old values.
 

·
Registered
Joined
·
135 Posts
Discussion Starter · #131 ·
AstroWill said:
Was that directly after the replacement?

I would give it some time, could have been trying to adjust fuel/air based on the old values.
True. I replaced the Spider first then the IAC and now the Gas Tank and Pump.

So far its been running good
 

·
Registered
Joined
·
135 Posts
Discussion Starter · #132 ·
Okay now I have replaced the MAP sensor and the another IAC, time for a test drive and see what happens
 

·
Registered
Joined
·
135 Posts
Discussion Starter · #135 ·
made a slight adjustment but nothing really changed on the idle.
the only key thing I have is that runs better with a load on the engine (ac running)
I might have to clean the throttle butterfly and see if maybe some gunk is stuck or causing a strange idle.
 

·
Registered
Joined
·
135 Posts
Discussion Starter · #136 ·
Replaced Spark plugs and wires and ran a can of seafoam SS14 seems to have done the trick. Idling 100% better but time will tell if it stays
 

·
Registered
1992 Astro - Silver / Gray / 4 Wheels
Joined
·
5,246 Posts
Wow... all that work and still the Seafoam.
I really hope you get things sorted and idling properly.

CPI Intake right?
 

·
Registered
Joined
·
135 Posts
Discussion Starter · #138 ·
sixsix said:
Wow... all that work and still the Seafoam.
I really hope you get things sorted and idling properly.

CPI Intake right?
Running like a champ now.... a lot more power. I wonder if carbon build in the intake was making the EGR get stuck or something.

Now I got gotta make sure I have no coolant leak or anything. Since the heater valve went bad.
 

·
Registered
Joined
·
135 Posts
Discussion Starter · #139 ·
Had a piece of carbon build-up in the intake manifold causing the EGR Valve to get stuck open.
Cleaned it and now it is running great and gas milage has improved dramatically.
 
121 - 140 of 148 Posts
Top