Chevy Astro and GMC Safari Forum banner

AWD issues

470 Views 4 Replies 3 Participants Last post by  Bryans astros
I have a 2003 Astro LT in which the front drive axles were removed by the idiot before me. It runs fine, but travels real tight as if there was something holding it back. Could the transfer unit still be engaged? If so, how do I correct this besides rebuilding the AWD? I dont mind having RWD.
1 - 5 of 5 Posts
Remove the front diff and front drive shaft?

That feeling that something is holding you back is likely the engine 馃榿
Remove the front diff and front drive shaft?

That feeling that something is holding you back is likely the engine 馃榿
The engine runs beautiful. It has been scoped and all is well. It almost feels like it wont go into OD but I can feel it shift. Almost like it has a girdle strapped to it
If the front axles were removed.. then the AWD system would see a difference in speed between front and rear, and would engage the AWD transfer case. PULL THE ATC (automatic traction control) fuse under the hood.
OK. Looked under the fuse cover and the ATC fuse had been removed. Thanx. Any other ideas? I also have an issue when I put the car in Drive and roll without touching the pedal, I press the pedal and get zero acceleration. I have to mash the pedal to get it into first gear and it really howls. My 2000 RWD does the same exact thing. Any idea? Thanx
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top