Chevy Astro and GMC Safari Forum banner
1 - 12 of 12 Posts

·
Registered
GMC Safari Passenger Van SLE
Joined
·
7 Posts
Discussion Starter · #1 ·
Hello, my name is Joel. You can also call me Spacedogg.
I recently purchased my first ever van. A 2002 GMC safari SLE rwd with 106k original miles for $1500. It’s in great condition in some areas, but It had a few problems that I was able to fix right away:
-Loose donut gasket (it was loud as hell when I bought it). I took it into a muffler shop and fixed that.
-The A/C needed a charge, took care of that, The right rear turn signal socket was clapped out so soldered a new one on.

Now I have a new problem, where my dash light and tail lights are out. I’ve done a little research and I’ve concluded that it’s likely a connection issue, headlight dimmer issue, or a blown fuse. I’m wondering if me monkeying around with the turn signal could have caused this.

Besides that everything is great! The interior is pretty worn. Most of the knobs on the radio and such are missing, but all work. The passenger seats weren’t included so the cargo area is wide open. The paint is in great shape. The underside is also in great shape, very little rust. Drives and shifts great. The passenger exterior door handles don’t work but the driver door and back door handles work fine. The guy gave me 2 new handles that he hadn’t got around to installing.

I’m very excited to take this thing camping and to moped rallies. I’m not really planning on building it out, butI do have a few modifications in mind.
Car Automotive parking light Automotive side marker light Automotive side-view mirror Vehicle

Automotive side marker light Automotive parking light Wheel Car Automotive side-view mirror

Wheel Tire Automotive parking light Car Automotive side-view mirror

Automotive tire Motor vehicle Car Steering wheel Automotive design

Car Land vehicle Vehicle Window Fixture
 

·
Administrator
Common Sense + Critical Thinking
Joined
·
13,947 Posts
Welcome to the site Joel!

Nice score for $1500, everything can be fixed, and you should be able to find the information around here somewhere.

Might want to look into where your A/C is leaking as well, if it needed to be charged, there is a leak somewhere.

As far as your lights, is it just the IPC illumination lights that aren't working? In the back which all lights are working and which ones are not, like the marker lights, running lights, brake lights, license plate lights?

There are some links here for the digital FSM and some wiring diagrams if you need them(see links in sig).
 

·
Registered
Joined
·
72 Posts
Welcome !!
looks good and you got it for a great price !!
the interior panel your missing should be able to find at junkyard !

Are you planning on pulling a trailer for the moped or a hitch cargo trailer setup?
 

·
Registered
2004 Astro V6
Joined
·
148 Posts
Looks like an easy restore..good price!Apparently another Astro driver is moving into the junkyard as his second home..LOL! You shouldn't have to live there for long..;)..make a list of the small stuff and head out! I'm sure like all of us you'll forget something and have to make a second trip.("Really Honey..I do need that part I saw!" My first trip was spent buying goodies I didn't need...Oh well..more work.
 

·
Registered
GMC Safari Passenger Van SLE
Joined
·
7 Posts
Discussion Starter · #7 ·
Thanks for the warm welcome!
To answer your question @AstroWill, pretty much it’s just the light behind the speedo, and the rest of the gauges. The turn signal icons and everything seem to be lighting up fine. And then it’s looks like the rear running lights aren’t working as well as the back up beams. Rear turn signals and brake lights work fine. I also noticed that the radio screen only works when the light dial switch is in certain spots.
 

·
Administrator
Common Sense + Critical Thinking
Joined
·
13,947 Posts
Running/parking and BU lights are both on different circuits, front running/parking lights working fine? BU lights are controlled by the PNP switch on the transmission, would first check the bulbs/sockets. For the illumination lights it definitely could be the dimmer switch if it's only working in certain spots. Factory radio?
 

·
Registered
GMC Safari Passenger Van SLE
Joined
·
7 Posts
Discussion Starter · #9 ·
From what I've observed, only the headlights, front turn signals, rear turn signals, and brake lights work.

The radio is the factory radio yes.

This wasn't and issue when I bought it. The rear right turn signal was out so I went to put a fresh bulb in there only to find that the socket was in very rough shape. I wasn't able to rotate the bulb once pushed in the socket. I decided it was a good idea to just replace the socket. I snipped and stripped the wires and soldered on the new turn signal socket. It was only after that when I noticed the taillight/dash light issue.

I did do some monkeying around with the bulb while the car was running. I also messed with the tail light bulb and noticed that socket was pretty clapped out as well, I might have messed with it when the car was running, but I'm not sure. I was thinking it could be a fuse, but I'm not sure which fuse it is.

I noticed the BU bulb is a dual filament, what's the other filament used for?

I seen a lot of forum posts about this issue and a lot of people point to the dimmer switch. I have two questions about this:
1.) When you say dimmer switch do you mean the little dial and knob apparatus to the left of the wheel? Or do you mean the stick thing attached to the wheel?
2.) When people point this as an issue do they mean that it needs to be replaced or that I just need to pop it open and see if there's anything that looks disconnected? I've had trouble finding detailed descriptions of how to deal with said dimmer issue.

Thanks for the help!
 

·
Administrator
Common Sense + Critical Thinking
Joined
·
13,947 Posts
Definitely check all of your fuses, they are listed in the owners manual, service manuals, wiring diagrams, etc.

I'm talking about the dimmer, the little dial next to the headlight switch, definitely check everything else first.

The BU bulb is a single filament bulb, or is supposed to be. Double check that you have the correct bulbs installed at the proper locations.
 

·
Registered
GMC Safari Passenger Van SLE
Joined
·
7 Posts
Discussion Starter · #11 ·
Hahaha… looks like I was checking the wrong fuse the whole time… for anyone with this issue in the future it was breaker 9 on the inside fuse box. Looks like it’s back to normal. Thanks!
 

·
Administrator
Common Sense + Critical Thinking
Joined
·
13,947 Posts
Hahaha… looks like I was checking the wrong fuse the whole time… for anyone with this issue in the future it was breaker 9 on the inside fuse box. Looks like it’s back to normal. Thanks!
Thanks for replying with your solution. Glad to hear you got it working and that it was something simple :)
 
1 - 12 of 12 Posts
Top