Chevy Astro and GMC Safari Forum banner

Fuep pump has power but dioesn't run

508 Views 13 Replies 6 Participants Last post by  ehbrown1
Not your typical 'old pump', but old one and new one. I've read much here on the subject but can't find a problem like mine hence the new post. 2003 Safari RWD passenger van.

First some background: The van started and drove fine but overheated. I did the head gaskets etc, but not all at once. I bolted torqued the heads and rockers, but money, health, and general crap stopped me at that point. The tank showed below empty on the guage and stayed that way as it sat. Now 3 years later I need it as my big van is nearly dead, so I finished everything except the belt, fan, and shroud since I need to replace the heater control valve and wanted access. On the "big day" it turned over fine but no run. Thinking I had the pancake 180 degrees out I turned it around- still no go. I checked spark at the coil- hot spark. I'm thinking "must be fuel related" so i shot carb cleaner in the intake and still no go. Rechecking everything for the unpteenth time I put the pancake back, hit the carb cleaner again and now she runs again- YAAAY! But only tlll the carb cleaner is done. I pressed in on the schrader valve on the fuel rail- nothing. I swapped the A/C and fuel pump relays- nothing. I put the test light to the relay and have voltage across the electromagnet plus power into the relay. Not a sound at the tank even after banging on it. I check for power there and get the 2- second 'prime' cycle then power drops out. Ground shows continuity there. Still no running fuel pump even with more banging during the prime cycle so I figured the fuel pump went bad while it sat. I just replaced the pump (will do a write-up on the floor cutting as my 2003 was a bit different than what I found) and am still not getting a running pump. I tied in a solid outboard jumper to ground and ran a hot straight from the battery to the pump- still nothing. It's a "Precision" cheapo pump as that's all I had money for and I'll drop a GM in there ASAP. Had to swap harness connections as per the instructions. triple checked those for color and good connection at the butt terminal joins. Swapped relays and jumped relay power out again just in case and still no running pump, not even for prime even with banging on it.

The only in-tank GM pump I have experience with was on my old Buick many years ago. As best I remember it had only 4-5 wires; this one has 4 to the pump connector and 3 to another connector. I can't see why so many- two for pump and two for gauge makes sense, more doesn't. I don't know what the extra wires do so I'm stuck. I absolutely have to have this van running in 5 days or I lose job, home, and everything else even if I have to straight-wire the pump through a switch but I can't even figure out how to do that. It would be nice to have it work as it's supposed to but for now all I need is some way to make the fuel pump run. I'll deal with the flat spot on my forehead from banging it into the wall all day myself- I KNOW how to handle that!

Thanks in advance,
See less See more
1 - 2 of 14 Posts
I've seen butt-splice connections (with aftermarket) fail.
Or the "new" pump has failed.
Darn glad I cut the floor instead of dropping the tank to do this one.
  • Like
Reactions: 2
1 - 2 of 14 Posts