Chevy Astro and GMC Safari Forum banner
1 - 20 of 80 Posts

·
Premium Member
Joined
·
6,388 Posts
Discussion Starter · #1 ·
Moderators/admin please feel free to put the other posts about this into this thread.
I started with a rear drive 89 Astro RS, I added a 350 from a 91 silverado. Now I am taking the frame, front differential
from a 1998 AWD cargo van I bought for 400 cash. Luckily the 98 has the same gear ratio as my 89 rear axle so I do not need the axle from the 98. I sold the engine for 100, the trans for 100 and various other parts for about 100. So I have the frame, front differential, transfer and front suspension. The 98 had new shocks all around so I got them too.
I did a lot of reading and asking questions possibly some of the same questions more then once lol. I had to buy a special oil pan to fit this frame with my 350 V8. I also had to buy a different transmission to transfer adapter because I am using a 700R4 instead of the 98 4l60E. I also bought an add a leaf and the 6 each 2" body lift pucks. I have no idea what they are called now but years ago they called them pucks. I am using the stock 98 driveshafts for now with the factory transfer case for AWD but I plan on swapping it for a 233C in the future. I removed all the wiring and brake lines from the 98 frame since I will be using the braking system from the 89 for simplification. I already had the steel leaf springs from a 2000 Astro installed on my Astro so that part is done. I will update this as I go.
 

·
Premium Member
Joined
·
6,388 Posts
Discussion Starter · #3 ·
The 89 Body sitting on the 98 frame with 2 inch body lift and a sticker I had made for the van. Also 1 pic of the 2 wd drive frame prior to being stripped.

I figured out the power steering lines are the same thread so those are done and the brake lines are the same thread also so I will have to make one to three lines since the frames are shaped different. I will figure out what I will have to make or at least bend tomorrow weather permitting. The rear drive frame has the brake line crossing on the crossmember beneath the engine oil pan but the AWD frame it crosses in the front right behind the bumper so I will try to use the original brake line but I don't think it will work.
 

Attachments

·
Premium Member
Joined
·
6,388 Posts
Discussion Starter · #5 ·
I did encounter a potential problem that I will have to figure out: the 98 came with a totally different system for the shifting of the transmission. The 1st gen vans have a mechanical armature that attaches to the steering column and then down to the frame then to the transmission. The 2nd gen van used a cable of sorts. I may have to go back to a floor shift like I had before. I will post what I come up with when I figure out how to do it. I can't use the system from the 98 since my transmission is a 91 700R4.
 

·
Registered
Joined
·
713 Posts
When I was looking at the cable shift trans (not very long or paying attention to detail) it looked like you could just undo the nut holding the shifter connection on and replace with the linkage connection from the 1st gen.
 

·
Premium Member
Joined
·
6,388 Posts
Discussion Starter · #8 ·
I did something stupid lol I was kinda rushing getting the AWD frame ready and I cut all the cables and brake lines to just get them out of my way. Its all good I will just have to redo the console I built to fit the hurst shifter I had in the van in the past and put it back in. No big deal to me since I already own the shifter. I remember there was a member that posted a console he got from a ford I think and put a floor shift in it where the original shifter (ford) was and I believe he used a mega shifter. But I can't find the post. I may just start searching pick n pull vehicles till I find one that suits me. As for the brake lines I will just buy new lines and bend them then paint them and install them its pretty simply stuff.
 

·
Registered
Joined
·
1,121 Posts
When I did my V8 swap (on my old 85 panel van) I used a B&M shifter, and cut a hole in the floor where the factory would have cut for a floor shifter. It was kind of close to the seat, but worked just fine. It was also a cable shifter with a very long cable attached to it. I think I got it from Summit for 100 bucks. Sorry no pics of it though.
 

·
Premium Member
Joined
·
6,388 Posts
Discussion Starter · #11 ·
OK so I got the adapter that was incorrect to work by cutting a ring out of the inside. After that it lined right up. Today I took the 700R4 apart and removed the rear drive output shaft and slide the AWD shaft in to its place. Tomorrow I will finish up cause my transmission was not shifting properly so I need to look into what could be the cause. I also noticed the inner tie rod end on the passenger side is missing the boot. I know I can just replace the boot but for 20 bucks I may as well just replace it. Project is moving right along, not much for REAL problems as of yet just little stuff like misplacing things lol.I am thinking of replacing the rear springs with the S-10 springs to match the 2" body lift instead of working with the steel springs I already installed a few years ago.
I replaced the rear main seal and oil pan gasket since I am swapping oil pans anyway.
 

·
Banned
1992 Astro - Silver / Gray / 4 Wheels
Joined
·
5,327 Posts
I think I see that shaft... under the jacket... right there...
... See you been to the "chevymaher garage box / organization / shelving system course".

Think you'll need AWD/4WD/4X4 in Texas too? Desert / Mountain climbing instead of Blown Snow.
 

·
Premium Member
Joined
·
6,388 Posts
Discussion Starter · #14 ·
My van will be in New Hampshire when its done, When we go to Texas we will possibly get a little car to keep there just to get around.The sticker was just me playing around.
 

·
Registered
Joined
·
1,121 Posts
Seeing that reminds me of the old V8 Vega days. I modified a few pans back in the day. Had a few V8 Vegas too. ;)
 

·
Premium Member
Joined
·
6,388 Posts
Discussion Starter · #20 ·
So a few years ago I rebuilt my 700R4 and I never did figure out why the reverse was out. However I took it apart again to swap the output shaft to make it AWD. So I found one valve that was stuck, so I tried to get it out and it came out in two pieces. One piece is still stuck in the valve body. Not sure if this is common but I will have to get a non screwed up one to finish this. Mark
 
1 - 20 of 80 Posts
Top