Chevy Astro and GMC Safari Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
someone gave me an 2002 astro van the body is in good condition but it will not start; it is getting fuel even the spider is spitting, getting spark but will not start i am thinking maybe timming chain
 

·
Registered
1998 LS AWD Forest Green metallic
Joined
·
1,105 Posts
You have fuel and spark, but do you have god spark and at the correct time?
I certainly would not think timing chains without a lot more diagnosis. The 4.3 is not known for an issue with timing chains.
Just having an obvious spark does not mean it is getting to the correct plug at he correct time. Have you tried a shot of starting fluid in the intake? Low fuel pressure could keep it from starting, even though you seemingly have fuel at the spider.
Check for the notorious bad distributor problem, and if it appears to be good, then a new cap and rotor would be worth the expense. If it is not needed now, you will have a spare when you do need it.
Since you have never had it running, do you know much of anything of it's history?
A compression test should be high on the list on a No Start with an unknown history. If it comes out poorly, it might be a timing chain problem, but I would still bet against it. You will also know the condition of the plugs buy then.
Other will be along shortly with additional offerings

Rod J
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
You have fuel and spark, but do you have god spark and at the correct time?
I certainly would not think timing chains without a lot more diagnosis. The 4.3 is not known for an issue with timing chains.
Just having an obvious spark does not mean it is getting to the correct plug at he correct time. Have you tried a shot of starting fluid in the intake? Low fuel pressure could keep it from starting, even though you seemingly have fuel at the spider.
Check for the notorious bad distributor problem, and if it appears to be good, then a new cap and rotor would be worth the expense. If it is not needed now, you will have a spare when you do need it.
Since you have never had it running, do you know much of anything of it's history?
A compression test should be high on the list on a No Start with an unknown history. If it comes out poorly, it might be a timing chain problem, but I would still bet against it. You will also know the condition of the plugs buy then.
Other will be along shortly with additional offerings

Rod J
i did a compression test 175 on the right bank 115-120 0n the left bank that when i decided to pull the heads. intake gasket in bad shape upper intake wet and oily lower intake gasket gone around no1. pull timming cover a little slack in chain tomorrow i am going to drop the pan. at this point maybe a rebuild or another moter van has over 200000 miles what do u think
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
i did a compression test 175 on the right bank 115-120 0n the left bank that when i decided to pull the heads. intake gasket in bad shape upper intake wet and oily lower intake gasket gone around no1. pull timming cover a little slack in chain tomorrow i am going to drop the pan. at this point maybe a rebuild or another moter van has over 200000 miles what do u think
this is my first time with astro what distributor problem famus for expan on this for me
 

·
Registered
1998 LS AWD Forest Green metallic
Joined
·
1,105 Posts
Sure, put 'Pancake distributor disease' in the search box.
The very common issue is a very badly worn drive gear on the lower end of the shaft.
Rod J
 

·
Registered
1998 LS AWD Forest Green metallic
Joined
·
1,105 Posts
someone gave me an 2002 astro van the body is in good condition but it will not start; it is getting fuel even the spider is spitting, getting spark but will not start i am thinking maybe timming chain
You began saying the above, apparently looking for advice. But apparently you already did a compression test and took the heads off. It would have been helpful to have given all that information in the beginning. IT is difficult to offer suggestions on a 'No Start', problem when the motor is apart.
Have fun :confused:
Rod J
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
You began saying the above, apparently looking for advice. But apparently you already did a compression test and took the heads off. It would have been helpful to have given all that information in the beginning. IT is difficult to offer suggestions on a 'No Start', problem when the motor is apart.
Have fun :confused:
Rod J
i posted this late afternoon no replay so next day went to work that night late got replay in other words the communication was laging the work i appoligy i am new it this sorry
 

·
Registered
01 Astro RWD Cargo, 97 AWD Mark III
Joined
·
2,210 Posts
Fast replies not guaranteed accurate. Accurate replies not guaranteed fast!
 
1 - 9 of 9 Posts
Top