Chevy Astro and GMC Safari Forum banner
1 - 10 of 10 Posts

·
Super Moderator
05 Astro AWD
Joined
·
14,157 Posts
That one is the only one with a part number and it's the only one that's plastic.

For all else, you buy a chunk of 'windshield washer line' at your LAPS (usually in a box or plastic snap thing with a few feet), then snip what you need. 7/16" rings a bell, but double-check.
 

·
Super Moderator
05 Astro AWD
Joined
·
14,157 Posts
Battery cable. Grounds to core support.
 

·
Super Moderator
05 Astro AWD
Joined
·
14,157 Posts
No. It plugs into the front of the canister that the PCV hose plugs into.

The barb pointed up, here:


Which goes in the big, round empty hole at the driver's side front of the intake plenum
 

·
Super Moderator
05 Astro AWD
Joined
·
14,157 Posts
No. Your '03 only has one.
 

·
Super Moderator
05 Astro AWD
Joined
·
14,157 Posts
Awesome. Unfortunately, sometimes you do get what you pay for...
 

·
Super Moderator
05 Astro AWD
Joined
·
14,157 Posts
Several guys have had the MAF go bad. At least one more has had the MAF wiring harness go bad. Quickie test is to disconnect the MAF and see if the van runs better in regular driving. If it does, the MAF probably has outlived its useful life.

I got P0101 when my cat was plugged. As soon as I got ignition and fuel straightened out and replaced the cat, all was well.
 

·
Super Moderator
05 Astro AWD
Joined
·
14,157 Posts
The old-style PCV valve isn't supposed to be in there. That's the new-style valve that doesn't need to be replaced.
 

·
Super Moderator
05 Astro AWD
Joined
·
14,157 Posts
I don't give a flying F what color you are, what gender you identify with, what whatever. I care how you treat people, I care how you treat animals, and I care how you treat vehicles. Period.

Don't care for anyone named Karen, don't care for anyone nicknamed Karen.

I do, however, care that you're running a van with a coil (or any other ignition component) from the factory with well over 17 years on it. That's just not smart. Ain't nuttin' running like it was from the factory with over 15 years of heat and cold on it. Think about it.
 

·
Super Moderator
05 Astro AWD
Joined
·
14,157 Posts
Without checking anything, the RPMs seem really high for 62mph. They're high for 72mph, really.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top