Chevy Astro and GMC Safari Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I have a 99 Astor with 174k on the clock. I am having issues with my shift indicator not working at all the screen is black. Sometimes it works like when I first start the van it works. But you shut it off and restart it won't come back on most of the time. I have replaced the neutral safety switch and also replaced the seal that goes between the trans and driveshaft it was dripping trans fluid. I can't figure out the shift indicator screen the first time it went out my trans shifted hard and acted like it's slipping but it's fine never got hot or low on fluid. When the indicator works drives like a dream when it doesn't it acts like an unresponsive turd. Any help at all would be helpfull. Also have taken dash apart and removed cluster seemed fine just didn't take the cluster apart to look inside. Would love to fix this problem this van is,awesome gets around better than my chevy silverado 01 lol it's the best camping van ever built would hate to have to get another van. Any help at all would be much appreciated :ty:
 

·
Administrator
Common Sense + Critical Thinking
Joined
·
14,451 Posts
If the PRNDL indicator was simply not showing, I would guess it was the dimmer controls. But if you are having an issue with shifting at the same time, then I would think wiring/ground issue.
 

·
Registered
Joined
·
1,547 Posts
This is a known problem, and has a fairly simple repair. See my post about it here;

 
1 - 5 of 5 Posts
Top