Chevy Astro and GMC Safari Forum banner
1 - 20 of 61 Posts

·
Registered
1995 gmc safari rwd.
Joined
·
41 Posts
Discussion Starter · #1 ·
95 safari v6, it shakes a lot when in gear and waiting at the light with brakes on. does not shake when in neutral or in park. already replaced both motor mounts and tranny mount. any thoughts? thanks.
 

·
Registered
Joined
·
5,796 Posts
Need more info, misfires? runs smooth? when does it shake? in gear? under load? all the time?

 

·
Registered
1995 gmc safari rwd.
Joined
·
41 Posts
Discussion Starter · #4 ·
I dont remember where ive got the mounts from, i think they were like generic ones, not oem.
The oem onea from autozone did not have the tabs.
It runs smooth, delivers power when needed, no engine light. But like when im waiting for the light to go green, it shakes a lot. Does not shake while driving unless i hit like 60mph.
Thanks.
 

·
Administrator
Common Sense + Critical Thinking
Joined
·
14,037 Posts
There are a TON of things that can cause a rough idle. How many miles, when was the last time a tune-up was done? What do your spark plugs look like, fireworks/water mist test on the spark plug wires, cap/rotor in good condition?
 

·
Registered
Joined
·
12 Posts
There are a TON of things that can cause a rough idle. How many miles, when was the last time a tune-up was done? What do your spark plugs look like, fireworks/water mist test on the spark plug wires, cap/rotor in good condition?
hi. van has 147k miles i just did a full tune up. replaced wires and spark plugs looked fine (replace em too)
i'm gonna replace the rotor next.
 

·
Super Moderator
05 Astro AWD
Joined
·
14,158 Posts
Have you ever looked and and cleaned the EGR? How about the IAC?
 
  • Like
Reactions: kenk

·
Registered
1995 gmc safari rwd.
Joined
·
41 Posts
Discussion Starter · #11 ·
Need more info, misfires? runs smooth? when does it shake? in gear? under load? all the time?

does not misfire, if u take away the shaking, yeah it runs smooth, power is on point when needed. yeah, the shaking is worst when in gear. it does shake all the time but it gets worse when in gear.

i call it the "parkinson" van.

joking aside, i've been doing some research and a lot of people have the same issue as well, feels like it is like a common issue with this vans, i guess it is what it is. sucks tho.
 

·
Administrator
Common Sense + Critical Thinking
Joined
·
14,037 Posts

·
Registered
1995 gmc safari rwd.
Joined
·
41 Posts
Discussion Starter · #14 ·
So ive found out that it is missfiring and it does not have the crack position sensor, its just missing. So ive got the sensor but i can not find the connector for it.
 

·
Super Moderator
05 Astro AWD
Joined
·
14,158 Posts
It’s a ‘95. I don’t think they had one, except for the very late ‘95s that are OBD II.
 

·
Registered
2000 Lifted 4x4 Astro 92 V8-350 Shorty
Joined
·
5,998 Posts
O2 won't usually cause misfiring... (but I could be wrong)
Shaking at idle is not the same as misfiring
 

·
Registered
1995 gmc safari rwd.
Joined
·
41 Posts
Discussion Starter · #19 ·
Forgot to mention, there is no engine light on.
Its driving me insane lol
Im seriously considering just getting another one and drive this one down a cliff.
 
1 - 20 of 61 Posts
Top