Climate control does nothing

Climate control does nothing

Postby Xmayakartoum [OP] » April 3rd 2021, 3:49pm

Hi, I have a strange problem with my climate control. Here is the first thing what happend is that all was working fine exept that when you put the speed of the blower motor on 1 nothing happend, the second and full power worked but the blower motor made a ratling sound. So i changed the blower motor and then it became smooth and blowing fine. Except on low speed no air but on second and full blowing good. O yeah rear AC always worked fine.
Changing vents position is not working only window defrost, wich i presume that these are the vacuum lines that are briddle of broke.

Next day i started the van and now nothing works. No fan blowing at any position, the rear window defrost button not working, and the rear AC doing nothing.
Could it be that it is a fuse or a relay? or is it the climate control module that is malfunction? I have no clue so does anyone had this problem or maybe have some tips for me to try of look at. Thanks
Original Poster [OP]
Xmayakartoum
Fueling (Empty tank)
Fueling (Empty tank)
Posts: 2
Topics: 1
Joined: April 2021
Gender: Male
Alias (AKA): Xmaya
Van Model Year: 2003
Van Make/Model: Chevrolet Astro
Extra Info: 4.3L V6 RWD

  • Similar topics
    Replies
    Views
    Author

Re: Climate control does nothing

Postby sixsix » April 3rd 2021, 9:40pm

Xmayakartoum wrote:Climate control does nothing...

At least not the "Human Kind of Control".
.

I Love Peaches also & Wolverines and Gophers
User avatar
sixsix
Firing on 8 Cylinders (L5)
Firing on 8 Cylinders (L5)
Years of Membership: sixsix has been a member for 6 full yearssixsix has been a member for 6 full yearssixsix has been a member for 6 full yearssixsix has been a member for 6 full yearssixsix has been a member for 6 full yearssixsix has been a member for 6 full years
Posts: 4819
Topics: 39
Images: 1342
Joined: May 2014
Location: Edgewood, Northern Ky.
Gender: Male
Alias (AKA): Mike
Van Model Year: 1992
Van Make/Model: Chevrolet Astro
Extra Info: LT W CPI - RWD 200K

Re: Climate control does nothing

Postby AstroWill » April 3rd 2021, 10:03pm

Xmayakartoum wrote:Changing vents position is not working only window defrost, wich i presume that these are the vacuum lines that are briddle of broke.

Exactly, see the sticky in this section.

Xmayakartoum wrote:Next day i started the van and now nothing works. No fan blowing at any position, the rear window defrost button not working, and the rear AC doing nothing.
Could it be that it is a fuse or a relay? or is it the climate control module that is malfunction? I have no clue so does anyone had this problem or maybe have some tips for me to try of look at. Thanks

Yep, probably blew fuse 12 under the dash.

Trolls take away from productive work, best to ignore & go about your business. See: Dark Tetrad
Report terrorists and anyone inciting violence to FBI @ fbi.gov and 800-CALLFBI (225-5324)
User avatar
AstroWill
Technical Director
Technical Director
Firing on 8 Cylinders (L7)
Firing on 8 Cylinders (L7)
Years of Membership: AstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full years
Posts: 11732
Topics: 108
Images: 473
Joined: February 2009
Alias (AKA): Critical Thinking+Common Sense
Van Make/Model: Chevrolet Astro
Extra Info: I love peaches

Re: Climate control does nothing

Postby Xmayakartoum [OP] » April 4th 2021, 7:56pm

Hi, Yes the fuse under the dash was blown. Changed it and "worked" like before. So now ac rear works, defrost works and blower fan works, but only on middle and full power. Low and second one does not work. Could it be that the blower motor resistor is the cause of this?
Next step will be changing the vacuum lines to change the vents. They are not norking only on defrost.
Original Poster [OP]
Xmayakartoum
Fueling (Empty tank)
Fueling (Empty tank)
Posts: 2
Topics: 1
Joined: April 2021
Gender: Male
Alias (AKA): Xmaya
Van Model Year: 2003
Van Make/Model: Chevrolet Astro
Extra Info: 4.3L V6 RWD

Re: Climate control does nothing

Postby Walleyehunter » April 8th 2021, 1:09am

Very well could be. Pull the washer fluid reservoir. Test light the harness while switching speeds. Just replaced my resistor board because I had no high blower. That is the orange wire. When you remove the board you’ll see it’s pretty well toast. Ordered a Delco replacement off Amazon. You have to nip the 4 plastic pins off the back of it to fit it back in the hole. You’ll see.
Walleyehunter
Fueling (Empty tank)
Fueling (Empty tank)
Posts: 1
Joined: January 2021
Alias (AKA):
Van Model Year: 1998
Van Make/Model: Chevrolet Astro
Extra Info: LT 4.3L V6 RWD

Re: Climate control does nothing

Postby AstroWill » April 8th 2021, 5:22am

Xmayakartoum wrote:Hi, Yes the fuse under the dash was blown. Changed it and "worked" like before. So now ac rear works, defrost works and blower fan works, but only on middle and full power. Low and second one does not work. Could it be that the blower motor resistor is the cause of this?

Most likely, pretty easy to check at the connector.

Xmayakartoum wrote:Next step will be changing the vacuum lines to change the vents. They are not norking only on defrost.

Common issue, see the sticky in this section.

Trolls take away from productive work, best to ignore & go about your business. See: Dark Tetrad
Report terrorists and anyone inciting violence to FBI @ fbi.gov and 800-CALLFBI (225-5324)
User avatar
AstroWill
Technical Director
Technical Director
Firing on 8 Cylinders (L7)
Firing on 8 Cylinders (L7)
Years of Membership: AstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full yearsAstroWill has been a member for 12 full years
Posts: 11732
Topics: 108
Images: 473
Joined: February 2009
Alias (AKA): Critical Thinking+Common Sense
Van Make/Model: Chevrolet Astro
Extra Info: I love peaches


 
  • Related topics
    Replies
    Views
    Last post

Return to Climate Control

It is currently April 14th 2021, 5:45am

Climate Control Forum
Climate ControlTopics regarding the climate control in the cabin of the van. Discuss things like air conditioning, refrigerant recharging, and dual climate controls, a/c vents, accumulator or defrosters, heater core, or fan inside the van.
To create a new topic in Climate Control, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
AOTD
in Climate Control
Views: 166
Comments: 4
Date: Feb 27 '21
Time: 10:05pm
» Read last comment
Attached by:
AOTD
in Climate Control
Views: 153
Comments: 2
Date: Feb 27 '21
Time: 9:31pm
» Read last comment
Attached by:
Attached by: Toskavat
Toskavat
in Climate Control
Views: 329
Comments: 17
Date: Feb 26 '21
Time: 4:13pm
» Read last comment
Attached by:
Sailing_Faith
in Climate Control
Views: 355
Comments: 12
Date: Feb 18 '21
Time: 9:05pm
» Read last comment
Attached by:
Attached by: sixsix
sixsix
in Climate Control
Views: 1263
Comments: 15
Date: Feb 17 '21
Time: 2:47pm
» Read last comment
Sponsors

Who is online

Users browsing this forum: No registered users and 10 guests