Switch to full site
Hello and welcome to the best and original home for Astro & Safari owners. Please introduce yourself to the community and make yourself at home. Tell us about yourself and post your introductions and welcome messages here.

Forum rules

Please do not post support requests in the new members lounge! This forum is for new member introductions and assistance only. Please post other topics in their appropriate areas so they stay categorized.
Post a reply

New to Site

September 5th 2016, 5:21pm

Hi guys,

My name is Luke, I am new to the site. I am currently living in Stillwater MN and would love to meet some other Astro fans in the Twin Cities! I recently just picked up an 02 Astro LT AWD with 180k on it. I found it with high mileage but the damn thing has only been through 2 previous owners and garaged it's whole life. Planning on turning this van into a camping rig!!

The good;
Very little body rust
Limited frame rust
Newer exhaust
Tight front end ie; Links, Sways, bearings
Newer Brakes
good glass
solid drive shaft
suspension is good
new battery
Clean Fluids

The bad;
intermittent squeaking noise coming from either Tension pulley or Fan Clutch
Needs new AWD Transfer Case Motor
some leakage of oil/fluids from underneath might need a good pressure wash to diagnose leak
Drivers side door needs to be re set on pins, does not seal all the way shut.
Drivers side door interior is a little rough/cracked.

Re: New to Site

September 6th 2016, 2:16am

Welcome to the site. Good luck with your conversion and as I always say, "never ever use the handle mounted on the dash that's on the passenger side."

Re: New to Site

September 6th 2016, 3:12am

welcome to the forum and good luck on your project and oh by the way we love pictures here. take your belt off and check the pulleys the squeak could be a pulley bearing or alternator or any one of the pulleys.The door may be that your door striker needs to be adjusted.

Re: New to Site

September 6th 2016, 3:31am

Welcome!

Did the guys mention photos? We love photos here.

It is possible it's the belt or tensioner, but as Mark said, it's more likely the idler pulley or alternator bearing. If you loosen the belt and spin each by hand, you'll hear/feel it.

Re: New to Site

September 6th 2016, 5:28am

Hi and welcome. I replied to your other thread about the AWD issue. Hope you get the van the way you want it without any headaches!
-M!ke-
Post a reply