High idle that cycles on 1995 4.3

High idle that cycles on 1995 4.3

Postby ducsunlimited [OP] » October 18th 2018, 6:26pm

Hello all.

First post here. I inherited a single owner, 320k mile, 1995 Astro LT 4.3 rwd from my father. Issue is ridiculously high idle, that will kick down as described below.

Van will chirp the tires when going into gear and it will cruise at 60mph on the highway. I've replaced the IAC, PCV and related lines, and checked the resistance of the coolant temp sensor (good) and done a smoke check for vacuum leaks. The plastic vacuum line though the firewall to the hvac controls was leaking as most do, but I've disconnected and plugged that for now at the T junction by the check valve. What makes it seems different (to me) than a simple vacuum leak is that the engine will cycle down to a normal idle, or even lower, if I let it top out its speed in a lower gear. For example, if I just drive it in first gear, it will accelerate to about 25mph with the engine racing then once it tops out at a high rpm it will kick down with strong engine braking, like the IAC valve slams shut until the engine slows down sufficiently, then the IAC will open back up and the van will accelerate, repeating this over and over like a drunken sailor. Any ideas what could causes the IAC to shut like that and reopen (assuming that is what is happening)? Is that an indication that the issue is in the electronic bits, or is there possibly a vacuum leak that I just haven't found and the electronics are just doing their job to compensate. All help appreciated. The damn thing isn't safe to drive as is. thx. Also username is based on unhealthy obsession with italian motorcycles.
Original Poster [OP]
User avatar
ducsunlimited
Fueling (Empty tank)
Fueling (Empty tank)
Years of Membership: ducsunlimited has been a member for 2 full yearsducsunlimited has been a member for 2 full years
Posts: 4
Topics: 1
Joined: October 2018
Alias (AKA):
Van Model Year: 1995
Van Make/Model: Chevrolet Astro
Extra Info: LT 4.3L

  • Similar topics
    Replies
    Views
    Author

Re: High idle that cycles on 1995 4.3

Postby MechBob » October 18th 2018, 10:10pm

Possible bad TPS.If you do not have a scan tool,unplug it,start it up an drive,see what it does.
User avatar
MechBob
Firing on 2 Cylinders (L2)
Firing on 2 Cylinders (L2)
Years of Membership: MechBob has been a member for 2 full yearsMechBob has been a member for 2 full years
Posts: 1227
Topics: 11
Images: 12
Joined: August 2018
Gender: Male
Alias (AKA): Bob
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: 4x4

Re: High idle that cycles on 1995 4.3

Postby ducsunlimited [OP] » October 19th 2018, 5:35pm

I unplugged TPS and drove it. I had to take off snorkel to get to it. I replugged in the intake air temp sensor on the snorkel and tied up the snorkel out of the way, so I had no snorkel on when I drove it it for this experiment.

it ran even higher at idle, but was sluggish as i floored it. so the tps seems to be doing something. bob, what were you expecting it to do?
Original Poster [OP]
User avatar
ducsunlimited
Fueling (Empty tank)
Fueling (Empty tank)
Years of Membership: ducsunlimited has been a member for 2 full yearsducsunlimited has been a member for 2 full years
Posts: 4
Topics: 1
Joined: October 2018
Alias (AKA):
Van Model Year: 1995
Van Make/Model: Chevrolet Astro
Extra Info: LT 4.3L

Re: High idle that cycles on 1995 4.3

Postby MechBob » October 19th 2018, 8:52pm

With the TPS unplugged,it would drop into backup mode,it would run sluggish,but idle would be fairly normal.So,other than the last code set(tps) what other codes are being set?Before I would go further,need to put a scan tool on it,possible wiring problem ,possibly in the sensor circuit of the IAC,to the PCM.
User avatar
MechBob
Firing on 2 Cylinders (L2)
Firing on 2 Cylinders (L2)
Years of Membership: MechBob has been a member for 2 full yearsMechBob has been a member for 2 full years
Posts: 1227
Topics: 11
Images: 12
Joined: August 2018
Gender: Male
Alias (AKA): Bob
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: 4x4

Re: High idle that cycles on 1995 4.3

Postby ducsunlimited [OP] » October 20th 2018, 5:41am

I don't have an obd1 reader, but reading blinks shows:

22 TPS voltage low
35 IAC circuit
44 02 circuit lean exhaust detected.
Original Poster [OP]
User avatar
ducsunlimited
Fueling (Empty tank)
Fueling (Empty tank)
Years of Membership: ducsunlimited has been a member for 2 full yearsducsunlimited has been a member for 2 full years
Posts: 4
Topics: 1
Joined: October 2018
Alias (AKA):
Van Model Year: 1995
Van Make/Model: Chevrolet Astro
Extra Info: LT 4.3L

Re: High idle that cycles on 1995 4.3

Postby MechBob » October 21st 2018, 12:08am

Code 35 will set when the PCM sees a different reading in desired IAC and actual IAC.So,I can only think of 3 issues,bad IAC,PCM problem,or(most likely) a wiring problem between PCM and IAC.Unplug the PCM and look for corrosion on the terminals,and check the wiring.
User avatar
MechBob
Firing on 2 Cylinders (L2)
Firing on 2 Cylinders (L2)
Years of Membership: MechBob has been a member for 2 full yearsMechBob has been a member for 2 full years
Posts: 1227
Topics: 11
Images: 12
Joined: August 2018
Gender: Male
Alias (AKA): Bob
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: 4x4

Re: High idle that cycles on 1995 4.3

Postby ducsunlimited [OP] » November 18th 2018, 9:13pm

Quick update on this. SO it was the upper plenum gasket. I replaced it and van now runs like a champ!

Diagnosis: I started the van and put my hand over the throttle body to seal it off and the van kept running. I did a second smoke test this time with the throttle body taped off and pushing smoke in with my homemade mason jar/soldering iron/mineral oil/bike pump smoke machine through a vacuum port on the backside of the plenum and smoke came pouring out of a two inch long section of the upper gasket interface. Not sure how i didn't catch that before. BUT now i'm super curious of why the "drunken sailor" cycling i reported in the first post. Any ideas what could have made it do that?
Original Poster [OP]
User avatar
ducsunlimited
Fueling (Empty tank)
Fueling (Empty tank)
Years of Membership: ducsunlimited has been a member for 2 full yearsducsunlimited has been a member for 2 full years
Posts: 4
Topics: 1
Joined: October 2018
Alias (AKA):
Van Model Year: 1995
Van Make/Model: Chevrolet Astro
Extra Info: LT 4.3L

Re: High idle that cycles on 1995 4.3

Postby Leeann_93 » November 19th 2018, 11:59pm

If there's a condition that the IAC can't correct for, the computer can tell it to do some weird **** because the computer can get confused.

I'd put the cycling down to computer confusion due to weird inputs. You know, GIGO (garbage in, garbage out).
'05 Astro AWD vin X
'02 Astro LS AWD vin X
'00 Astro LS AWD - WIP
'99 Safari XLE AWD - broke
'93 AWD EXT vin W - real broke
User avatar
Leeann_93
Team Leader
Team Leader
Firing on 8 Cylinders (L7)
Firing on 8 Cylinders (L7)
Years of Membership: Leeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full years
Posts: 13575
Topics: 44
Images: 17
Joined: December 2008
Location: MD
Gender: Female
Alias (AKA):
Van Model Year: 2005
Van Make/Model: Chevrolet Astro
Extra Info: LS AWD


 
  • Related topics
    Replies
    Views
    Last post

Return to Engines

It is currently December 5th 2020, 10:25am

Engines Forum
Engine Repairs, Modifications, Diagnostics, Tuning, Upgrading, Questions.

<a href="https://ad.doubleclick.net/ddm/trackclk/N8334.275400VERTICALSCOPEINC./B20209277.204028354;dc_trk_aid=407011718;dc_trk_cid=94070067;dc_lat=;dc_rdid=;tag_for_child_directed_treatment="target="_blank"><img src="https://tpc.googlesyndication.com/pagead/imgad?id=CICAgKDrrqWwMRCAARgcKAEyCN4sAjjtai4k" border="0" align="right">
<IMG SRC="https://ad.doubleclick.net/ddm/trackimp/N8334.275400VERTICALSCOPEINC./B20209277.204028354;dc_trk_aid=407011718;dc_trk_cid=94070067;ord=;dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?" BORDER="0" HEIGHT="1" WIDTH="1" ALT="Advertisement">
Moderator: chevy57bert
To create a new topic in Engines, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
Attached by: icebrrg3rd
icebrrg3rd
in Engines
Views: 200
Comments: 7
Date: Dec 01 '20
Time: 12:16am
» Read last comment
Attached by:
djpigs
in Engines
Views: 1154
Comments: 42
Date: Nov 26 '20
Time: 11:23pm
» Read last comment
Attached by:
Attached by: Leeann_93
Leeann_93
in Engines
Views: 200
Comments: 7
Date: Nov 26 '20
Time: 12:43am
» Read last comment
Attached by:
Attached by: Slime
Slime
in Engines
Views: 200
Comments: 7
Date: Nov 24 '20
Time: 11:11pm
» Read last comment
Attached by:
K-TRON
in Engines
Views: 589
Comments: 23
Date: Nov 16 '20
Time: 1:07am
» Read last comment
Sponsors

Who is online

Users browsing this forum: Google Adsense [Bot] and 16 guests