ASTROVAN starts but not power

ASTROVAN starts but not power

Postby Francisco2003 [OP] » July 19th 2020, 7:14pm

2003 astro van 224,000 miles engine start and run up to 20 miles and hour and lose power I am able to run the van up to 20 miles and hour and lost power after all can not get to hills not power enough to reach the hill after 30 minus on the road start taking time to star running to reach the 20 miles and hour I change apart plugs cables distributor fuel filter check the fuel pump is working right any idea what can be wrog?
Original Poster [OP]
Francisco2003
Fueling (Empty tank)
Fueling (Empty tank)
Posts: 1
Topics: 1
Joined: July 2020
Gender: Male
Alias (AKA): Cruz
Van Model Year: 2003
Van Make/Model: Chevrolet Astro
Extra Info: 4.3L v6

  • Similar topics
    Replies
    Views
    Author

Re: ASTROVAN starts but not power

Postby Leeann_93 » July 20th 2020, 10:19pm

Pull one of the two front oxygen sensors and try again. Is there any difference?

What is your fuel pressure, KOEO (Key On, Engine Off) on prime? After prime? Ten minutes later?
'05 Astro AWD vin X
'02 Astro LS AWD vin X
'00 Astro LS AWD - WIP
'99 Safari XLE AWD - broke
'93 AWD EXT vin W - real broke
User avatar
Leeann_93
Team Leader
Team Leader
Firing on 8 Cylinders (L7)
Firing on 8 Cylinders (L7)
Years of Membership: Leeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full years
Posts: 13430
Topics: 44
Images: 17
Joined: December 2008
Location: MD
Gender: Female
Alias (AKA):
Van Model Year: 2005
Van Make/Model: Chevrolet Astro
Extra Info: LS AWD


 
  • Related topics
    Replies
    Views
    Last post

Return to Engines

It is currently September 21st 2020, 4:54am

Engines Forum
Engine Repairs, Modifications, Diagnostics, Tuning, Upgrading, Questions.

<a href="https://ad.doubleclick.net/ddm/trackclk/N8334.275400VERTICALSCOPEINC./B20209277.204028354;dc_trk_aid=407011718;dc_trk_cid=94070067;dc_lat=;dc_rdid=;tag_for_child_directed_treatment="target="_blank"><img src="https://tpc.googlesyndication.com/pagead/imgad?id=CICAgKDrrqWwMRCAARgcKAEyCN4sAjjtai4k" border="0" align="right">
<IMG SRC="https://ad.doubleclick.net/ddm/trackimp/N8334.275400VERTICALSCOPEINC./B20209277.204028354;dc_trk_aid=407011718;dc_trk_cid=94070067;ord=;dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?" BORDER="0" HEIGHT="1" WIDTH="1" ALT="Advertisement">
Moderator: chevy57bert
To create a new topic in Engines, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
Maddog
in Engines
Views: 403
Comments: 31
Date: Sep 18 '20
Time: 11:15pm
» Read last comment
Attached by:
Maddog
in Engines
Views: 403
Comments: 31
Date: Sep 18 '20
Time: 10:47pm
» Read last comment
Attached by:
Maddog
in Engines
Views: 403
Comments: 31
Date: Sep 18 '20
Time: 10:43pm
» Read last comment
Attached by:
Maddog
in Engines
Views: 403
Comments: 31
Date: Sep 18 '20
Time: 10:40pm
» Read last comment
Attached by:
erikw9
in Engines
Views: 823
Comments: 37
Date: Sep 14 '20
Time: 7:30pm
» Read last comment

Who is online

Users browsing this forum: No registered users and 29 guests