1994 Astro engine cuts off then starts back up again

1994 Astro engine cuts off then starts back up again

Postby blendergasket [OP] » August 17th 2020, 5:50pm

Hi! My Astro has started having a(nother) problem.

I was driving up Snoqualmie Pass in WA and then out into the dirt roads in the mountains. Right when I was heading to the trailhead, on a dirt road going up a slight incline after a long hot drive, my van's engine stopped working momentarily. I still had radio, so the electricity was still there. The van cut and then turned back on after cutting one or two times. The van was fine for about 100 miles or so.

I replaced the fuel pump relay as it was pretty chewed up and I thought this might've been the cause. I checked the voltage at the battery and it was 12.3 V and after the lights were on for 1 minute it was at 11.6. I thought I'd fixed it as I didn't have the problem on a long drive I took after replacing the relay.

On Saturday I drove back into the mountains and on the way home the engine started cutting again. It was much worse. Again, the weather was pretty hot and I'd been driving for quite a while if that makes a difference. The engine cut then came back on. It then cut a couple more times and was much less interested in coming back on. It really started sputtering. I pulled off the road I was on and stopped the van. I turned it back on again and made it the rest of the way home without incident.

Yesterday I drove to the store and the van cut as I was rounding a corner. It was really hot out, but I had only been driving for maybe 5 minutes.

Is this the fuel pump going out? Or something different?

Thanks for all the help y'all give. I am extremely grateful for this forum.
1994 Astro Ext AWD
Original Poster [OP]
blendergasket
Site Contributor
Site Contributor
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: blendergasket has been a member for 3 full yearsblendergasket has been a member for 3 full yearsblendergasket has been a member for 3 full years
Posts: 138
Topics: 20
Joined: July 2017
Gender: Male
Alias (AKA): blendergasket
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: AWD

  • Similar topics
    Replies
    Views
    Author

Re: 1994 Astro engine cuts off then starts back up again

Postby MechBob » August 17th 2020, 6:34pm

2 very common problems with your symptoms.1- the wiring harness gets rubbed through,shorting out a wire. This usually happens on the engine harness,rear of engine.
2 the connector on the injector inside the manifold gets loose.You can usually check this by wiggling/pulling on the 2 injector wires,where they come out of a rubber grommet on the intake.
User avatar
MechBob
Firing on 2 Cylinders (L2)
Firing on 2 Cylinders (L2)
Years of Membership: MechBob has been a member for 2 full yearsMechBob has been a member for 2 full years
Posts: 1260
Topics: 11
Images: 12
Joined: August 2018
Gender: Male
Alias (AKA): Bob
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: 4x4

Re: 1994 Astro engine cuts off then starts back up again

Postby blendergasket [OP] » August 17th 2020, 9:06pm

Thank you for the info. How much give should be OK when testing the injector tubes? Would they come all the way out if they're bad or is a certain amount of back and forth a bad sign? There is maybe a mm or less of play when i jiggle them.

The wiring harness seems good up to where it splits. One half goes up into the front of the engine, and the other half goes into the passenger side of the van. It looks like 2 wires on the part that goes into the passenger side of the van are pretty worn down, one is worn down to the metal. It is orange if that helps at all. Are those going to the PCM?
1994 Astro Ext AWD
Original Poster [OP]
blendergasket
Site Contributor
Site Contributor
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: blendergasket has been a member for 3 full yearsblendergasket has been a member for 3 full yearsblendergasket has been a member for 3 full years
Posts: 138
Topics: 20
Joined: July 2017
Gender: Male
Alias (AKA): blendergasket
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: AWD

Re: 1994 Astro engine cuts off then starts back up again

Postby blendergasket [OP] » August 17th 2020, 9:39pm

Also, the van stalled right when I fired it up to take it down into the carport where I am now working on it. I had to turn the ignition to get it running again.
1994 Astro Ext AWD
Original Poster [OP]
blendergasket
Site Contributor
Site Contributor
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: blendergasket has been a member for 3 full yearsblendergasket has been a member for 3 full yearsblendergasket has been a member for 3 full years
Posts: 138
Topics: 20
Joined: July 2017
Gender: Male
Alias (AKA): blendergasket
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: AWD

Re: 1994 Astro engine cuts off then starts back up again

Postby unclemaui » August 17th 2020, 9:55pm

I was just helped by this forum on a similar issue.

check your battery posts. they maybe just loose enough to break the connection. however my radio lost all of its input (aftermarket digital)

I'd pull over and it would start right up. When I checked the cables they were tight. tight enough I did not figure it was the cause. I leaned a little more on the positive and have not had the issue since.
unclemaui
Fueling (1/8 tank)
Fueling (1/8 tank)
Years of Membership: unclemaui has been a member for 7 full yearsunclemaui has been a member for 7 full yearsunclemaui has been a member for 7 full yearsunclemaui has been a member for 7 full yearsunclemaui has been a member for 7 full yearsunclemaui has been a member for 7 full yearsunclemaui has been a member for 7 full years
Posts: 15
Topics: 5
Joined: July 2013
Alias (AKA):
Van Model Year: 1994
Van Make/Model: Chevrolet Astro

Re: 1994 Astro engine cuts off then starts back up again

Postby blendergasket [OP] » August 17th 2020, 10:05pm

Thanks. I'll go out and check them.

I noticed that an orange wire comes out of the oil pressure sending unit (is this the same thing as the oil pressure sensor?) but I am unsure how to tell if this is the same wire that's been rubbed bare. How would I test this?

Thanks again for the help!
Last edited by blendergasket on August 17th 2020, 10:21pm, edited 1 time in total.
1994 Astro Ext AWD
Original Poster [OP]
blendergasket
Site Contributor
Site Contributor
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: blendergasket has been a member for 3 full yearsblendergasket has been a member for 3 full yearsblendergasket has been a member for 3 full years
Posts: 138
Topics: 20
Joined: July 2017
Gender: Male
Alias (AKA): blendergasket
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: AWD

Re: 1994 Astro engine cuts off then starts back up again

Postby MechBob » August 17th 2020, 10:11pm

Tubes? You wiggle/pull on the injector wires,while it is idling,see if it stumbles
User avatar
MechBob
Firing on 2 Cylinders (L2)
Firing on 2 Cylinders (L2)
Years of Membership: MechBob has been a member for 2 full yearsMechBob has been a member for 2 full years
Posts: 1260
Topics: 11
Images: 12
Joined: August 2018
Gender: Male
Alias (AKA): Bob
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: 4x4

Re: 1994 Astro engine cuts off then starts back up again

Postby blendergasket [OP] » August 17th 2020, 10:22pm

Hmmm. I was thinking we were talking about the two metal pipes going into the manifold from the fuel tank. Should I be testing something other than that? But I will wiggle those two metal pipes while its running to check. Thanks for the reply.
1994 Astro Ext AWD
Original Poster [OP]
blendergasket
Site Contributor
Site Contributor
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: blendergasket has been a member for 3 full yearsblendergasket has been a member for 3 full yearsblendergasket has been a member for 3 full years
Posts: 138
Topics: 20
Joined: July 2017
Gender: Male
Alias (AKA): blendergasket
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: AWD

Re: 1994 Astro engine cuts off then starts back up again

Postby blendergasket [OP] » August 20th 2020, 4:14am

Deleted
1994 Astro Ext AWD
Original Poster [OP]
blendergasket
Site Contributor
Site Contributor
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: blendergasket has been a member for 3 full yearsblendergasket has been a member for 3 full yearsblendergasket has been a member for 3 full years
Posts: 138
Topics: 20
Joined: July 2017
Gender: Male
Alias (AKA): blendergasket
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: AWD

Re: 1994 Astro engine cuts off then starts back up again

Postby CopperFiremistCopperFiremist is online! » August 20th 2020, 4:59am

Sounds like you need to see Copper, I'm in the Seattle area send me a PM
Pullin The Pass
User avatar
CopperFiremistCopperFiremist is online!
V8 Swap Achievement
V8 Swap Achievement
Firing on 1 Cylinder (L2)
Firing on 1 Cylinder (L2)
Years of Membership: CopperFiremist has been a member for 6 full yearsCopperFiremist has been a member for 6 full yearsCopperFiremist has been a member for 6 full yearsCopperFiremist has been a member for 6 full yearsCopperFiremist has been a member for 6 full yearsCopperFiremist has been a member for 6 full years
Posts: 1169
Topics: 25
Images: 6
Joined: March 2015
Location: Seattle Wa
Gender: Male
Alias (AKA): B
Van Model Year: 1998
Van Make/Model: Chevrolet Astro
Extra Info: LS Swap

Re: 1994 Astro engine cuts off then starts back up again

Postby blendergasket [OP] » August 23rd 2020, 8:37pm

I haven't given up quite yet! Doing some of the diagnostic tests referenced above today to see if I can get to the bottom of it.
1994 Astro Ext AWD
Original Poster [OP]
blendergasket
Site Contributor
Site Contributor
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: blendergasket has been a member for 3 full yearsblendergasket has been a member for 3 full yearsblendergasket has been a member for 3 full years
Posts: 138
Topics: 20
Joined: July 2017
Gender: Male
Alias (AKA): blendergasket
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: AWD


 
  • Related topics
    Replies
    Views
    Last post

Return to Engines

It is currently March 7th 2021, 4:03pm

Engines Forum
Engine Repairs, Modifications, Diagnostics, Tuning, Upgrading, Questions.

<a href="https://ad.doubleclick.net/ddm/trackclk/N8334.275400VERTICALSCOPEINC./B20209277.204028354;dc_trk_aid=407011718;dc_trk_cid=94070067;dc_lat=;dc_rdid=;tag_for_child_directed_treatment="target="_blank"><img src="https://tpc.googlesyndication.com/pagead/imgad?id=CICAgKDrrqWwMRCAARgcKAEyCN4sAjjtai4k" border="0" align="right">
<IMG SRC="https://ad.doubleclick.net/ddm/trackimp/N8334.275400VERTICALSCOPEINC./B20209277.204028354;dc_trk_aid=407011718;dc_trk_cid=94070067;ord=;dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?" BORDER="0" HEIGHT="1" WIDTH="1" ALT="Advertisement">
Moderator: chevy57bert
To create a new topic in Engines, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
AppaTheAirBison
in Engines
Views: 72
Comments: 2
Date: Yesterday
Time: 8:54pm
» Read last comment
Attached by:
Attached by: MHM
MHM
in Engines
Views: 378
Comments: 22
Date: Mar 02 '21
Time: 2:20pm
» Read last comment
Attached by:
Attached by: MHM
MHM
in Engines
Views: 378
Comments: 22
Date: Mar 01 '21
Time: 7:27pm
» Read last comment
Attached by:
Ken2.7
in Engines
Views: 244
Comments: 10
Date: Feb 24 '21
Time: 2:02am
» Read last comment
Attached by:
Attached by: Mmusicman
Mmusicman
in Engines
Views: 244
Comments: 10
Date: Feb 23 '21
Time: 8:38pm
» Read last comment
Sponsors

Who is online

Users browsing this forum: No registered users and 11 guests