Drivability Problems

Drivability Problems

Postby daytonboi [OP] » March 17th 2012, 12:43am

This might be a bit long winded...just a warning.

My van use to get decent gas mileage. Now i'm lucky to get 10mpg. I always figured that my t-stat was bad...it's factory and i'm at 202k miles and it takes almost 2 hours of driving to make any kind of appreciable heat. Haven't changed it cause the ground wire is stuck to the bolt (another story). Also my heat gauge doesn't work, which leads to my problem I'm assuming. Me poking around under the hood I was testing the leads to the temp sensor next to the egr, after being led to believe that was in fact the one that goes to the dash gauge...well it wasn't responding to the test so i plugged it back in and started the van. It started right up, but i had an SES light on, on the dash now. I figured I would after disconnecting the sensor. Next morning i remote started my van and noted that the van was idling kinda high. Then all a sudden the idle went really low. Then it began to run like it was really low on fuel sorta bucking while it was sitting there. It smoothed out in about a minute and I was on my way. But as I was driving the van began to do the same thing, I would be on the throttle and it would almost sorta stall I guess. It would do that a couple times and then it would be ok. SES light still on. I was driving around and it would do that intermittently. The SES light went off. I figured back to normal. Nope it would still buck every once in a while. It's been doing this for two days now and I'm at a loss. I drive for my job so I want to get this fixed as fast as I can. Any help is appreciated. Also I think my alternator is beginning to go...I plan on fixing that next week or so upgrading to an ad244.
Original Poster [OP]
User avatar
daytonboi
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: daytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full years
Posts: 100
Topics: 35
Joined: January 2009
Location: Dayton, OH
Gender: Male
Alias (AKA): El
Van Model Year: 1998
Van Make/Model: Chevrolet Astro
Extra Info: AWD

Re: Drivability Problems

Postby RECox286 » March 17th 2012, 3:32am

Hey, you know the drill...

First thing to do is upgrade your information to include the year truck you have.

Next thing to do is get a live scan done so you will have a readout of what is going on with the computer & sensors.

Third thing to do is somehow get that T-stat changed out so you will have a warm engine and some cabin heat. The

computer may be in open loop due to the engine temp being too cold.

How long has it been since you did an eyeball inspection of the vacuum hoses ? How about a tune up ? And do you

know if the EGR is working, clogged, stuck open, or what ?

Bad ignition parts, as well as electric leaks are not good for driveability either.

Good hunting

Uncle Bob
Start a fire for a man and he will be warm for a day.
Set a man on fire and he will be warm the rest of his life.

Sent using two Progresso soup cans and a string
User avatar
RECox286
U.S. Armed Forces
U.S. Armed Forces
Purple Status (L6)
Purple Status (L6)
Years of Membership: RECox286 has been a member for 10 full yearsRECox286 has been a member for 10 full yearsRECox286 has been a member for 10 full yearsRECox286 has been a member for 10 full yearsRECox286 has been a member for 10 full yearsRECox286 has been a member for 10 full yearsRECox286 has been a member for 10 full yearsRECox286 has been a member for 10 full yearsRECox286 has been a member for 10 full yearsRECox286 has been a member for 10 full years
Posts: 5008
Topics: 40
Images: 0
Joined: July 2010
Location: South Jersey
Gender: Male
Alias (AKA): Uncle Bob
Van Model Year: 1993
Van Make/Model: Chevrolet Astro
Extra Info: RWD V6 [325K mi]

Re: Drivability Problems

Postby daytonboi [OP] » March 18th 2012, 4:22am

Thanks for the info... I haven't done the live scan yet i working on buying me a scanner to use with my phone and laptop. But today I did get my thermostat changed out and I do have heat. I also changed my coolant temp sensor that heads to that dash. Now my van is reading almost 260...but i'm not sure if that's right. I did a light flush and drained all the water out and then put more back in, but not the gauges are saying i'm running hot. so I'm not sure if there is air trapped in the system. I've tried burping it but either there is no air in the system or I don't know what i'm doing...and I'm leaning more toward the latter.
Original Poster [OP]
User avatar
daytonboi
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: daytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full yearsdaytonboi has been a member for 11 full years
Posts: 100
Topics: 35
Joined: January 2009
Location: Dayton, OH
Gender: Male
Alias (AKA): El
Van Model Year: 1998
Van Make/Model: Chevrolet Astro
Extra Info: AWD


 
  • Related topics
    Replies
    Views
    Last post

Return to Engines

It is currently October 25th 2020, 5:51am

Engines Forum
Engine Repairs, Modifications, Diagnostics, Tuning, Upgrading, Questions.

<a href="https://ad.doubleclick.net/ddm/trackclk/N8334.275400VERTICALSCOPEINC./B20209277.204028354;dc_trk_aid=407011718;dc_trk_cid=94070067;dc_lat=;dc_rdid=;tag_for_child_directed_treatment="target="_blank"><img src="https://tpc.googlesyndication.com/pagead/imgad?id=CICAgKDrrqWwMRCAARgcKAEyCN4sAjjtai4k" border="0" align="right">
<IMG SRC="https://ad.doubleclick.net/ddm/trackimp/N8334.275400VERTICALSCOPEINC./B20209277.204028354;dc_trk_aid=407011718;dc_trk_cid=94070067;ord=;dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?" BORDER="0" HEIGHT="1" WIDTH="1" ALT="Advertisement">
Moderator: chevy57bert
To create a new topic in Engines, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
AstroTan
in Engines
Views: 171
Comments: 5
Date: Oct 21 '20
Time: 8:02pm
» Read last comment
Attached by:
Attached by: Sparkydog
Sparkydog
in Engines
Views: 340
Comments: 13
Date: Oct 20 '20
Time: 4:01pm
» Read last comment
Attached by:
Attached by: Sparkydog
Sparkydog
in Engines
Views: 86
Comments: 0
Date: Oct 13 '20
Time: 8:49pm
» Read last comment
Attached by:
Attached by: stent
stent
in Engines
Views: 3090
Comments: 61
Date: Oct 09 '20
Time: 2:58am
» Read last comment
Attached by:
hankheat
in Engines
Views: 320
Comments: 8
Date: Oct 07 '20
Time: 6:30pm
» Read last comment

Who is online

Users browsing this forum: No registered users and 22 guests