Failed emiisions test by this much

Failed emiisions test by this much

Postby Rod b [OP] » March 26th 2012, 4:57pm

Took the old 95 safari in for the dreaded emissions test today and failed as i expected Maybe some input from all you helpful people may shine a route to go .I must say the test center had just re calibrated their machine so it was dead on ( tooo bad for me)

here are the readings and a little history on this baby
emgif.gif
emission test

5000 ks ago was checked over gold tipped plugs ( looked brand new)cap and rotor( were corroded) egr valve( surging and gave a code) fuel pressure regulator( was leaking) and needed a new cat for emissions .The tech at the garage said it was so little either run 1/2 hi-test and try again in a couple days or go to another shop.It has always stunk of unburnt fuel even with the new cat ( sulphur) the tech says the cat seems okay any ideas would be great Id hate to throw on a new set of plugs as you know they are a ***** unless you have a hoist thanks in advance
Original Poster [OP]
Rod b
Fueling (1/2 tank)
Fueling (1/2 tank)
Years of Membership: Rod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full years
Posts: 53
Topics: 9
Joined: August 2009
Alias (AKA): byteme
Van Make/Model: GMC Safari
Extra Info: w code

  • Similar topics
    Replies
    Views
    Author
  • Coolant PH test strip advice?
    by rlyoung » July 27th 2020, 4:16pm in Engines
    4 Replies
    192 Views
    Last post by MechBob View the latest post
    July 27th 2020, 10:59pm
  • 4.3L V6 Hesitant To Start When hot - Fuel Pressure Test
    by K-TRON » November 5th 2020, 4:42am in Engines
    23 Replies
    532 Views
    Last post by MechBob View the latest post
    November 17th 2020, 3:05am
  •  
    5
    34
    Last post by AstroSafari.com View the latest post
    November 27th 2020, 10:02am

Re: Failed emiisions test by this much

Postby sadglad » March 26th 2012, 6:44pm

My 93 failed with similar circumstances. It barely passed the higher rpm test with high HC but failed at idle with excessive HC. It had new cap+rotor, new wires, new plugs. It turns out one of the spark plugs had a hairline crack in the porcelain. I had looked and listened for a spark jump in a dark garage but did not see it. I used a clear plastic hose as a stethoscope and the clear plastic caught a faint glimpse of spark jump and reflected it back enough to see. Without the hose the spark was not visible.

Replaced the one spark plug and passed HC levels by a wide margin. Van ran much better too.
sadglad
Site Contributor
Site Contributor
Firing on 3 Cylinders (L1)
Firing on 3 Cylinders (L1)
Years of Membership: sadglad has been a member for 8 full yearssadglad has been a member for 8 full yearssadglad has been a member for 8 full yearssadglad has been a member for 8 full yearssadglad has been a member for 8 full yearssadglad has been a member for 8 full yearssadglad has been a member for 8 full yearssadglad has been a member for 8 full years
Posts: 334
Topics: 22
Images: 15
Joined: January 2012
Gender: Male
Alias (AKA):
Van Model Year: 2002
Van Make/Model: Chevrolet Astro
Extra Info: 2002 AWD Cargo

Re: Failed emiisions test by this much

Postby Rod b [OP] » March 26th 2012, 8:04pm

The van seems to run fine no real miss felt I may just jamb in a new set of plugs and some hi test and retest the old girl I just cant afford to pour a lot into it ...
Original Poster [OP]
Rod b
Fueling (1/2 tank)
Fueling (1/2 tank)
Years of Membership: Rod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full years
Posts: 53
Topics: 9
Joined: August 2009
Alias (AKA): byteme
Van Make/Model: GMC Safari
Extra Info: w code

Re: Failed emiisions test by this much

Postby 1990GMCRallySTX » March 26th 2012, 9:33pm

sadglad wrote:My 93 failed with similar circumstances. It barely passed the higher rpm test with high HC but failed at idle with excessive HC. It had new cap+rotor, new wires, new plugs. It turns out one of the spark plugs had a hairline crack in the porcelain. I had looked and listened for a spark jump in a dark garage but did not see it. I used a clear plastic hose as a stethoscope and the clear plastic caught a faint glimpse of spark jump and reflected it back enough to see. Without the hose the spark was not visible.

Replaced the one spark plug and passed HC levels by a wide margin. Van ran much better too.


Hey, did you happen to snap a pic of the hairline crack on the plugs ? Did you need to look very closely to spot it or is the crack obvious. The van I run failed with high HC idle as well.
1990 GMC Rally STX G-1500 Van 5.7L V8 Throttle Body Injection, 4 speed automatic, Cruise, Tilt, Power Windows/Locks, Rear Accessory Heater, A/C, 350K KM
User avatar
1990GMCRallySTX
Fueling (1/8 tank)
Fueling (1/8 tank)
Years of Membership: 1990GMCRallySTX has been a member for 8 full years1990GMCRallySTX has been a member for 8 full years1990GMCRallySTX has been a member for 8 full years1990GMCRallySTX has been a member for 8 full years1990GMCRallySTX has been a member for 8 full years1990GMCRallySTX has been a member for 8 full years1990GMCRallySTX has been a member for 8 full years1990GMCRallySTX has been a member for 8 full years
Posts: 24
Topics: 2
Images: 6
Joined: March 2012
Location: Vancouver Canada
Gender: Male
Alias (AKA):
Van Model Year: 1990
Extra Info: 5.7 TBI

Re: Failed emiisions test by this much

Postby Jasen » March 26th 2012, 9:57pm

Did you change the oil before the test. This has worked for me in the past on the close ones and now I always change the oil before test.
I'm a Journeyman woodworker,
Every projects a journey man.

200k
Ultra gauge

Being a mad scientist IS NOT as easy as it look's on TV



Image
Jasen
Site Contributor
Site Contributor
Firing on 8 Cylinders (L7)
Firing on 8 Cylinders (L7)
Years of Membership: Jasen has been a member for 11 full yearsJasen has been a member for 11 full yearsJasen has been a member for 11 full yearsJasen has been a member for 11 full yearsJasen has been a member for 11 full yearsJasen has been a member for 11 full yearsJasen has been a member for 11 full yearsJasen has been a member for 11 full yearsJasen has been a member for 11 full yearsJasen has been a member for 11 full yearsJasen has been a member for 11 full years
Posts: 7045
Topics: 260
Images: 101
Joined: July 2009
Location: Seattle, Wa
Gender: Male
Alias (AKA):
Van Model Year: 1997
Van Make/Model: Chevrolet Astro
Extra Info: AWD cargo Dutch door

Re: Failed emiisions test by this much

Postby Rod b [OP] » March 27th 2012, 12:02am

yes fresh oil change on friday so that's not it the tech asked that too its 1 thing i always do
Original Poster [OP]
Rod b
Fueling (1/2 tank)
Fueling (1/2 tank)
Years of Membership: Rod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full years
Posts: 53
Topics: 9
Joined: August 2009
Alias (AKA): byteme
Van Make/Model: GMC Safari
Extra Info: w code

Re: Failed emiisions test by this much

Postby sadglad » March 27th 2012, 1:59am

1990GMCRallySTX wrote:Hey, did you happen to snap a pic of the hairline crack on the plugs ? Did you need to look very closely to spot it or is the crack obvious. The van I run failed with high HC idle as well.


Sorry, no pic. It was fairly obvious.
sadglad
Site Contributor
Site Contributor
Firing on 3 Cylinders (L1)
Firing on 3 Cylinders (L1)
Years of Membership: sadglad has been a member for 8 full yearssadglad has been a member for 8 full yearssadglad has been a member for 8 full yearssadglad has been a member for 8 full yearssadglad has been a member for 8 full yearssadglad has been a member for 8 full yearssadglad has been a member for 8 full yearssadglad has been a member for 8 full years
Posts: 334
Topics: 22
Images: 15
Joined: January 2012
Gender: Male
Alias (AKA):
Van Model Year: 2002
Van Make/Model: Chevrolet Astro
Extra Info: 2002 AWD Cargo

Re: Failed emiisions test by this much

Postby thor124 » March 27th 2012, 1:13pm

How hot was the engine at test? My 1995 Monte Carlo flunked once when the engine was only "warm"(warm enough to be in closed loop, but not up to full operating temp). Passed the next time when I took it to them after a 20minute drive on the highway.
thor124
Fueling (5/8 tank)
Fueling (5/8 tank)
Years of Membership: thor124 has been a member for 9 full yearsthor124 has been a member for 9 full yearsthor124 has been a member for 9 full yearsthor124 has been a member for 9 full yearsthor124 has been a member for 9 full yearsthor124 has been a member for 9 full yearsthor124 has been a member for 9 full yearsthor124 has been a member for 9 full yearsthor124 has been a member for 9 full years
Posts: 69
Topics: 9
Joined: March 2011
Gender: Male
Alias (AKA):
Van Make/Model: Chevrolet Astro

Re: Failed emiisions test by this much

Postby Rod b [OP] » March 27th 2012, 3:25pm

come to think of it i only drove 8 blocks in the city sat half hour then they took it in .If the cat was having problems would it be more evident at higher temp or lower ??
Original Poster [OP]
Rod b
Fueling (1/2 tank)
Fueling (1/2 tank)
Years of Membership: Rod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full years
Posts: 53
Topics: 9
Joined: August 2009
Alias (AKA): byteme
Van Make/Model: GMC Safari
Extra Info: w code

Re: Failed emiisions test by this much

Postby 94 Van Guy » March 27th 2012, 9:12pm

I agree with thor124 about the engine being hot. A must to pass emissions. I always take mine out for a 15 min run on the freeway first.

Good luck,

Keith

EDIT: Typo
Last edited by 94 Van Guy on March 28th 2012, 2:45pm, edited 1 time in total.
'91 Chevy G30 Bus 39.3K Miles


Retired
Safari
87 Safari, 91 Astro
86 Astro, 85 Astro
88 Astro, 92 Astro
89 Astro, 88 Astro

Image
User avatar
94 Van Guy
250k+ Miles
250k+ Miles
Firing on 5 Cylinders (L3)
Firing on 5 Cylinders (L3)
Years of Membership: 94 Van Guy has been a member for 10 full years94 Van Guy has been a member for 10 full years94 Van Guy has been a member for 10 full years94 Van Guy has been a member for 10 full years94 Van Guy has been a member for 10 full years94 Van Guy has been a member for 10 full years94 Van Guy has been a member for 10 full years94 Van Guy has been a member for 10 full years94 Van Guy has been a member for 10 full years94 Van Guy has been a member for 10 full years
Posts: 2538
Topics: 71
Images: 44
Joined: February 2010
Location: Salt Lake City, Utah USA
Gender: Male
Alias (AKA): Keith
Van Model Year: 1991
Van Make/Model: Chevrolet Astro
Extra Info: G30 Bus

Re: Failed emiisions test by this much

Postby Rod b [OP] » March 28th 2012, 2:27am

will find out in the morning might put in a bit of hi-test and give her a half hour hiway burn before my 8:30 am test .Someone also mentioned a canister filter I don't think my 95 has one ???
Original Poster [OP]
Rod b
Fueling (1/2 tank)
Fueling (1/2 tank)
Years of Membership: Rod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full years
Posts: 53
Topics: 9
Joined: August 2009
Alias (AKA): byteme
Van Make/Model: GMC Safari
Extra Info: w code

Re: Failed emiisions test by this much

Postby Rod b [OP] » March 30th 2012, 9:07pm

Well getting it hot didn't pay off the test failed even worse .Took it back to original testing station and was ready to pay the 90 for diagnosis left the truck came home.Nervous as to more big bucks called later in day guy says all done he says it passed??? Spoke to the tech ( first time id gone here) he waited until the office was empty and said I know why your truck failed too much fuel left at idle so when the test asked for idle loop the truck wasnt at idle . I think i found a real honest give a **** shop il go back .He says he doesnt believe in this 459 limit especially when its off by so little. He did suggest change the o2 sensors if i never had so thats next .
Original Poster [OP]
Rod b
Fueling (1/2 tank)
Fueling (1/2 tank)
Years of Membership: Rod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full years
Posts: 53
Topics: 9
Joined: August 2009
Alias (AKA): byteme
Van Make/Model: GMC Safari
Extra Info: w code

Re: Failed emiisions test by this much

Postby 1990GMCRallySTX » March 30th 2012, 11:24pm

I really hate car repair shops, they are always in it for themselves and usually don't do the work you had asked and sometimes end up by making things worse, and stealing your money. Even worse are the Manufacturer 'Stealerships' .
1990 GMC Rally STX G-1500 Van 5.7L V8 Throttle Body Injection, 4 speed automatic, Cruise, Tilt, Power Windows/Locks, Rear Accessory Heater, A/C, 350K KM
User avatar
1990GMCRallySTX
Fueling (1/8 tank)
Fueling (1/8 tank)
Years of Membership: 1990GMCRallySTX has been a member for 8 full years1990GMCRallySTX has been a member for 8 full years1990GMCRallySTX has been a member for 8 full years1990GMCRallySTX has been a member for 8 full years1990GMCRallySTX has been a member for 8 full years1990GMCRallySTX has been a member for 8 full years1990GMCRallySTX has been a member for 8 full years1990GMCRallySTX has been a member for 8 full years
Posts: 24
Topics: 2
Images: 6
Joined: March 2012
Location: Vancouver Canada
Gender: Male
Alias (AKA):
Van Model Year: 1990
Extra Info: 5.7 TBI

Re: Failed emiisions test by this much

Postby Rod b [OP] » March 31st 2012, 3:31am

my experience seems to have negated that all shops are thieves Ive ran a number of repair shops and yes there are techs out there to jamb you but they are not everywhere.As for dealers they were built for warranty work only and people that take their cars there are either loyal and have a rapore with a trusted tech or don't know any better .It seems you were burnt once or twice and thats a drag but please don't paint everyone with the same brush its not fare ,just sayin not looking for an argument.
Original Poster [OP]
Rod b
Fueling (1/2 tank)
Fueling (1/2 tank)
Years of Membership: Rod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full yearsRod b has been a member for 11 full years
Posts: 53
Topics: 9
Joined: August 2009
Alias (AKA): byteme
Van Make/Model: GMC Safari
Extra Info: w code

Re: Failed emiisions test by this much

Postby ryyiann » April 1st 2012, 1:47pm

i got my emissions coming up in a few weeks
04 Astro awd
98 Safari rwd sold at 208k
98 Astro awd sold at 220k
92 Astro awd sold at 170k
01 Blazer 4x4 sold at 180k
99 Express 1500 rwd sold at 160k
92 Astro rwd sold at 110k
ryyiann
Fueling (3/8 tank)
Fueling (3/8 tank)
Years of Membership: ryyiann has been a member for 8 full yearsryyiann has been a member for 8 full yearsryyiann has been a member for 8 full yearsryyiann has been a member for 8 full yearsryyiann has been a member for 8 full yearsryyiann has been a member for 8 full yearsryyiann has been a member for 8 full yearsryyiann has been a member for 8 full years
Posts: 44
Topics: 4
Images: 1
Joined: March 2012
Gender: Male
Alias (AKA):
Van Model Year: 2004
Van Make/Model: Chevrolet Astro
Extra Info: AWD

Re: Failed emiisions test by this much

Postby xit » April 1st 2012, 2:44pm

We don't need no STINKING emission testing here! Seriously, here in Oklahoma there is no testing for emissions or anything else for that matter. You should see some of the wrecks that are driven on the highway, headlights, stop lights hanging out, cars with more than one temporary spare on, broken glasses, crazy. We did have inspections from the mid 60s till the 90s, then the state government just did away with them. :shrug:
Possibly Natures most perfect food, good beef jerky and cold beer......
User avatar
xit
Firing on 5 Cylinders (L1)
Firing on 5 Cylinders (L1)
Years of Membership: xit has been a member for 9 full yearsxit has been a member for 9 full yearsxit has been a member for 9 full yearsxit has been a member for 9 full yearsxit has been a member for 9 full yearsxit has been a member for 9 full yearsxit has been a member for 9 full yearsxit has been a member for 9 full yearsxit has been a member for 9 full years
Posts: 592
Topics: 65
Images: 4
Joined: August 2011
Location: Central Oklahoma
Gender: Male
Alias (AKA):
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: Conversion

Re: Failed emiisions test by this much

Postby Heavyopp » April 1st 2012, 3:13pm

Same thing going on here for me.
NJ state inspection center -- 1st test was 1800 PPM for HC passing limit 220 -- CO was also higher than the limit but not by much

I tuned the van up - Denso TT plugs - delphi wires - accel cap and rotor - air filter - PCV valve - oil change
Van runs awesome -- the cap I took off was all corroded on the ignition coil connection the rest looked OK.

2nd test 256 PPM HC Passing limit 220 --- CO was fine -- All this testing is at idle. High rev test was fine from the beginning

For my 3rd test this week I think I'm going get another PCV valve and hook it up to the vacuum line but not stick it in the valve cover. Just let it breathe fresh air.
I'll leave the PCV thats in there now in the valve cover to stop possible smoke and oil getting everywhere.

Here in NJ state testing is free. Well at least it doesn't cost any money at the inspection station -- just time -- usually 50 minutes of waiting and a 10 minute test.
Heavyopp
Fueling (7/8 tank)
Fueling (7/8 tank)
Years of Membership: Heavyopp has been a member for 9 full yearsHeavyopp has been a member for 9 full yearsHeavyopp has been a member for 9 full yearsHeavyopp has been a member for 9 full yearsHeavyopp has been a member for 9 full yearsHeavyopp has been a member for 9 full yearsHeavyopp has been a member for 9 full yearsHeavyopp has been a member for 9 full yearsHeavyopp has been a member for 9 full years
Posts: 89
Topics: 8
Images: 11
Joined: October 2011
Location: Middlesex County, NJ
Gender: Male
Alias (AKA):
Van Model Year: 1992
Van Make/Model: GMC Safari
Extra Info: HD S10 rear springs

Re: Failed emiisions test by this much

Postby Lumpy » April 1st 2012, 3:39pm

In Arizona, they only test in the metro areas. You can go online and see real time video of the cars waiting in line and the estimated wait time.


Lump
User avatar
Lumpy
Deprived Privileges
Deprived Privileges
Firing on 8 Cylinders (L7)
Firing on 8 Cylinders (L7)
Years of Membership: Lumpy has been a member for 10 full yearsLumpy has been a member for 10 full yearsLumpy has been a member for 10 full yearsLumpy has been a member for 10 full yearsLumpy has been a member for 10 full yearsLumpy has been a member for 10 full yearsLumpy has been a member for 10 full yearsLumpy has been a member for 10 full yearsLumpy has been a member for 10 full yearsLumpy has been a member for 10 full years
Posts: 10996
Topics: 261
Joined: April 2010
Location: Phoenix AZ USA
Gender: Male
Alias (AKA):
Van Model Year: 1989
Van Make/Model: Chevrolet Astro
Extra Info: 11 in. lift Camo

Re: Failed emiisions test by this much

Postby RECox286 » April 1st 2012, 4:08pm

The truth be told:

In Joisey, the test is not free. The state requires an ANNUAL registration fee be paid, then the Smog test is administered by a

state facility, manned by a private contractor, EVERY OTHER year. You get a choice of using this state facility, for "free"

(part of the registration fee) or you can use a state licensed testing facility (basically a repair center) which will cost you

a fee, over and above registration, for them to do the testing. Either way, I see it as a rip off. And we have to pass

California Smog Standards.

I didn't chose to be born free ! Ha.

Uncle Bob
Start a fire for a man and he will be warm for a day.
Set a man on fire and he will be warm the rest of his life.

Sent using two Progresso soup cans and a string
User avatar
RECox286
U.S. Armed Forces
U.S. Armed Forces
Purple Status (L6)
Purple Status (L6)
Years of Membership: RECox286 has been a member for 10 full yearsRECox286 has been a member for 10 full yearsRECox286 has been a member for 10 full yearsRECox286 has been a member for 10 full yearsRECox286 has been a member for 10 full yearsRECox286 has been a member for 10 full yearsRECox286 has been a member for 10 full yearsRECox286 has been a member for 10 full yearsRECox286 has been a member for 10 full yearsRECox286 has been a member for 10 full years
Posts: 5008
Topics: 40
Images: 0
Joined: July 2010
Location: South Jersey
Gender: Male
Alias (AKA): Uncle Bob
Van Model Year: 1993
Van Make/Model: Chevrolet Astro
Extra Info: RWD V6 [325K mi]

Re: Failed emiisions test by this much

Postby TDMobile » April 1st 2012, 4:33pm

RECox286 wrote:The truth be told:

In Joisey, the test is not free. The state requires an ANNUAL registration fee be paid, then the Smog test is administered by a

state facility, manned by a private contractor, EVERY OTHER year. You get a choice of using this state facility, for "free"

(part of the registration fee) or you can use a state licensed testing facility (basically a repair center) which will cost you

a fee, over and above registration, for them to do the testing. Either way, I see it as a rip off. And we have to pass

California Smog Standards.

I didn't chose to be born free ! Ha.

Uncle Bob


And don't go to the Deptford testing facility if it gets too close to 8:30AM, you won't get out until noon!!!
User avatar
TDMobile
250k+ Miles
250k+ Miles
Firing on 6 Cylinders (L1)
Firing on 6 Cylinders (L1)
Years of Membership: TDMobile has been a member for 8 full yearsTDMobile has been a member for 8 full yearsTDMobile has been a member for 8 full yearsTDMobile has been a member for 8 full yearsTDMobile has been a member for 8 full yearsTDMobile has been a member for 8 full yearsTDMobile has been a member for 8 full yearsTDMobile has been a member for 8 full years
Posts: 624
Topics: 13
Images: 5
Joined: March 2012
Location: Philadelphia area
Gender: Male
Alias (AKA):
Van Model Year: 2005
Van Make/Model: Chevrolet Astro
Extra Info: AWD Cargo 300K

Next

 
  • Related topics
    Replies
    Views
    Last post

Return to Engines

It is currently November 27th 2020, 10:02am

Engines Forum
Engine Repairs, Modifications, Diagnostics, Tuning, Upgrading, Questions.

<a href="https://ad.doubleclick.net/ddm/trackclk/N8334.275400VERTICALSCOPEINC./B20209277.204028354;dc_trk_aid=407011718;dc_trk_cid=94070067;dc_lat=;dc_rdid=;tag_for_child_directed_treatment="target="_blank"><img src="https://tpc.googlesyndication.com/pagead/imgad?id=CICAgKDrrqWwMRCAARgcKAEyCN4sAjjtai4k" border="0" align="right">
<IMG SRC="https://ad.doubleclick.net/ddm/trackimp/N8334.275400VERTICALSCOPEINC./B20209277.204028354;dc_trk_aid=407011718;dc_trk_cid=94070067;ord=;dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?" BORDER="0" HEIGHT="1" WIDTH="1" ALT="Advertisement">
Moderator: chevy57bert
To create a new topic in Engines, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
djpigs
in Engines
Views: 1043
Comments: 41
Date: Yesterday
Time: 11:23pm
» Read last comment
Attached by:
Attached by: Leeann_93
Leeann_93
in Engines
Views: 114
Comments: 5
Date: Yesterday
Time: 12:43am
» Read last comment
Attached by:
Attached by: Slime
Slime
in Engines
Views: 114
Comments: 5
Date: Nov 24 '20
Time: 11:11pm
» Read last comment
Attached by:
K-TRON
in Engines
Views: 532
Comments: 23
Date: Nov 16 '20
Time: 1:07am
» Read last comment
Attached by:
Attached by: Devonian
Devonian
in Engines
Views: 342
Comments: 10
Date: Nov 13 '20
Time: 2:19am
» Read last comment
Sponsors

Who is online

Users browsing this forum: No registered users and 6 guests