Possible solution to the dreaded P0300 code...

Possible solution to the dreaded P0300 code...

Postby yajblackburn [OP] » October 3rd 2008, 8:12pm

So, I had the problem with my 1999 Astro van. Eveybody knows the problem, you start it up and the damn thing sputters like crazy. You drive around for a while and it sort of goes away......until the next morning when it wont even start. So, I tried the Ignition route replacing the cap, rotor, wires and plugs with non ACDelco products to no advantage. I checked all the forums on this problem and it seemed no one had a decent answer. Recently I figured hey, I might as well try to clean the EGR valvle to see what happens. After a good cleaning with compressed air and a dentists tool to scrape off the carbon, I reinstalled it and it ran fine. So what right? Wait until the morning when it's at it's worst. So the next morning it started it up just fine and ran just as well. No sputtering!! It's been a week and it has ben sputter free. My suggestion to everyone out there with this problem is not to waste your time and money on fuel press regulators, ignition coils and so on and go right for that EGR valve (don't use carb cleaner as it will damage the diaphram). It worked for me.
Original Poster [OP]
yajblackburn
Fueling (Empty tank)
Fueling (Empty tank)
Years of Membership: yajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full years
Posts: 2
Topics: 1
Joined: September 2008
Alias (AKA):

  • Similar topics
    Replies
    Views
    Author
  • P0175 code
    by fitter » November 3rd 2020, 4:39pm in Engines
    1 Replies
    551 Views
    Last post by TBLBill View the latest post
    November 3rd 2020, 6:50pm
  • Code 43 help please.
    by Roadtrip John » December 8th 2020, 5:35pm in Engines
    7 Replies
    246 Views
    Last post by Big_kid View the latest post
    December 14th 2020, 11:16pm
  •  
    9
    29
    Last post by AstroSafari.com View the latest post
    April 18th 2021, 4:00am

Re: Possible solution to the dreaded P0300 code...

Postby Matrixx » October 3rd 2008, 10:35pm

Good trouble shooting with that code doesn't only relate to that specific problem you had. I sense a bit of something in your post when you stated Non AC Delco parts (Maybe I'm misunderstanding it). You might want to go back to the Old Forum Board that is linked up here on the front page and do a little research their over the years it was up and running, you might be surprised in what you find. This particular code has been discussed many times over.

Either way, Welcome to the board yajblackburn. :)
96-GMC Safari - Rwd - Original Transmission - Exhaust - Air Cared - 3.73 Limited Slip Rear End - Motor Replaced - 91 octane (Chevron) for the last 14 years - MFI Upgrade - 640,000 Kilometers.
User avatar
Matrixx
AstroSafari Pioneer
AstroSafari Pioneer
Firing on 6 Cylinders (L3)
Firing on 6 Cylinders (L3)
Years of Membership: Matrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full years
Posts: 2640
Topics: 14
Joined: January 2008
Alias (AKA):

Re: Possible solution to the dreaded P0300 code...

Postby yajblackburn [OP] » October 6th 2008, 7:15pm

What I meant by the non AC Delco products was that previously noted post, people saying to replace the stock ignition products with the AC Delco ones instead. Making them perform better. However, I have read that people were still having the same problem even with new AC Delco products installed. I was stating that the problem that I was having had nothing to do with the ignition setup, so it didn't matter if they were or were not AC Delco. Just to clean and confusuion. Hope it helps!
Original Poster [OP]
yajblackburn
Fueling (Empty tank)
Fueling (Empty tank)
Years of Membership: yajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full yearsyajblackburn has been a member for 12 full years
Posts: 2
Topics: 1
Joined: September 2008
Alias (AKA):


 
  • Related topics
    Replies
    Views
    Last post

Return to Engines

It is currently April 18th 2021, 4:00am

Engines Forum
Engine Repairs, Modifications, Diagnostics, Tuning, Upgrading, Questions.

<a href="https://ad.doubleclick.net/ddm/trackclk/N8334.275400VERTICALSCOPEINC./B20209277.204028354;dc_trk_aid=407011718;dc_trk_cid=94070067;dc_lat=;dc_rdid=;tag_for_child_directed_treatment="target="_blank"><img src="https://tpc.googlesyndication.com/pagead/imgad?id=CICAgKDrrqWwMRCAARgcKAEyCN4sAjjtai4k" border="0" align="right">
<IMG SRC="https://ad.doubleclick.net/ddm/trackimp/N8334.275400VERTICALSCOPEINC./B20209277.204028354;dc_trk_aid=407011718;dc_trk_cid=94070067;ord=;dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?" BORDER="0" HEIGHT="1" WIDTH="1" ALT="Advertisement">
Moderator: chevy57bert
To create a new topic in Engines, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
Attached by: stent
stent
in Engines
Views: 213
Comments: 13
Date: Yesterday
Time: 9:03pm
» Read last comment
Attached by:
Attached by: stent
stent
in Engines
Views: 213
Comments: 13
Date: Apr 16 '21
Time: 6:08pm
» Read last comment
Attached by:
kvargas1356
in Engines
Views: 85
Comments: 1
Date: Apr 11 '21
Time: 10:20pm
» Read last comment
Attached by:
Attached by: jfunkngroove
jfunkngroovejfunkngroove is online!
in Engines
Views: 269
Comments: 17
Date: Apr 10 '21
Time: 10:38pm
» Read last comment
Attached by:
Attached by: Mmusicman
Mmusicman
in Engines
Views: 85
Comments: 3
Date: Apr 08 '21
Time: 8:52pm
» Read last comment

Who is online

Users browsing this forum: No registered users and 20 guests