dropping idle randomly-IAC?

dropping idle randomly-IAC?

Postby redfury [OP] » March 17th 2014, 4:52pm

So, ever since I replaced the fuel pump on my van ( killed the coil, the fuel pump died, yadda yadda yadda ), I stared having a problem with my idle. Sometimes ( randomly, haven't been able to pinpoint the cause yet ) the idle will kill the engine it's so bad. If I just restart the van, it'll restart immediately, but will die. If I restart by holding the key for a second at run, then start, it'll idle again.

I've kinda narrowed it down to something with the IAC valve, since a key on engine off will reset the IAC. I also had a problem with the IAC when I was monkeying around with the motor and had the IAC valve out of the throttle body, plugged in and turned the key on and the pintle shot out of it across the interior of the van. It was a month later when I found the spring on top of the motor. Interestingly, I cannot control the IAC valve using a bidirectional scan tool with the motor running, which seems strange. However, when the van is running, the idle seems to adjust for load ( switching from Park to Drive with the brakes engaged )

I'm considering just replacing the valve, but for some reason I'm not confident that just changing it will affect much. Or, it could. I've got lean bank codes for both cylinders and wonder sometimes if the IAC isn't part of that problem since it affects both banks.
A temporary fix usually becomes a permanent solution, therefore it does not exist.
doghouse removal by me!http://www.youtube.com/watch?v=uIJ0kuROlbU
Original Poster [OP]
User avatar
redfury
U.S. Armed Forces
U.S. Armed Forces
Firing on 8 Cylinders (L3)
Firing on 8 Cylinders (L3)
Years of Membership: redfury has been a member for 10 full yearsredfury has been a member for 10 full yearsredfury has been a member for 10 full yearsredfury has been a member for 10 full yearsredfury has been a member for 10 full yearsredfury has been a member for 10 full yearsredfury has been a member for 10 full yearsredfury has been a member for 10 full yearsredfury has been a member for 10 full yearsredfury has been a member for 10 full years
Posts: 2958
Topics: 53
Images: 13
Joined: December 2010
Location: isanti, mn
Gender: Male
Alias (AKA): Mike
Van Model Year: 1998
Van Make/Model: Chevrolet Astro
Extra Info: LT 5.7L 4wd

 
  • Related topics
    Replies
    Views
    Last post

Return to Engines

It is currently March 1st 2021, 8:20am

Engines Forum
Engine Repairs, Modifications, Diagnostics, Tuning, Upgrading, Questions.

<a href="https://ad.doubleclick.net/ddm/trackclk/N8334.275400VERTICALSCOPEINC./B20209277.204028354;dc_trk_aid=407011718;dc_trk_cid=94070067;dc_lat=;dc_rdid=;tag_for_child_directed_treatment="target="_blank"><img src="https://tpc.googlesyndication.com/pagead/imgad?id=CICAgKDrrqWwMRCAARgcKAEyCN4sAjjtai4k" border="0" align="right">
<IMG SRC="https://ad.doubleclick.net/ddm/trackimp/N8334.275400VERTICALSCOPEINC./B20209277.204028354;dc_trk_aid=407011718;dc_trk_cid=94070067;ord=;dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?" BORDER="0" HEIGHT="1" WIDTH="1" ALT="Advertisement">
Moderator: chevy57bert
To create a new topic in Engines, click this button:
Previous topic Next topic

Who is online

Users browsing this forum: No registered users and 16 guests