Proper operating temp 2003

Proper operating temp 2003

Postby astroman97 [OP] » August 9th 2014, 3:31am

astroman97 wrote:My 2003 seems to run at 100 Celsius all the time hot IMHO...my 97 and 98 run just above 40-60...I figured the rad was plugged or clutch fan were not working correctly so I swapped it them with the 98 and installed a new thermostat everything but water pump...still runs at 100 was thinking a lower temp thermostat as mentioned ..as I will be replacing the transmission soon (heat is not a transmissions friend) would love to see it run cooler any other suggestions? :confused:
Original Poster [OP]
astroman97
Firing on 3 Cylinders (L1)
Firing on 3 Cylinders (L1)
Years of Membership: astroman97 has been a member for 9 full yearsastroman97 has been a member for 9 full yearsastroman97 has been a member for 9 full yearsastroman97 has been a member for 9 full yearsastroman97 has been a member for 9 full yearsastroman97 has been a member for 9 full yearsastroman97 has been a member for 9 full yearsastroman97 has been a member for 9 full yearsastroman97 has been a member for 9 full years
Posts: 368
Topics: 78
Images: 2
Joined: August 2011
Alias (AKA):
Van Model Year: 2003
Van Make/Model: GMC Safari
Extra Info: Also 97 both 2wd

  • Similar topics
    Replies
    Views
    Author

Re: Proper operating temp 2003

Postby Leeann_93 » August 9th 2014, 3:36am

That's better ;)

Now, 100°C is approx 212°F, which is the normal operating range for these engines. The thermostats are 195°, but they don't actually start to open until that and aren't fully open until 205°-210°. So this van is running completely normal. Your other vans are actually running a bit cool, which will help the engine build up carbon deposits and run a little less efficiently.

As for your transmission, if you regularly haul heavy loads or tow, definitely add a tranny cooler.

Now if the temp starts climbing above 100°C, you've got a problem.
'05 Astro AWD vin X
'02 Astro LS AWD vin X
'00 Astro LS AWD - WIP
'99 Safari XLE AWD - broke
'93 AWD EXT vin W - real broke
User avatar
Leeann_93
Team Leader
Team Leader
Firing on 8 Cylinders (L7)
Firing on 8 Cylinders (L7)
Years of Membership: Leeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full years
Posts: 13741
Topics: 44
Images: 17
Joined: December 2008
Location: MD
Gender: Female
Alias (AKA):
Van Model Year: 2005
Van Make/Model: Chevrolet Astro
Extra Info: LS AWD

Re: Proper operating temp 2003

Postby astroman97 [OP] » August 9th 2014, 3:45am

Def transmission cooler will be added when the rebuild goes in....guess I was thinking the 100temp contributed to the transmission failure ...though not completely gone yet def notice it less responsive than the 97 with a rebuilt transmission less than 10k ago..I just touch the gas and it lays rubber..the 2003 seems to sorta over rev a touch as it would with transmission slip ..thinking that would be where the loss of HP would be too?
Original Poster [OP]
astroman97
Firing on 3 Cylinders (L1)
Firing on 3 Cylinders (L1)
Years of Membership: astroman97 has been a member for 9 full yearsastroman97 has been a member for 9 full yearsastroman97 has been a member for 9 full yearsastroman97 has been a member for 9 full yearsastroman97 has been a member for 9 full yearsastroman97 has been a member for 9 full yearsastroman97 has been a member for 9 full yearsastroman97 has been a member for 9 full yearsastroman97 has been a member for 9 full years
Posts: 368
Topics: 78
Images: 2
Joined: August 2011
Alias (AKA):
Van Model Year: 2003
Van Make/Model: GMC Safari
Extra Info: Also 97 both 2wd

Re: Proper operating temp 2003

Postby Corsemoto » August 9th 2014, 3:56am

Corsemoto wrote:Wow, blast from the past!

Since then I've replaced fan clutch and with Jet Programmer plugged in, it shows temp is right around 200° or so even though the dash gauge reads higher so nothing to worry about.


I should add, I've also done a full cooling system flush/fill, new radiator, hoses, thermostat and transmission cooler.
User avatar
Corsemoto
AstroSafari Pioneer
AstroSafari Pioneer
Firing on 6 Cylinders (L3)
Firing on 6 Cylinders (L3)
Years of Membership: Corsemoto has been a member for 12 full yearsCorsemoto has been a member for 12 full yearsCorsemoto has been a member for 12 full yearsCorsemoto has been a member for 12 full yearsCorsemoto has been a member for 12 full yearsCorsemoto has been a member for 12 full yearsCorsemoto has been a member for 12 full yearsCorsemoto has been a member for 12 full yearsCorsemoto has been a member for 12 full yearsCorsemoto has been a member for 12 full yearsCorsemoto has been a member for 12 full yearsCorsemoto has been a member for 12 full years
Posts: 2648
Topics: 39
Images: 13
Joined: June 2008
Alias (AKA):
Van Model Year: 2004
Van Make/Model: Chevrolet Astro
Extra Info: LT AWD


 
  • Related topics
    Replies
    Views
    Last post

Return to Engines

It is currently March 7th 2021, 12:34pm

Engines Forum
Engine Repairs, Modifications, Diagnostics, Tuning, Upgrading, Questions.

<a href="https://ad.doubleclick.net/ddm/trackclk/N8334.275400VERTICALSCOPEINC./B20209277.204028354;dc_trk_aid=407011718;dc_trk_cid=94070067;dc_lat=;dc_rdid=;tag_for_child_directed_treatment="target="_blank"><img src="https://tpc.googlesyndication.com/pagead/imgad?id=CICAgKDrrqWwMRCAARgcKAEyCN4sAjjtai4k" border="0" align="right">
<IMG SRC="https://ad.doubleclick.net/ddm/trackimp/N8334.275400VERTICALSCOPEINC./B20209277.204028354;dc_trk_aid=407011718;dc_trk_cid=94070067;ord=;dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?" BORDER="0" HEIGHT="1" WIDTH="1" ALT="Advertisement">
Moderator: chevy57bert
To create a new topic in Engines, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
AppaTheAirBison
in Engines
Views: 66
Comments: 2
Date: Yesterday
Time: 8:54pm
» Read last comment
Attached by:
Attached by: MHM
MHM
in Engines
Views: 378
Comments: 22
Date: Mar 02 '21
Time: 2:20pm
» Read last comment
Attached by:
Attached by: MHM
MHM
in Engines
Views: 378
Comments: 22
Date: Mar 01 '21
Time: 7:27pm
» Read last comment
Attached by:
Ken2.7
in Engines
Views: 243
Comments: 10
Date: Feb 24 '21
Time: 2:02am
» Read last comment
Attached by:
Attached by: Mmusicman
Mmusicman
in Engines
Views: 243
Comments: 10
Date: Feb 23 '21
Time: 8:38pm
» Read last comment
Sponsors

Who is online

Users browsing this forum: Google [Bot] and 12 guests