P0740 and transmission acting wierd, went away at the shop..

P0740 and transmission acting wierd, went away at the shop..

Postby thesigma [OP] » September 16th 2020, 3:59pm

So a couple weeks back I jumped in the van to go to lunch, and it started doing this wierd shuddery thing at low speed, so I turned around and parked it at the office. Ran my little bluetooth OBD and Torgque app and pulled a code P0740 TCC circuit failure. tried to drive it again later and the same thing and it didn't seem to shift... left it sit a couple weeks as I had to go out of town and when I got back I started looking for a new ride and got a pre approved loan for the payment I was willing to have (but don't really want). looking around and not finding instant gratification, I called The local transmission shop and talked to them. They said theyd check it out and worst case about $2200 installed for a rebuilt tranny and I said I'd think about it. ended up driving it down a couple hours later after deciding I'd rather put another 2200 in the van. It does have 240K miles on it but in the last year and a half (and 20k miles) It has a new fuel pump, 4 new shocks, 4 new tires, and a rebuilt front end, I've maintained her faithfully since I owned it at about 88K miles, and it's been a really great vehicle. on the other hand I don't require the moderate offroad ability and cargo space anymore and it's not so good on gas as a daily driver. Ultimately I probably find a cheap little japanese beater to drive to work everyday (~10mi. no highway).

Anyway the shop calls me up yesterday (I dropped it off the prior night) and says now what exactly was the probelem because it seems to be working normally. No when I drove it over there it was worse than ever, I backed out of the parking spot fine but when I shifted to D it didn't want to go, had to give it a lot of gas to get going, and it shakes real bad at low speed up to about 30 MPH or so then when you brake it doesn't want to decelerate and starts shaking when you stop. I guess it was the torque converter clutch staying locked? it was maybe 2 mi from the office to the Transmission shop, so all told I dove it maybe 5 miles acting wierd.

They pulled the pan and asked when I had it serviced last. Fluid and filter about 6 months ago IIRC. said it looked great inside, but after talking more about the problem they still think it's on the way out and I"ll need a rebuild. I decided to drive it for now and see how it goes (won't be making any long trips in it). so far so good, drove it home and back to work this morning.

Read all 9 post's that caome up with p0740 in the search, seems like some people had it caused by electrical problems, but usually got other codes with it. I don't other than an evap solenoid code I've had forever.... they had a better scanner at the shop and said they got only those two codes also and the temp and realtime info looked normal. I also read about ignition switch causing some problems but that seemed different than my issue. I only wonder because I did have to replace my worn out lock cylinder (but not the switch) about 2 months ago.

Also my Headlight Auto on feature will quit working for sometime a couple times, both times it started working again after a trip to the shop.....(and no it's not the press the button 3 times till it chimes thing, I knopw about that and it wouldn't engage the feature at all)

I mention it because I want to rule out the possibility of say a bad ground or electrical problem that a rebuilt transmission wont fix. I hate wasting money......

Any thoughts?

Thanks!
3097820409
Original Poster [OP]
thesigma
Fueling (3/8 tank)
Fueling (3/8 tank)
Years of Membership: thesigma has been a member for 6 full yearsthesigma has been a member for 6 full yearsthesigma has been a member for 6 full yearsthesigma has been a member for 6 full yearsthesigma has been a member for 6 full yearsthesigma has been a member for 6 full years
Posts: 40
Topics: 6
Images: 10
Joined: February 2014
Gender: Male
Alias (AKA):
Van Model Year: 2005
Van Make/Model: Chevrolet Astro
Extra Info: AWD Passenger

  • Similar topics
    Replies
    Views
    Author
  • Transmission oil cooler leaks
    by Rod's Trucks » April 14th 2020, 8:20pm in Automatic
    11 Replies
    629 Views
    Last post by MmusicmanMmusicman is online! View the latest post
    April 22nd 2020, 2:03am
  • 1999 GMC Yukon Transmission fit inside of Astro/Safari?
    by gman » April 22nd 2020, 9:29pm in Automatic
    3 Replies
    310 Views
    Last post by Bikley View the latest post
    April 25th 2020, 6:06pm
  •  
    9
    13
    Last post by AstroSafari.com View the latest post
    September 22nd 2020, 7:33pm

Re: P0740 and transmission acting wierd, went away at the sh

Postby MechBob » September 16th 2020, 4:17pm

It is possible the wiring harness to the trans,or the one in the trans,has a spot rubbed in it,causing an intermittent problem,but they should have inspected them,as they had pan off and vehicle up in the air.I would have replaced the TCC solenoid,at that point,if I found nothing.As,many times,it is dirt in the solenoid,or it is failing.Will leave you 2 articles to read.
https://www.obd-codes.com/p0740
https://www.onallcylinders.com/2019/04/ ... converter/
Oh,yes,what you describe is the tcc being locked up when it should not be.
User avatar
MechBob
Blue Status (L2)
Blue Status (L2)
Years of Membership: MechBob has been a member for 2 full yearsMechBob has been a member for 2 full years
Posts: 1087
Topics: 11
Images: 12
Joined: August 2018
Gender: Male
Alias (AKA): Bob
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: 4x4

Re: P0740 and transmission acting wierd, went away at the sh

Postby thesigma [OP] » September 16th 2020, 5:49pm

Thanks MechBob.

So the solenoid looks like a cheap part. not sure I want to drop the pan and do it myself though, I don't have a lift and it sounds messy. I can understand a shop not wanting to do it either b/c it seems to me at nearly 250K miles, something else may go at some point.....

What do you think? I'm willing to put say 200 or so dollars in to trying with no warranty. but shopuld I expect much more life out the Tranny with that many miles? or should I just bite the bullet and replace with a rebuild?
3097820409
Original Poster [OP]
thesigma
Fueling (3/8 tank)
Fueling (3/8 tank)
Years of Membership: thesigma has been a member for 6 full yearsthesigma has been a member for 6 full yearsthesigma has been a member for 6 full yearsthesigma has been a member for 6 full yearsthesigma has been a member for 6 full yearsthesigma has been a member for 6 full years
Posts: 40
Topics: 6
Images: 10
Joined: February 2014
Gender: Male
Alias (AKA):
Van Model Year: 2005
Van Make/Model: Chevrolet Astro
Extra Info: AWD Passenger

Re: P0740 and transmission acting wierd, went away at the sh

Postby MechBob » September 16th 2020, 5:53pm

Not going to make a recommendation.bad practice.BUT,my 96 has 211,000(or more),original trans,and if just the TCC was acting up,I would be trying the repair. :D
User avatar
MechBob
Blue Status (L2)
Blue Status (L2)
Years of Membership: MechBob has been a member for 2 full yearsMechBob has been a member for 2 full years
Posts: 1087
Topics: 11
Images: 12
Joined: August 2018
Gender: Male
Alias (AKA): Bob
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: 4x4

Re: P0740 and transmission acting wierd, went away at the sh

Postby thesigma [OP] » September 20th 2020, 4:45pm

So it started acting up again Thursday and I parked it at home. not nearly as bad as before it just felt like the tourque converter clutch would stick a little then let go. I'm going to attempt to replace all the solenoids and wiring harness (looks like
I can get an electronic parts kit for about $200). anything else I should look at or replace while I'm in there? I'm only dropping the pan so I'm not going any deeper than that, and I don't have lift so I really don't want mess with the valve bodies unless I have to. The 1-2 shift isn't terribly smooth but hoping the solenoid might help? need to order parts soon to try and do the job next week.

Went and picked up a 2012 Toyata Camry with about 89K miles on so hopefully we have at least one reliable car for the next couple years....
3097820409
Original Poster [OP]
thesigma
Fueling (3/8 tank)
Fueling (3/8 tank)
Years of Membership: thesigma has been a member for 6 full yearsthesigma has been a member for 6 full yearsthesigma has been a member for 6 full yearsthesigma has been a member for 6 full yearsthesigma has been a member for 6 full yearsthesigma has been a member for 6 full years
Posts: 40
Topics: 6
Images: 10
Joined: February 2014
Gender: Male
Alias (AKA):
Van Model Year: 2005
Van Make/Model: Chevrolet Astro
Extra Info: AWD Passenger


 
  • Related topics
    Replies
    Views
    Last post

Return to Automatic

It is currently September 22nd 2020, 7:33pm

Automatic Forum
AutomaticThe purpose of an Automatic Transmission is similar to that of a manual transmission, the auto tranny's primary duty is to allow the engine to operate in its narrow range of speeds while providing a wide range of output speeds.
To create a new topic in Automatic, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
Chunkstyle
in Automatic
Views: 475
Comments: 6
Date: Aug 11 '20
Time: 8:25pm
» Read last comment
Attached by:
Attached by: Mmusicman
MmusicmanMmusicman is online!
in Automatic
Views: 336
Comments: 11
Date: Jul 26 '20
Time: 1:22pm
» Read last comment
Attached by:
Olivier02
in Automatic
Views: 283
Comments: 4
Date: Jun 13 '20
Time: 9:22pm
» Read last comment
Attached by:
SoccerMom4x4
in Automatic
Views: 847
Comments: 15
Date: Jun 12 '20
Time: 2:50pm
» Read last comment
Attached by:
SoccerMom4x4
in Automatic
Views: 847
Comments: 15
Date: Jun 11 '20
Time: 2:12pm
» Read last comment
Sponsors

Who is online

Users browsing this forum: No registered users and 11 guests