Ignition Issues

Ignition Issues

Postby WakkoWarner [OP] » July 20th 2021, 5:19pm

My mom's 2000 Astro had another distributor cap go bad. So, I decided it was time to install some new components. I got a new distributor under warranty (comes with a cap/rotor), and I replaced the ignition coil. As soon as I went to start it up, it didn't want to start. It finally started and seemed to be running smooth. I took it for a drive and the check engine light came on. The previous code was a PO300 (multiple misfires). The new code is a P1345 (camshaft/crankshaft position sensor correlation. I put the new distributor back in the same way it came out, so I have no idea what might be causing this.

Is it possible that the actual crankshaft position sensor is going bad (it is the original w/ 119,000 miles on it)? If anyone has any ideas, your input will be greatly appreciated. Thanks in advance.
Original Poster [OP]
WakkoWarner
Fueling (1/2 tank)
Fueling (1/2 tank)
Years of Membership: WakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full years
Posts: 55
Topics: 19
Joined: August 2011
Location: 200 miles from water, 2 feet from hell - aka Arizona
Gender: Male
Alias (AKA):
Van Model Year: 2000
Van Make/Model: Chevrolet Astro
Extra Info: LS 4.3L V6 RWD

  • Similar topics
    Replies
    Views
    Author
  • Ignition power won’t turn off
    by Timbomac » February 17th 2021, 10:15pm in Electrical
    6 Replies
    186 Views
    Last post by AstroWill View the latest post
    February 18th 2021, 10:50pm
  • Mystery occasional bad-start ignition?
    by johnv » March 1st 2021, 11:34pm in Electrical
    12 Replies
    362 Views
    Last post by Mmusicman View the latest post
    April 26th 2021, 6:37pm
  •  
    5
    60
    Last post by AstroSafari.com View the latest post
    August 2nd 2021, 6:56pm

Re: Ignition Issues

Postby Godron629 » July 20th 2021, 6:21pm

Similar thread: https://www.astrosafari.com/viewtopic.php?f=43&t=13784

Did you mark the distributor position before you took it out?

I'd try to TDC it and try the install again - this video https://www.youtube.com/watch?v=LOR-9JZUUI0 is good for distributor information.
User avatar
Godron629
Fueling (3/8 tank)
Fueling (3/8 tank)
Posts: 43
Topics: 3
Joined: August 2020
Location: Alberta, Canada
Alias (AKA):
Van Model Year: 2003
Van Make/Model: Chevrolet Astro
Extra Info: Cargo 4.3L V6 RWD

Re: Ignition Issues

Postby CopperFiremistCopperFiremist is online! » July 20th 2021, 6:29pm

Try a crank angle relearn
Pullin The Pass
User avatar
CopperFiremistCopperFiremist is online!
V8 Swap Achievement
V8 Swap Achievement
Firing on 2 Cylinders (L2)
Firing on 2 Cylinders (L2)
Years of Membership: CopperFiremist has been a member for 6 full yearsCopperFiremist has been a member for 6 full yearsCopperFiremist has been a member for 6 full yearsCopperFiremist has been a member for 6 full yearsCopperFiremist has been a member for 6 full yearsCopperFiremist has been a member for 6 full years
Posts: 1232
Topics: 25
Images: 6
Joined: March 2015
Location: Seattle Wa
Gender: Male
Alias (AKA): B
Van Model Year: 1998
Van Make/Model: Chevrolet Astro
Extra Info: LS Swap

Re: Ignition Issues

Postby WakkoWarner [OP] » July 20th 2021, 6:39pm

CopperFiremist wrote:Try a crank angle relearn


I do not have the necessary scan tool to do that.
Original Poster [OP]
WakkoWarner
Fueling (1/2 tank)
Fueling (1/2 tank)
Years of Membership: WakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full years
Posts: 55
Topics: 19
Joined: August 2011
Location: 200 miles from water, 2 feet from hell - aka Arizona
Gender: Male
Alias (AKA):
Van Model Year: 2000
Van Make/Model: Chevrolet Astro
Extra Info: LS 4.3L V6 RWD

Re: Ignition Issues

Postby WakkoWarner [OP] » July 20th 2021, 8:21pm

Well, it turns out that the distributor was one tooth off when it dropped back in. I guess that the oil pump drive must have turned just a little when it came out (I have had the distributor out numerous times over the years and it has always dropped right back into the correct position). I moved it one tooth back, bumped it until it dropped into the oil pump drive, then buttoned it all up. I cleared the engine code, then started it up - no check engine light. I took it for a drive and the light stayed out. So, I will be sure to pay closer attention to the rotor position if I have to do this again (and I can pretty much guarantee that I will have to at some point).
Original Poster [OP]
WakkoWarner
Fueling (1/2 tank)
Fueling (1/2 tank)
Years of Membership: WakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full yearsWakkoWarner has been a member for 9 full years
Posts: 55
Topics: 19
Joined: August 2011
Location: 200 miles from water, 2 feet from hell - aka Arizona
Gender: Male
Alias (AKA):
Van Model Year: 2000
Van Make/Model: Chevrolet Astro
Extra Info: LS 4.3L V6 RWD

Re: Ignition Issues

Postby Godron629 » July 20th 2021, 8:35pm

Nice to hear.

I use my phone camera on video mode with the flash on to see down to that oil pump slot, along a long flat-head screwdriver to get it lined up.
User avatar
Godron629
Fueling (3/8 tank)
Fueling (3/8 tank)
Posts: 43
Topics: 3
Joined: August 2020
Location: Alberta, Canada
Alias (AKA):
Van Model Year: 2003
Van Make/Model: Chevrolet Astro
Extra Info: Cargo 4.3L V6 RWD


 
  • Related topics
    Replies
    Views
    Last post

Return to Electrical

It is currently August 2nd 2021, 6:56pm

Electrical Forum
ElectricalDiscussion specific to electric components of vans. Category for alternators or batteries, starters and ignition parts, anything 12v and electrical issue like fuses, circuitry, wire, terminals, switches, connectors, bulbs, relays, and wiring. Voltage and amperage diagnosis.
To create a new topic in Electrical, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
Attached by: AstroWill
AstroWill
in Electrical
Views: 291
Comments: 27
Date: Today
Time: 2:00am
» Read last comment
Attached by:
cbeascbeas is online!
in Electrical
Views: 291
Comments: 27
Date: Today
Time: 12:03am
» Read last comment
Attached by:
the_brucethe_bruce is online!
in Electrical
Views: 98
Comments: 6
Date: Yesterday
Time: 2:18am
» Read last comment
Attached by:
zz88008
in Electrical
Views: 165
Comments: 5
Date: Jul 25 '21
Time: 8:09pm
» Read last comment
Attached by:
OldSchoolNoe
in Electrical
Views: 144
Comments: 7
Date: Jul 23 '21
Time: 8:34pm
» Read last comment
Sponsors

Who is online

Users browsing this forum: cbeascbeas is online!, the_brucethe_bruce is online! and 26 guests