94 Safari says it's doing 100 mph standing still.

94 Safari says it's doing 100 mph standing still.

Postby Bikley [OP] » June 8th 2020, 6:29pm

My daughter was driving the van and said the speedometer pegged and hasn't gone back down. It's an analog gauge.

It's still running normally so I'm assuming it's not the VSS. I'm wondering if anyone has had this happen and could offer some advice. Thanks
Original Poster [OP]
Bikley
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: Bikley has been a member for 2 full yearsBikley has been a member for 2 full years
Posts: 171
Topics: 20
Joined: June 2018
Gender: Male
Alias (AKA):
Van Model Year: 1994
Van Make/Model: GMC Safari
Extra Info: AWD Vin W

  • Similar topics
    Replies
    Views
    Author

Re: 94 Safari says it's doing 100 mph standing still.

Postby Bikley [OP] » June 8th 2020, 10:54pm

Update. She got it home and now it won't run at all. I'm thinking it probably is the VSS buffer. Any ideas would be greatly appreciated.
Original Poster [OP]
Bikley
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: Bikley has been a member for 2 full yearsBikley has been a member for 2 full years
Posts: 171
Topics: 20
Joined: June 2018
Gender: Male
Alias (AKA):
Van Model Year: 1994
Van Make/Model: GMC Safari
Extra Info: AWD Vin W

Re: 94 Safari says it's doing 100 mph standing still.

Postby Big_kid » June 9th 2020, 1:57am

Codes? 94 was OBD1, pull any codes with a paper clip on the 2 top right terminals in the connector. Install the jumper, key on, engine off, codes will flash starting with 12.
95 Astro Conversion of unknown irrelevant lineage
We have enough youth. How about a fountain of smart?
User avatar
Big_kid
Team Leader
Team Leader
Firing on 7 Cylinders (L7)
Firing on 7 Cylinders (L7)
Years of Membership: Big_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full years
Posts: 6772
Topics: 185
Images: 339
Joined: June 2008
Gender: Male
Alias (AKA):
Van Model Year: 1995
Van Make/Model: Chevrolet Astro
Extra Info: 2WD 5.7 V8

Re: 94 Safari says it's doing 100 mph standing still.

Postby Bikley [OP] » June 9th 2020, 3:10am

Now that I've had a chance to look at it the engine starts but wants to race and it has no power to the dash at all. No idiot lights, the speedo is pegged and all the other gauges are frozen.

It's getting too dark to mess with it tonight so for now that's all I have.
Original Poster [OP]
Bikley
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: Bikley has been a member for 2 full yearsBikley has been a member for 2 full years
Posts: 171
Topics: 20
Joined: June 2018
Gender: Male
Alias (AKA):
Van Model Year: 1994
Van Make/Model: GMC Safari
Extra Info: AWD Vin W

Re: 94 Safari says it's doing 100 mph standing still.

Postby MechBob » June 9th 2020, 8:09am

Behind the batery,there is a plug in connection,with fuse links.The connections corrode and you may find the problem there.
User avatar
MechBob
Firing on 2 Cylinders (L2)
Firing on 2 Cylinders (L2)
Years of Membership: MechBob has been a member for 2 full yearsMechBob has been a member for 2 full years
Posts: 1257
Topics: 11
Images: 12
Joined: August 2018
Gender: Male
Alias (AKA): Bob
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: 4x4

Re: 94 Safari says it's doing 100 mph standing still.

Postby Bikley [OP] » June 9th 2020, 10:56pm

Ok, I was able to power up my 1320 box with my jump start box and there were no codes but the alternator is only putting out 9 volts. I checked the connections behind the battery and everything seems intact.

I'm pretty sure the alternator is cooked but that doesn't explain the dash issues and the 1,900 rpm idle speed.

Next I guess I'll pull the instrument cluster and see if there's a short or something that could be the cause. I've never had an alternator go out and take the instruments out with it.
Original Poster [OP]
Bikley
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: Bikley has been a member for 2 full yearsBikley has been a member for 2 full years
Posts: 171
Topics: 20
Joined: June 2018
Gender: Male
Alias (AKA):
Van Model Year: 1994
Van Make/Model: GMC Safari
Extra Info: AWD Vin W

Re: 94 Safari says it's doing 100 mph standing still.

Postby Bikley [OP] » June 9th 2020, 11:29pm

Now after having set disconnected the battery is almost 12v again so at least that didn't fry.
Original Poster [OP]
Bikley
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: Bikley has been a member for 2 full yearsBikley has been a member for 2 full years
Posts: 171
Topics: 20
Joined: June 2018
Gender: Male
Alias (AKA):
Van Model Year: 1994
Van Make/Model: GMC Safari
Extra Info: AWD Vin W

Re: 94 Safari says it's doing 100 mph standing still.

Postby Bikley [OP] » June 16th 2020, 5:56pm

I have sorted this out. The alternator fried and took out a couple fuses. Everything seems to be working normally again.
Original Poster [OP]
Bikley
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: Bikley has been a member for 2 full yearsBikley has been a member for 2 full years
Posts: 171
Topics: 20
Joined: June 2018
Gender: Male
Alias (AKA):
Van Model Year: 1994
Van Make/Model: GMC Safari
Extra Info: AWD Vin W

Re: 94 Safari says it's doing 100 mph standing still.

Postby Big_kid » June 16th 2020, 10:59pm

Thank you for posting the followup!
95 Astro Conversion of unknown irrelevant lineage
We have enough youth. How about a fountain of smart?
User avatar
Big_kid
Team Leader
Team Leader
Firing on 7 Cylinders (L7)
Firing on 7 Cylinders (L7)
Years of Membership: Big_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full yearsBig_kid has been a member for 12 full years
Posts: 6772
Topics: 185
Images: 339
Joined: June 2008
Gender: Male
Alias (AKA):
Van Model Year: 1995
Van Make/Model: Chevrolet Astro
Extra Info: 2WD 5.7 V8


 
  • Related topics
    Replies
    Views
    Last post

Return to Electrical

It is currently January 25th 2021, 9:23pm

Electrical Forum
ElectricalDiscussion specific to electric components of vans. Category for alternators or batteries, starters and ignition parts, anything 12v and electrical issue like fuses, circuitry, wire, terminals, switches, connectors, bulbs, relays, and wiring. Voltage and amperage diagnosis.
To create a new topic in Electrical, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
OldSchoolNoe
in Electrical
Views: 148
Comments: 4
Date: Jan 19 '21
Time: 2:15am
» Read last comment
Attached by:
OldSchoolNoe
in Electrical
Views: 148
Comments: 4
Date: Jan 16 '21
Time: 9:23pm
» Read last comment
Attached by:
Attached by: AstroWill
AstroWill
in Electrical
Views: 732
Comments: 9
Date: Jan 15 '21
Time: 5:08am
» Read last comment
Attached by:
Attached by: markmitch
markmitch
in Electrical
Views: 211
Comments: 11
Date: Jan 04 '21
Time: 6:15pm
» Read last comment
Attached by:
doogaloo
in Electrical
Views: 211
Comments: 11
Date: Jan 04 '21
Time: 11:53am
» Read last comment
Sponsors

Who is online

Users browsing this forum: No registered users and 10 guests