Temp, fuel, some lights working/not on dash

Temp, fuel, some lights working/not on dash

Postby Hiker2187 [OP] » October 21st 2020, 5:20pm

So I've been trying to troubleshoot this problem for days, I thought it was the alternator which did have blown diodes, changed that out. But the problem still resides. The temperature gauge, the fuel gauge don't work. The low fuel light is on ABS light is on. Battery is new alternators new charging at 13.4-13.6. Check the fuses pulled the dash and my wits end here. Figured I would ask some of you guys before I take it into an electrician. Couple of Old-Timers told me that at the ground mechanic friend told me that it's the dash.
Original Poster [OP]
Hiker2187
Fueling (Empty tank)
Fueling (Empty tank)
Posts: 2
Topics: 1
Joined: October 2020
Alias (AKA):
Van Model Year: 2001
Van Make/Model: Chevrolet Astro
Extra Info: 4.3

  • Similar topics
    Replies
    Views
    Author

Re: Temp, fuel, some lights working/not on dash

Postby TBLBill » October 22nd 2020, 5:59pm

I would check the wiring and plugs behind the gauge cluster, maybe something is loose. Then, look at the rest of the wiring going toward the temp sensor, fuel pump, and ABS module. The only thing that I don't see that often is the temp not working though - fuel gauge/low fuel light is a common problem, ABS light could be a speed sensor.
TBLBill
Firing on 2 Cylinders (L1)
Firing on 2 Cylinders (L1)
Years of Membership: TBLBill has been a member for 3 full yearsTBLBill has been a member for 3 full yearsTBLBill has been a member for 3 full years
Posts: 220
Topics: 12
Images: 42
Joined: February 2018
Location: Scranton, PA
Gender: Male
Alias (AKA):
Van Model Year: 1999
Van Make/Model: Chevrolet Astro
Extra Info: LS RWD

Re: Temp, fuel, some lights working/not on dash

Postby Hiker2187 [OP] » October 22nd 2020, 6:19pm

I checked the cluster, pulled it and ran line down seens om. Could it be the cluster itself or multi func switch on the ignition?
Original Poster [OP]
Hiker2187
Fueling (Empty tank)
Fueling (Empty tank)
Posts: 2
Topics: 1
Joined: October 2020
Alias (AKA):
Van Model Year: 2001
Van Make/Model: Chevrolet Astro
Extra Info: 4.3

Re: Temp, fuel, some lights working/not on dash

Postby TBLBill » October 22nd 2020, 7:13pm

I'm not sure about the multi switch, but it could be the cluster. Can you get another one from a JY to test? Should be $10-20 to pull one.
TBLBill
Firing on 2 Cylinders (L1)
Firing on 2 Cylinders (L1)
Years of Membership: TBLBill has been a member for 3 full yearsTBLBill has been a member for 3 full yearsTBLBill has been a member for 3 full years
Posts: 220
Topics: 12
Images: 42
Joined: February 2018
Location: Scranton, PA
Gender: Male
Alias (AKA):
Van Model Year: 1999
Van Make/Model: Chevrolet Astro
Extra Info: LS RWD


 
  • Related topics
    Replies
    Views
    Last post

Return to Electrical

It is currently April 15th 2021, 8:07pm

Electrical Forum
ElectricalDiscussion specific to electric components of vans. Category for alternators or batteries, starters and ignition parts, anything 12v and electrical issue like fuses, circuitry, wire, terminals, switches, connectors, bulbs, relays, and wiring. Voltage and amperage diagnosis.
To create a new topic in Electrical, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
Attached by: GaryMacGuyver
GaryMacGuyver
in Electrical
Views: 66
Comments: 2
Date: Apr 10 '21
Time: 11:29am
» Read last comment
Attached by:
Attached by: stent
stent
in Electrical
Views: 1846
Comments: 36
Date: Apr 06 '21
Time: 11:08pm
» Read last comment
Attached by:
Attached by: stent
stent
in Electrical
Views: 1846
Comments: 36
Date: Apr 06 '21
Time: 9:58pm
» Read last comment
Attached by:
Ken2.7
in Electrical
Views: 1038
Comments: 33
Date: Apr 04 '21
Time: 2:38am
» Read last comment
Attached by:
Attached by: LumaWJ
LumaWJ
in Electrical
Views: 248
Comments: 4
Date: Apr 01 '21
Time: 8:38am
» Read last comment
Sponsors

Who is online

Users browsing this forum: No registered users and 18 guests