CEL not working correctly, Instrument panel?

CEL not working correctly, Instrument panel?

Postby Themistocles [OP] » November 28th 2020, 5:40pm

My CEL has been acting screwy over the last few months. When I turn the key to “On” with engine off, the light will light up for the test along with the others, But then will stay on along with the battery indicator. Sometimes however, the light will not turn on at all. When I start the engine the light immediately turns off. This situation will continue with or without active error codes in the the system. If I get an error code the light WILL NOT turn on while the engine is running.
What gives? Is the instrument panel at fault? Is it the PCM? If I replace the panel, how would I test a junk yard panel without plugging it into my car first?
Original Poster [OP]
Themistocles
Fueling (Empty tank)
Fueling (Empty tank)
Posts: 7
Topics: 4
Joined: November 2020
Alias (AKA):
Van Model Year: 2003
Van Make/Model: Chevrolet Astro
Extra Info: 4.3L V6 RWD

  • Similar topics
    Replies
    Views
    Author
  • Temp, fuel, some lights working/not on dash
    by Hiker2187 » October 21st 2020, 5:20pm in Electrical
    3 Replies
    289 Views
    Last post by TBLBill View the latest post
    October 22nd 2020, 7:13pm
  • low beams not working
    by david crockett » December 19th 2020, 9:18pm in Electrical
    2 Replies
    135 Views
    Last post by AstroWill View the latest post
    December 22nd 2020, 12:14am
  •  
    8
    40
    Last post by AstroSafari.com View the latest post
    April 21st 2021, 12:30am

Re: CEL not working correctly, Instrument panel?

Postby TBLBill » December 4th 2020, 1:25pm

I'm not sure of the cause, but I know some junkyards will let you bring in a good battery to hook up (if you can find a van with all the electronics still connected) to test it.
TBLBill
Firing on 2 Cylinders (L1)
Firing on 2 Cylinders (L1)
Years of Membership: TBLBill has been a member for 3 full yearsTBLBill has been a member for 3 full yearsTBLBill has been a member for 3 full years
Posts: 220
Topics: 12
Images: 42
Joined: February 2018
Location: Scranton, PA
Gender: Male
Alias (AKA):
Van Model Year: 1999
Van Make/Model: Chevrolet Astro
Extra Info: LS RWD


 
  • Related topics
    Replies
    Views
    Last post

Return to Electrical

It is currently April 21st 2021, 12:30am

Electrical Forum
ElectricalDiscussion specific to electric components of vans. Category for alternators or batteries, starters and ignition parts, anything 12v and electrical issue like fuses, circuitry, wire, terminals, switches, connectors, bulbs, relays, and wiring. Voltage and amperage diagnosis.
To create a new topic in Electrical, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
Attached by: GaryMacGuyver
GaryMacGuyver
in Electrical
Views: 76
Comments: 2
Date: Apr 10 '21
Time: 11:29am
» Read last comment
Attached by:
Attached by: stent
stent
in Electrical
Views: 1884
Comments: 36
Date: Apr 06 '21
Time: 11:08pm
» Read last comment
Attached by:
Attached by: stent
stent
in Electrical
Views: 1884
Comments: 36
Date: Apr 06 '21
Time: 9:58pm
» Read last comment
Attached by:
Ken2.7
in Electrical
Views: 1055
Comments: 33
Date: Apr 04 '21
Time: 2:38am
» Read last comment
Attached by:
Attached by: LumaWJ
LumaWJ
in Electrical
Views: 260
Comments: 4
Date: Apr 01 '21
Time: 8:38am
» Read last comment

Who is online

Users browsing this forum: MmusicmanMmusicman is online!, SurfinSafari97SurfinSafari97 is online! and 12 guests