astro van wont start after rain

astro van wont start after rain

Postby leegaddis32 [OP] » December 28th 2008, 6:18pm

not sure what happened but was running fine . has 190k on it but has been reliable as ever. just changed fuel pump dist cap and rotor plugs and wires not 6 months ago. it rained hard night before last and went to try to start and nothing. turns over and tries to start. i have noticed it running a little rough like a slight misfire last few weeks. any suggestions would be greatly appreciated
Original Poster [OP]
leegaddis32
Fueling (1/8 tank)
Fueling (1/8 tank)
Years of Membership: leegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full years
Posts: 24
Topics: 4
Joined: December 2008
Gender: Male
Alias (AKA):

  • Similar topics
    Replies
    Views
    Author
  • Just wont start
    by ChevyChase » September 2nd 2020, 3:57pm in Electrical
    1 Replies
    117 Views
    Last post by sixsix View the latest post
    September 2nd 2020, 9:24pm
  • Engine stays revving after highway run
    by smokinjoe » May 30th 2020, 1:58am in Electrical
    1 Replies
    174 Views
    Last post by M_a_t_t View the latest post
    May 30th 2020, 3:06am
  •  
    6
    23
    Last post by AstroSafari.com View the latest post
    October 26th 2020, 1:55am

Re: astro van wont start after rain

Postby marcus38 » December 29th 2008, 12:31am

i would recheck the dist cap for moisture and plug wires especially the coil wire.
1990 astro CS 4.3 z engine 700r trans 2WD radical custom build
marcus38
Firing on 2 Cylinders (L1)
Firing on 2 Cylinders (L1)
Years of Membership: marcus38 has been a member for 12 full yearsmarcus38 has been a member for 12 full yearsmarcus38 has been a member for 12 full yearsmarcus38 has been a member for 12 full yearsmarcus38 has been a member for 12 full yearsmarcus38 has been a member for 12 full yearsmarcus38 has been a member for 12 full yearsmarcus38 has been a member for 12 full yearsmarcus38 has been a member for 12 full yearsmarcus38 has been a member for 12 full yearsmarcus38 has been a member for 12 full yearsmarcus38 has been a member for 12 full years
Posts: 297
Topics: 35
Images: 5
Joined: June 2008
Gender: Male
Alias (AKA): mark

Re: astro van wont start after rain

Postby astro355 » December 29th 2008, 5:53pm

marcus38 wrote:i would recheck the dist cap for moisture and plug wires especially the coil wire.


x2
If the misfire you spoke of is ignition related, moisture would surely of made the problem into a no start condition.
Diagnose 1st, never be a parts changer!

355 small block chevy w/ modified 700R4

Image
User avatar
astro355
V8 Swap Achievement
V8 Swap Achievement
Firing on 4 Cylinders (L6)
Firing on 4 Cylinders (L6)
Years of Membership: astro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full years
Posts: 5484
Topics: 57
Joined: May 2008
Location: Cleveland, OH
Gender: Male
Alias (AKA):
Van Model Year: 1989
Van Make/Model: Chevrolet Astro
Extra Info: 355 V8 700R4

Re: astro van wont start after rain

Postby leegaddis32 [OP] » December 30th 2008, 11:45pm

it started but was real hard to start sort of like it flooded out. but checked all those things before it started and it still wouldnt start. not sure what the heck happened
Original Poster [OP]
leegaddis32
Fueling (1/8 tank)
Fueling (1/8 tank)
Years of Membership: leegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full years
Posts: 24
Topics: 4
Joined: December 2008
Gender: Male
Alias (AKA):

Re: astro van wont start after rain

Postby astro355 » December 31st 2008, 1:59am

Did it get better while the engine warmed up?

Glad you got it running. When you have a misfire, damp weather will always make it worse.
Diagnose 1st, never be a parts changer!

355 small block chevy w/ modified 700R4

Image
User avatar
astro355
V8 Swap Achievement
V8 Swap Achievement
Firing on 4 Cylinders (L6)
Firing on 4 Cylinders (L6)
Years of Membership: astro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full years
Posts: 5484
Topics: 57
Joined: May 2008
Location: Cleveland, OH
Gender: Male
Alias (AKA):
Van Model Year: 1989
Van Make/Model: Chevrolet Astro
Extra Info: 355 V8 700R4

Re: astro van wont start after rain

Postby leegaddis32 [OP] » August 6th 2009, 1:44am

its done it a couple more times seems to run rough when it rains but when it pours it seems like it wont start for about 3 hours after its done raining----here lately seems like it has a constant "miss" checked all the obvisious
Original Poster [OP]
leegaddis32
Fueling (1/8 tank)
Fueling (1/8 tank)
Years of Membership: leegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full years
Posts: 24
Topics: 4
Joined: December 2008
Gender: Male
Alias (AKA):

Re: astro van wont start after rain

Postby leegaddis32 [OP] » August 8th 2009, 2:18pm

seems be getting worse didnt rain that hard last night but got up to go fishing and low and behold no starting of the van sprayed the wires with wire dryer guess go try start in a few to see what happens lol
Original Poster [OP]
leegaddis32
Fueling (1/8 tank)
Fueling (1/8 tank)
Years of Membership: leegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full years
Posts: 24
Topics: 4
Joined: December 2008
Gender: Male
Alias (AKA):

Re: astro van wont start after rain

Postby guyonearth » August 8th 2009, 3:57pm

Condensation on the coil tower, probably, exacerbated by a loose coil wire. I would clean all your terminals and make sure they are sealed with dielectric grease. When I had this problem spraying the coil down with WD-40 and using a little starting fluid would usually get it going.
guyonearth
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: guyonearth has been a member for 11 full yearsguyonearth has been a member for 11 full yearsguyonearth has been a member for 11 full yearsguyonearth has been a member for 11 full yearsguyonearth has been a member for 11 full yearsguyonearth has been a member for 11 full yearsguyonearth has been a member for 11 full yearsguyonearth has been a member for 11 full yearsguyonearth has been a member for 11 full yearsguyonearth has been a member for 11 full yearsguyonearth has been a member for 11 full years
Posts: 185
Topics: 5
Joined: June 2009
Gender: Male
Alias (AKA): DeanC

Re: astro van wont start after rain

Postby leegaddis32 [OP] » August 8th 2009, 5:48pm

it started but not sure what the problem is sprayed everything down but it sit for a while and it will usually starts a few hours after rain. it used to only happen after a hard rain now it seems to do it just with a little rain or a lot of humidity
Original Poster [OP]
leegaddis32
Fueling (1/8 tank)
Fueling (1/8 tank)
Years of Membership: leegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full years
Posts: 24
Topics: 4
Joined: December 2008
Gender: Male
Alias (AKA):

Re: astro van wont start after rain

Postby SafariBrutus » August 9th 2009, 5:48am

I had that problem too. When it was damp and the van was cold, it simply wouldn't start. Soon as it dried out it started and ran fine. Mechanic said "I know exactly what's wrong. You have a cracked distributer cap!" The cap looked fine to me, but it must have been bad because the problem went away as soon as I put a new dist cap on.
SafariBrutus
Fueling (Empty tank)
Fueling (Empty tank)
Years of Membership: SafariBrutus has been a member for 12 full yearsSafariBrutus has been a member for 12 full yearsSafariBrutus has been a member for 12 full yearsSafariBrutus has been a member for 12 full yearsSafariBrutus has been a member for 12 full yearsSafariBrutus has been a member for 12 full yearsSafariBrutus has been a member for 12 full yearsSafariBrutus has been a member for 12 full yearsSafariBrutus has been a member for 12 full yearsSafariBrutus has been a member for 12 full yearsSafariBrutus has been a member for 12 full yearsSafariBrutus has been a member for 12 full years
Posts: 7
Topics: 1
Joined: April 2008
Alias (AKA):
Van Make/Model: GMC Safari
Extra Info: LTE 4.3L V6 RWD

Re: astro van wont start after rain

Postby astro355 » August 9th 2009, 5:56pm

leegaddis32 wrote:not sure what happened but was running fine . has 190k on it but has been reliable as ever. just changed fuel pump dist cap and rotor plugs and wires not 6 months ago. it rained hard night before last and went to try to start and nothing. turns over and tries to start. i have noticed it running a little rough like a slight misfire last few weeks. any suggestions would be greatly appreciated


What year is your van?
Diagnose 1st, never be a parts changer!

355 small block chevy w/ modified 700R4

Image
User avatar
astro355
V8 Swap Achievement
V8 Swap Achievement
Firing on 4 Cylinders (L6)
Firing on 4 Cylinders (L6)
Years of Membership: astro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full years
Posts: 5484
Topics: 57
Joined: May 2008
Location: Cleveland, OH
Gender: Male
Alias (AKA):
Van Model Year: 1989
Van Make/Model: Chevrolet Astro
Extra Info: 355 V8 700R4

Re: astro van wont start after rain

Postby mattsrevenge » August 10th 2009, 7:42pm

i 2x guyonearth's
i had the about same issue, my was the coil, shorting to the bracket that holds to the top of the intake.

i let the engine warm up (so the water could evaporate) and used a spray bottle of water, to wet down the top end components of the van with the doghouse off.
see my short vids on this

http://www.youtube.com/watch?v=Lm2MB_1FngA

http://www.youtube.com/watch?v=bt1gKHEPFPU
96 astro conversion
98 crown vic p71
User avatar
mattsrevenge
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: mattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full years
Posts: 106
Topics: 8
Joined: August 2008
Location: indianapolis
Gender: Male
Alias (AKA):
Van Make/Model: Chevrolet Astro
Extra Info: 2wd conversion

Re: astro van wont start after rain

Postby leegaddis32 [OP] » August 13th 2009, 9:34pm

went and got another distributor cap and rotor and seems to be fine but it hasnt rained to put it to the test. the parts man said that he knows folks that have to replace the distributor cap every year on these vans said its a bad design problem on the distributor---not sure how true it is but seems to make sense i guess
Original Poster [OP]
leegaddis32
Fueling (1/8 tank)
Fueling (1/8 tank)
Years of Membership: leegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full years
Posts: 24
Topics: 4
Joined: December 2008
Gender: Male
Alias (AKA):

Re: astro van wont start after rain

Postby leegaddis32 [OP] » August 13th 2009, 9:36pm

2000 astro---nice video man will have to replace the coil just in case this weekend. greatly appreciate all the input and suggestions
Original Poster [OP]
leegaddis32
Fueling (1/8 tank)
Fueling (1/8 tank)
Years of Membership: leegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full yearsleegaddis32 has been a member for 11 full years
Posts: 24
Topics: 4
Joined: December 2008
Gender: Male
Alias (AKA):

Re: astro van wont start after rain

Postby $uperJoe » August 13th 2009, 9:46pm

just wondering if the van hasnt moved over night and it wont start after a rain, how much rain do you get to get water up inside the motor cover. do you leave the hood open at night? i am from a low rain area but dont see how it can get that far into the doghouse latteraly without the vehicle moving. am i missing something?
Don't explain it poorly 5 times. Take the 15 seconds to go out and take a picture of it!!
Please do not confuse idle conversation with technical advise


Check out my Van build
User avatar
$uperJoe
Firing on 4 Cylinders (L2)
Firing on 4 Cylinders (L2)
Years of Membership: $uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years
Posts: 1416
Topics: 59
Joined: July 2009
Alias (AKA):
Van Make/Model: GMC Safari

Re: astro van wont start after rain

Postby mattsrevenge » May 3rd 2010, 8:48pm

resurrection!

hey folks, so i have the same problem as last time. my videos up there, sparky coil, etc, occur again.

ive had 3 caps, 3 rotors, new plugs, wires, and 4 coils on the astro.
best that i could figure, is that the block has a bad ground?
getting my stupid q's out of the way...
-engine block ground, does it ground thru the engine mounts?
where is the OEM ground? i couldnt find anything near to this, i didnt get under the vehicle though.

i replaced the last coils on warranty. (yay keeping reciepts) the plugs (it was due) and the wires (was also due) where prevnt maint.
but the caps, rotor (yes yes, acdelco only), i tried 2 aftermarkets, and then paid in full for the OEM (thats currently on the 'stro now).

so, the coil bots to the intake, on an alum surface. does this ground to the motor? or in the plastic intake, its set and not grounded.
either way, it was my process of elimination that the engine had bad/missing ground from the block to the body, etc.
fig'd that if the block isnt grounded properly, the spark from the coil, thru the wire, to the plug isnt grounding to the electrode on the plug, and causing resistance when its trying to fire. (concur or flame me for being wrong? lol)

when i replaced the coil up at my 'rents house (178 miles from home) when the van wouldnt start for me, this time i added a 10ga grounding wire from the back passenger head a major body ground (both cleaned, prepped, etc) and the van seemed to be 'more happy' and run 'stronger' than it has in the past 2 years. engine had more power, w/ a load (400+lbs of stuff) and a full tank, + runing the a/c. that and i observed crazy +++ in MPG from rents to home.
i observed 13 gal to get 178 miles, then 7 gal to return home, both w/ a/c and the return trip +400lb in weight added.

thoughts?
96 astro conversion
98 crown vic p71
User avatar
mattsrevenge
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: mattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full years
Posts: 106
Topics: 8
Joined: August 2008
Location: indianapolis
Gender: Male
Alias (AKA):
Van Make/Model: Chevrolet Astro
Extra Info: 2wd conversion

Re: astro van wont start after rain

Postby astroturf » May 3rd 2010, 10:38pm

WOW, You may be on to something Matt. I'm still learning a lot, But it sounds as though you have hit it on the head. I'll wait and let others chime in now. Did you grab any pix of it? Thanks, Jim
My Cup is neither half empty nor half full... But has a hole in it. Holy Cup Holders Batman. LOLz, Jim
User avatar
astroturf
U.S. Armed Forces
U.S. Armed Forces
Firing on 8 Cylinders (L7)
Firing on 8 Cylinders (L7)
Years of Membership: astroturf has been a member for 11 full yearsastroturf has been a member for 11 full yearsastroturf has been a member for 11 full yearsastroturf has been a member for 11 full yearsastroturf has been a member for 11 full yearsastroturf has been a member for 11 full yearsastroturf has been a member for 11 full yearsastroturf has been a member for 11 full yearsastroturf has been a member for 11 full yearsastroturf has been a member for 11 full yearsastroturf has been a member for 11 full years
Posts: 9005
Topics: 112
Joined: August 2009
Location: Richmond, VA
Gender: Male
Alias (AKA):
Van Make/Model: Chevrolet Astro
Extra Info: 2wd Passenger

Re: astro van wont start after rain

Postby Leeann_93 » May 3rd 2010, 11:11pm

Grounds should be:

LH Radiator Support
RH Radiator Support
LH Cylinder Head
Generator Bracket
Firewall, extreme passenger side of the engine compartment
'05 Astro AWD vin X
'02 Astro LS AWD vin X
'00 Astro LS AWD - WIP
'99 Safari XLE AWD - broke
'93 AWD EXT vin W - real broke
User avatar
Leeann_93
Team Leader
Team Leader
Firing on 8 Cylinders (L7)
Firing on 8 Cylinders (L7)
Years of Membership: Leeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full years
Posts: 13497
Topics: 44
Images: 17
Joined: December 2008
Location: MD
Gender: Female
Alias (AKA):
Van Model Year: 2005
Van Make/Model: Chevrolet Astro
Extra Info: LS AWD

Re: astro van wont start after rain

Postby Astroplane » May 4th 2010, 6:02am

mattsrevenge wrote:-engine block ground, does it ground thru the engine mounts?
where is the OEM ground?

Engine ground is next to the crankshaft balancer on the front of the block. Main body ground is on the radiator support in front of the battery. The coil itself does not need to be grounded, but the ICM (module)has a ground that splits at a splice and terminates at the thermostat housing and the left rear of the engine block near the knock sensor.
User avatar
Astroplane
Blue Status (L2)
Blue Status (L2)
Years of Membership: Astroplane has been a member for 10 full yearsAstroplane has been a member for 10 full yearsAstroplane has been a member for 10 full yearsAstroplane has been a member for 10 full yearsAstroplane has been a member for 10 full yearsAstroplane has been a member for 10 full yearsAstroplane has been a member for 10 full yearsAstroplane has been a member for 10 full yearsAstroplane has been a member for 10 full yearsAstroplane has been a member for 10 full years
Posts: 1048
Topics: 4
Joined: January 2010
Alias (AKA):
Van Make/Model: Chevrolet Astro
Extra Info: LT RWD

Re: astro van wont start after rain

Postby mattsrevenge » May 4th 2010, 2:33pm

thanks on the ground locations,

the RH firewall (facing the astro, driver side) and the firewall (above the blower motor) ive pulled and cleaned (they where clean, no rust/corrosion), and its the ground above the blower that i wired my pass side head bolt to (it holds one of the wire pack retention clips). i pulled the ground on the drivers side of the head and cleaned those as well (besides covered in oil, metal was clean under the bolt). so that leaves me with the

-LH radiator support
-generator braket (and i bring this one up becuase 4 years ago the van chewed thru 2 alternators in 30 days... i didnt repair that one, before i own, shop did r&r 1st time, and then diff shop did 2x under warranty)
-ICM (module)

ill be checking those later this week/weekend (whenver i FIND time haha)

much thanks everyone :rolling:
96 astro conversion
98 crown vic p71
User avatar
mattsrevenge
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: mattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full yearsmattsrevenge has been a member for 12 full years
Posts: 106
Topics: 8
Joined: August 2008
Location: indianapolis
Gender: Male
Alias (AKA):
Van Make/Model: Chevrolet Astro
Extra Info: 2wd conversion

Next

 
  • Related topics
    Replies
    Views
    Last post

Return to Electrical

It is currently October 26th 2020, 1:55am

Electrical Forum
ElectricalDiscussion specific to electric components of vans. Category for alternators or batteries, starters and ignition parts, anything 12v and electrical issue like fuses, circuitry, wire, terminals, switches, connectors, bulbs, relays, and wiring. Voltage and amperage diagnosis.
To create a new topic in Electrical, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
Attached by: Leeann_93
Leeann_93
in Electrical
Views: 100
Comments: 7
Date: Oct 24 '20
Time: 3:02pm
» Read last comment
Attached by:
donbenny1915
in Electrical
Views: 198
Comments: 4
Date: Oct 23 '20
Time: 1:44am
» Read last comment
Attached by:
nwisehart
in Electrical
Views: 118
Comments: 3
Date: Oct 21 '20
Time: 12:44am
» Read last comment
Attached by:
Olivier02
in Electrical
Views: 116
Comments: 3
Date: Oct 11 '20
Time: 8:34pm
» Read last comment
Attached by:
Attached by: Leeann_93
Leeann_93
in Electrical
Views: 170
Comments: 4
Date: Oct 10 '20
Time: 5:08pm
» Read last comment
Sponsors

Who is online

Users browsing this forum: No registered users and 10 guests