Radio Problem

Radio Problem

Postby Yaycandy [OP] » July 8th 2012, 8:16pm

I was wiring in an aftermarket radio, i didnt unhook battery, but when i installed it. A fuse blew. Looked at every fuse in van ans everyone is fine and works fine. My radio fuse is fine too but when van is turned on, radio dont turn on. So until i find problem i have it jimmyed through my cb that is connected directly to battery. Is there a fuse on the hotwire of the radio wirescor anyother fuses behind dash that could of blown? Thanks
Original Poster [OP]
Yaycandy
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: Yaycandy has been a member for 8 full yearsYaycandy has been a member for 8 full yearsYaycandy has been a member for 8 full yearsYaycandy has been a member for 8 full yearsYaycandy has been a member for 8 full yearsYaycandy has been a member for 8 full yearsYaycandy has been a member for 8 full yearsYaycandy has been a member for 8 full years
Posts: 156
Topics: 34
Joined: March 2012
Gender: Male
Alias (AKA):
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: AWD EXT CL 206k

  • Similar topics
    Replies
    Views
    Author
  • 12V radio line on all the time
    by paulbot » September 9th 2020, 11:34pm in Electrical
    10 Replies
    354 Views
    Last post by MechBob View the latest post
    September 17th 2020, 5:58am
  • 2004 Astro Cargo Van Power door Lock Problem / Questions
    by DD1 » October 9th 2020, 4:12am in Electrical
    6 Replies
    418 Views
    Last post by AstroWill View the latest post
    November 26th 2020, 1:40am
  •  
    7
    10
    Last post by AstroSafari.com View the latest post
    January 28th 2021, 6:07am

Re: Radio Problem

Postby Phantom » July 8th 2012, 8:37pm

Yaycandy wrote:I was wiring in an aftermarket radio, i didnt unhook battery, but when i installed it. A fuse blew. Looked at every fuse in van ans everyone is fine and works fine. My radio fuse is fine too but when van is turned on, radio dont turn on. So until i find problem i have it jimmyed through my cb that is connected directly to battery. Is there a fuse on the hotwire of the radio wirescor anyother fuses behind dash that could of blown? Thanks

If you looked at every fuse and they are fine , how did you determine you blew a fuse?
there are 2 fuses
1 for memory
1 for radio power

owners manual will help you ID them
Phantom
Firing on 7 Cylinders (L4)
Firing on 7 Cylinders (L4)
Years of Membership: Phantom has been a member for 10 full yearsPhantom has been a member for 10 full yearsPhantom has been a member for 10 full yearsPhantom has been a member for 10 full yearsPhantom has been a member for 10 full yearsPhantom has been a member for 10 full yearsPhantom has been a member for 10 full yearsPhantom has been a member for 10 full yearsPhantom has been a member for 10 full yearsPhantom has been a member for 10 full years
Posts: 3725
Topics: 15
Joined: July 2010
Alias (AKA):
Van Make/Model: Chevrolet Astro

Re: Radio Problem

Postby Yaycandy [OP] » July 8th 2012, 9:35pm

When i hooked it up, it sounded like a relay kicked. But it could of been the fuse behind the dash connected to the hotwire to the radio, if the van even has one back there
Original Poster [OP]
Yaycandy
Firing on 1 Cylinder (L1)
Firing on 1 Cylinder (L1)
Years of Membership: Yaycandy has been a member for 8 full yearsYaycandy has been a member for 8 full yearsYaycandy has been a member for 8 full yearsYaycandy has been a member for 8 full yearsYaycandy has been a member for 8 full yearsYaycandy has been a member for 8 full yearsYaycandy has been a member for 8 full yearsYaycandy has been a member for 8 full years
Posts: 156
Topics: 34
Joined: March 2012
Gender: Male
Alias (AKA):
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: AWD EXT CL 206k

Re: Radio Problem

Postby Phantom » July 8th 2012, 9:45pm

Yaycandy wrote:When i hooked it up, it sounded like a relay kicked. But it could of been the fuse behind the dash connected to the hotwire to the radio, if the van even has one back there

Both fuses are located in the fuse block down behind the brake pedal
Phantom
Firing on 7 Cylinders (L4)
Firing on 7 Cylinders (L4)
Years of Membership: Phantom has been a member for 10 full yearsPhantom has been a member for 10 full yearsPhantom has been a member for 10 full yearsPhantom has been a member for 10 full yearsPhantom has been a member for 10 full yearsPhantom has been a member for 10 full yearsPhantom has been a member for 10 full yearsPhantom has been a member for 10 full yearsPhantom has been a member for 10 full yearsPhantom has been a member for 10 full years
Posts: 3725
Topics: 15
Joined: July 2010
Alias (AKA):
Van Make/Model: Chevrolet Astro


 
  • Related topics
    Replies
    Views
    Last post

Return to Electrical

It is currently January 28th 2021, 6:07am

Electrical Forum
ElectricalDiscussion specific to electric components of vans. Category for alternators or batteries, starters and ignition parts, anything 12v and electrical issue like fuses, circuitry, wire, terminals, switches, connectors, bulbs, relays, and wiring. Voltage and amperage diagnosis.
To create a new topic in Electrical, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
Attached by: oneilldm
oneilldm
in Electrical
Views: 121
Comments: 8
Date: Today
Time: 4:39am
» Read last comment
Attached by:
OldSchoolNoe
in Electrical
Views: 156
Comments: 4
Date: Jan 19 '21
Time: 2:15am
» Read last comment
Attached by:
OldSchoolNoe
in Electrical
Views: 156
Comments: 4
Date: Jan 16 '21
Time: 9:23pm
» Read last comment
Attached by:
Attached by: AstroWill
AstroWill
in Electrical
Views: 733
Comments: 9
Date: Jan 15 '21
Time: 5:08am
» Read last comment
Attached by:
Attached by: markmitch
markmitch
in Electrical
Views: 216
Comments: 11
Date: Jan 04 '21
Time: 6:15pm
» Read last comment
Sponsors

Who is online

Users browsing this forum: No registered users and 18 guests

cron