Turn signals stoped working.

Turn signals stoped working.

Postby hotrodmike [OP] » April 26th 2009, 10:19am

I recently installed those front clear corner lenses on my 89 Astro.After putting in the new orange bulbs,and turn signal bulbs,My turn signals now will not blink on thier own,including the back ones.They were working just fine before.Please, any help would be totally appreciated.Thank you. :feedback: :confused:
Original Poster [OP]
User avatar
hotrodmike
Fueling (Empty tank)
Fueling (Empty tank)
Years of Membership: hotrodmike has been a member for 12 full yearshotrodmike has been a member for 12 full yearshotrodmike has been a member for 12 full yearshotrodmike has been a member for 12 full yearshotrodmike has been a member for 12 full yearshotrodmike has been a member for 12 full yearshotrodmike has been a member for 12 full yearshotrodmike has been a member for 12 full yearshotrodmike has been a member for 12 full yearshotrodmike has been a member for 12 full yearshotrodmike has been a member for 12 full yearshotrodmike has been a member for 12 full years
Posts: 11
Topics: 6
Joined: March 2008
Location: Marysville,Washington
Gender: Male
Alias (AKA): hotrodmike
Van Make/Model: Chevrolet Astro
Extra Info: 4.3 V6 RWD

  • Similar topics
    Replies
    Views
    Author
  • E-brake warning light won't turn off
    by AngryPunk » November 12th 2020, 3:43pm in Electrical
    7 Replies
    172 Views
    Last post by AstroWill View the latest post
    November 16th 2020, 6:37pm
  • No power when I turn the key
    by Travus123 » January 20th 2021, 8:07am in Electrical
    6 Replies
    140 Views
    Last post by AstroWill View the latest post
    January 22nd 2021, 4:40am
  •  
    7
    97
    Last post by AstroSafari.com View the latest post
    March 1st 2021, 2:38am

Re: Turn signals stoped working.

Postby Matrixx » April 26th 2009, 10:47am

Hi hotrodmike

Usually this is caused by a burnt out light bulb, but you mentioned it does it on both sides. I would recheck to make sure you have the correct bulbs in the sockets and everything is hooked up properly with the changes you made to it.

Always go back to what was done last that could have lead to this problem. Make sure the units are grounded properly as well. Hope this helps.:)
96-GMC Safari - Rwd - Original Transmission - Exhaust - Air Cared - 3.73 Limited Slip Rear End - Motor Replaced - 91 octane (Chevron) for the last 14 years - MFI Upgrade - 640,000 Kilometers.
User avatar
Matrixx
AstroSafari Pioneer
AstroSafari Pioneer
Firing on 6 Cylinders (L3)
Firing on 6 Cylinders (L3)
Years of Membership: Matrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full yearsMatrixx has been a member for 13 full years
Posts: 2640
Topics: 14
Joined: January 2008
Alias (AKA):

Re: Turn signals stoped working.

Postby gtkane » April 26th 2009, 3:08pm

Like Matrixx said check the new bulbs. Maybe you have 1156NA where there should be 1157Na.
General Motors master tech from friendly Manitoba.

Perfecting the fine art of more cost, less performance, since 1987!

User album #4...check it out!
User avatar
gtkane
Firing on 6 Cylinders (L1)
Firing on 6 Cylinders (L1)
Years of Membership: gtkane has been a member for 13 full yearsgtkane has been a member for 13 full yearsgtkane has been a member for 13 full yearsgtkane has been a member for 13 full yearsgtkane has been a member for 13 full yearsgtkane has been a member for 13 full yearsgtkane has been a member for 13 full yearsgtkane has been a member for 13 full yearsgtkane has been a member for 13 full yearsgtkane has been a member for 13 full yearsgtkane has been a member for 13 full yearsgtkane has been a member for 13 full yearsgtkane has been a member for 13 full years
Posts: 699
Topics: 11
Joined: February 2008
Location: Poplar Point,Manitoba
Gender: Male
Alias (AKA): Astruck
Van Make/Model: Chevrolet Astro
Extra Info: nasty 4.3

Re: Turn signals stoped working.

Postby ihatemybike » April 26th 2009, 5:28pm

I lost the signals on my 94 for a quite a while, couldn't figure it out. Then I was informed that there are two flashers, one in the main under dash fuse block, the other up under the dash that can been seen when looking up from the drivers foot well. Replacing the hidden one is what fixed my signals.
Aaron

2005 Astro (Gandalf) - AWD, 4.3L, 3.42, 130k+ miles
1997 Astro (Grumpy - $250 Rally Van) - AWD, 4.3L, 3.42, LSD, 2" lift, 31" tires, 335k+ orig engine, $30 eBay fuel pump
Prev Astros:99,97,00,94,87,86
ihatemybike
Firing on 6 Cylinders (L2)
Firing on 6 Cylinders (L2)
Years of Membership: ihatemybike has been a member for 12 full yearsihatemybike has been a member for 12 full yearsihatemybike has been a member for 12 full yearsihatemybike has been a member for 12 full yearsihatemybike has been a member for 12 full yearsihatemybike has been a member for 12 full yearsihatemybike has been a member for 12 full yearsihatemybike has been a member for 12 full yearsihatemybike has been a member for 12 full yearsihatemybike has been a member for 12 full yearsihatemybike has been a member for 12 full yearsihatemybike has been a member for 12 full years
Posts: 1666
Topics: 68
Joined: December 2008
Location: Elgin, IL
Gender: Male
Alias (AKA):


 
  • Related topics
    Replies
    Views
    Last post

Return to Electrical

It is currently March 1st 2021, 2:38am

Electrical Forum
ElectricalDiscussion specific to electric components of vans. Category for alternators or batteries, starters and ignition parts, anything 12v and electrical issue like fuses, circuitry, wire, terminals, switches, connectors, bulbs, relays, and wiring. Voltage and amperage diagnosis.
To create a new topic in Electrical, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
OldSchoolNoe
in Electrical
Views: 16
Comments: 0
Date: Today
Time: 12:53am
» Read last comment
Attached by:
tungtide
in Electrical
Views: 113
Comments: 6
Date: Feb 23 '21
Time: 1:54am
» Read last comment
Attached by:
Rockridge
in Electrical
Views: 273
Comments: 15
Date: Feb 20 '21
Time: 1:28am
» Read last comment
Attached by:
Coronavan
in Electrical
Views: 165
Comments: 10
Date: Feb 17 '21
Time: 7:21pm
» Read last comment
Attached by:
Attached by: Primusblack
Primusblack
in Electrical
Views: 426
Comments: 21
Date: Feb 17 '21
Time: 4:26am
» Read last comment
Sponsors

Who is online

Users browsing this forum: sixsixsixsix is online! and 20 guests