Things starting to fail

Things starting to fail

Postby starving030 [OP] » June 6th 2015, 5:51pm

I just took a road trip and noticed a few quarks I need to take care of but I'm unsure where to start. It started with the radio that I already made a post about.
https://www.astrosafari.com/viewtopic.php?f=32&t=77434
I changed the radio/lighter fuse and the radio started acting normal again. But my cig lighter is not working correctly now. If I plug something into it like a cell phone it shows that it's charging but it doesn't actually charge. Like, the little charge indicator is going on my phone but not really, it's not getting enough juice to actually charge. It's like the cig lighter is only putting out a couple volts instead of 12v. It took 2 hours to charge it 2%. The cig lighter itself worked for a couple of days after changing the fuse but not now. It won't get hot, but the fuse is good.

Also, none of my overhead dome or map lights work. Fuses and bulbs are all good but they won't turn on.

One more thing. My left front parking light went out and when I turn my headlights on the green "left" arrow stays on on the instrument cluster like the blinker is stuck. If I hit the blinker the arrow starts blinking normally but when the blinker goes off it stays lit up.

All this stuff happened at the same time as far as I can tell. Could they be related or just parts failing now that it's a daily driver? The previous owner used it maybe twice a year as a backup vehicle.
Original Poster [OP]
User avatar
starving030
Fueling (1/2 tank)
Fueling (1/2 tank)
Years of Membership: starving030 has been a member for 6 full yearsstarving030 has been a member for 6 full yearsstarving030 has been a member for 6 full yearsstarving030 has been a member for 6 full yearsstarving030 has been a member for 6 full yearsstarving030 has been a member for 6 full years
Posts: 53
Topics: 13
Images: 37
Joined: December 2014
Location: NE Ohio
Alias (AKA):
Van Model Year: 1995
Van Make/Model: GMC Safari

Re: Things starting to fail

Postby smokinjoe » June 6th 2015, 6:40pm

Does this all happen while the van is running or just sitting not running with ignition on.

Sounds to me like a bad battery or alternator. Put a voltmeter across the battery terminals and report what the numbers are at rest (not right after running) and running.

This will tell if the battery is getting proper charge and keeping the same.
User avatar
smokinjoe
Firing on 5 Cylinders (L2)
Firing on 5 Cylinders (L2)
Years of Membership: smokinjoe has been a member for 12 full yearssmokinjoe has been a member for 12 full yearssmokinjoe has been a member for 12 full yearssmokinjoe has been a member for 12 full yearssmokinjoe has been a member for 12 full yearssmokinjoe has been a member for 12 full yearssmokinjoe has been a member for 12 full yearssmokinjoe has been a member for 12 full yearssmokinjoe has been a member for 12 full yearssmokinjoe has been a member for 12 full yearssmokinjoe has been a member for 12 full yearssmokinjoe has been a member for 12 full years
Posts: 1523
Topics: 268
Images: 1
Joined: June 2008
Gender: Male
Alias (AKA): smokinjoe
Van Model Year: 2002
Van Make/Model: Chevrolet Astro
Extra Info: RWD

Re: Things starting to fail

Postby Lumpy » June 6th 2015, 7:21pm

A pico-EMP device has been hidden somewhere on your van. The NSA, Mossad, KGB or Amazon Prime apparently think you are worthy of watching. Be careful what you say and where you travel to in your van.

If it is Amazon Prime, one benefit is that they will automatically sense what kind of parts and accessories fit your year/make/model van and they'll put them in your shopping cart automatically.

That's right, I typed "automatically" twice in one sentence.


Lump
User avatar
Lumpy
Deprived Privileges
Deprived Privileges
Firing on 8 Cylinders (L7)
Firing on 8 Cylinders (L7)
Years of Membership: Lumpy has been a member for 10 full yearsLumpy has been a member for 10 full yearsLumpy has been a member for 10 full yearsLumpy has been a member for 10 full yearsLumpy has been a member for 10 full yearsLumpy has been a member for 10 full yearsLumpy has been a member for 10 full yearsLumpy has been a member for 10 full yearsLumpy has been a member for 10 full yearsLumpy has been a member for 10 full years
Posts: 10996
Topics: 261
Joined: April 2010
Location: Phoenix AZ USA
Gender: Male
Alias (AKA):
Van Model Year: 1989
Van Make/Model: Chevrolet Astro
Extra Info: 11 in. lift Camo


 
  • Related topics
    Replies
    Views
    Last post

Return to Electrical

It is currently January 25th 2021, 9:28pm

Electrical Forum
ElectricalDiscussion specific to electric components of vans. Category for alternators or batteries, starters and ignition parts, anything 12v and electrical issue like fuses, circuitry, wire, terminals, switches, connectors, bulbs, relays, and wiring. Voltage and amperage diagnosis.
To create a new topic in Electrical, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
OldSchoolNoe
in Electrical
Views: 148
Comments: 4
Date: Jan 19 '21
Time: 2:15am
» Read last comment
Attached by:
OldSchoolNoe
in Electrical
Views: 148
Comments: 4
Date: Jan 16 '21
Time: 9:23pm
» Read last comment
Attached by:
Attached by: AstroWill
AstroWill
in Electrical
Views: 732
Comments: 9
Date: Jan 15 '21
Time: 5:08am
» Read last comment
Attached by:
Attached by: markmitch
markmitch
in Electrical
Views: 211
Comments: 11
Date: Jan 04 '21
Time: 6:15pm
» Read last comment
Attached by:
doogaloo
in Electrical
Views: 211
Comments: 11
Date: Jan 04 '21
Time: 11:53am
» Read last comment

Who is online

Users browsing this forum: No registered users and 11 guests