PLEASE HELP. BAD GAS MILEAGE

Forum rules
This is NOT the place to post topics that could be better classified in another category. Please make every attempt to post in an appropriate category before posting here.

Please help us keep topics organized by making an effort to find an appropriate category before posting here. More often than not the posts in this forum could be moved to a better suited category.

PLEASE HELP. BAD GAS MILEAGE

Postby 98-ASTRO-SS [OP] » February 4th 2010, 3:11am

I have a 98 Astro w/ 68,000 original miles. The only mods I have done to it is a K&N replacement filter & 20" wheels w/ 245-35-20 all around. I bought the van with 52,000 miles about 8 months ago. When I first got the van I avg. 16-17.5 mpg now Im down to 8-9 mpg. The van still runs great, idles great, no codes are coming up. Just changed the plugs & the old ones where fine but changed them anyway. My mechanic can not find any leaks anywhere & he & I are dumbfounded on the whole problem. My wife drives the van & is bothering me to death about this problem. I hope yall can help me with this problem if not I will be trading it in & getting some other vehicle. Other thing that may help is the spedo is broke but does not affect the rpm's any & the problem started as soon as I got my oil changed at super lube to go on a trip & as soon as I left getting the oil changed my spedo broke & gas mileage fell . PLEASE HELP :banghead: :feedback: :confused: :shrug: :crying:
Original Poster [OP]
98-ASTRO-SS
Fueling (1/8 tank)
Fueling (1/8 tank)
Years of Membership: 98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years
Posts: 18
Topics: 4
Joined: July 2009
Alias (AKA):
Van Make/Model: Chevrolet Astro
Extra Info: 4.3L RWD

  • Similar topics
    Replies
    Views
    Author
  • checking mileage on junk yard vans
    by Rod's Trucks » November 19th 2020, 4:41am in Electrical
    16 Replies
    568 Views
    Last post by stent View the latest post
    December 5th 2020, 5:29pm
  • 1995 GMC Safari HWY Beast! But poor fuel mileage..
    by 95SafariRunner » January 31st 2021, 10:16am in Engines
    12 Replies
    361 Views
    Last post by AstroWill View the latest post
    February 2nd 2021, 8:13pm
  •  
    8
    48
    Last post by AstroSafari.com View the latest post
    March 1st 2021, 2:36pm

Re: PLEASE HELP. BAD GAS MILEAGE

Postby $uperJoe » February 4th 2010, 3:20am

i would check the connection at the vss in the tail of the trans for a loose or broken wire. there are 4 modes that the engine will work in. warm up, low idle, traffic, and cruise. each mode has different fuel mapping. if the pcm does not see any speed it will always dump fuel in the motor as if in warm up or easier to understand "choke"mode for you carb guys. the speedo is vital to fuel mapping
Don't explain it poorly 5 times. Take the 15 seconds to go out and take a picture of it!!
Please do not confuse idle conversation with technical advise


Check out my Van build
User avatar
$uperJoe
Firing on 4 Cylinders (L2)
Firing on 4 Cylinders (L2)
Years of Membership: $uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years$uperJoe has been a member for 11 full years
Posts: 1416
Topics: 59
Joined: July 2009
Alias (AKA):
Van Make/Model: GMC Safari

Re: PLEASE HELP. BAD GAS MILEAGE

Postby 98-ASTRO-SS [OP] » February 4th 2010, 3:28am

But wouldnt that make it idle high? It idles perfect
Original Poster [OP]
98-ASTRO-SS
Fueling (1/8 tank)
Fueling (1/8 tank)
Years of Membership: 98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years
Posts: 18
Topics: 4
Joined: July 2009
Alias (AKA):
Van Make/Model: Chevrolet Astro
Extra Info: 4.3L RWD

Re: PLEASE HELP. BAD GAS MILEAGE

Postby rev_les » February 4th 2010, 3:37am

Yeah, it's an odd problem, if it has no VSS signal, it shouldn't shift.Does the temp gauge show that it's coming up to operating temperature?
Figure out the problem before buying parts
NRA Lifetime Member
2'nd amendment supporter
'13 Jeep Patriot
'01 Safari 150K 4.3 "W" 3.42's
'87 Monte Carlo SS
'79 Avco 32' RV
User avatar
rev_les
Site Contributor
Site Contributor
Firing on 2 Cylinders (L3)
Firing on 2 Cylinders (L3)
Years of Membership: rev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full years
Posts: 2235
Topics: 39
Joined: February 2009
Location: Pinehurst TX
Gender: Male
Alias (AKA): Les
Van Make/Model: Chevrolet Astro
Extra Info: LS 4.3 RWD

Re: PLEASE HELP. BAD GAS MILEAGE

Postby 98-ASTRO-SS [OP] » February 4th 2010, 3:48am

it shifts fine. it doesnt smoke like its getting to much fuel or anything. I even run 93 octane & it doesnt help. Everything works just as good as when I got the van but now it gets about 9mpgs rather than 16-17. My mechanic is not a shade tree mech either if any of yall are thinking that. Its a pro full service auto shop. In other terms of mpgs It did get about 375 miles to a tank and now it gets 180-200
Original Poster [OP]
98-ASTRO-SS
Fueling (1/8 tank)
Fueling (1/8 tank)
Years of Membership: 98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years
Posts: 18
Topics: 4
Joined: July 2009
Alias (AKA):
Van Make/Model: Chevrolet Astro
Extra Info: 4.3L RWD

Re: PLEASE HELP. BAD GAS MILEAGE

Postby rev_les » February 4th 2010, 4:20am

if the engine's not coming up to operating temperature,the computer will keep it rich, causing bad fuel mileage, that's why I'm asking about that.If the catalytic converter is working correctly, an engine can even be burning some oil and not smoke, so no smoke isn't a reliable indicator.
Figure out the problem before buying parts
NRA Lifetime Member
2'nd amendment supporter
'13 Jeep Patriot
'01 Safari 150K 4.3 "W" 3.42's
'87 Monte Carlo SS
'79 Avco 32' RV
User avatar
rev_les
Site Contributor
Site Contributor
Firing on 2 Cylinders (L3)
Firing on 2 Cylinders (L3)
Years of Membership: rev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full yearsrev_les has been a member for 12 full years
Posts: 2235
Topics: 39
Joined: February 2009
Location: Pinehurst TX
Gender: Male
Alias (AKA): Les
Van Make/Model: Chevrolet Astro
Extra Info: LS 4.3 RWD

Re: PLEASE HELP. BAD GAS MILEAGE

Postby 98-ASTRO-SS [OP] » February 4th 2010, 4:43am

It comes up to operating temp just fine it has a low temp thermostat. I belive its 180 but it comes up to operating temp as it normally does. Thanks
Original Poster [OP]
98-ASTRO-SS
Fueling (1/8 tank)
Fueling (1/8 tank)
Years of Membership: 98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years
Posts: 18
Topics: 4
Joined: July 2009
Alias (AKA):
Van Make/Model: Chevrolet Astro
Extra Info: 4.3L RWD

Re: PLEASE HELP. BAD GAS MILEAGE

Postby Leeann_93 » February 4th 2010, 5:06am

98-ASTRO-SS wrote:It comes up to operating temp just fine it has a low temp thermostat. I belive its 180 but it comes up to operating temp as it normally does. Thanks



180° isn't operating temp for these vehicles. 195° is. One of the side affects of running cool is reduced gas mileage.
'05 Astro AWD vin X
'02 Astro LS AWD vin X
'00 Astro LS AWD - WIP
'99 Safari XLE AWD - broke
'93 AWD EXT vin W - real broke
User avatar
Leeann_93
Team Leader
Team Leader
Firing on 8 Cylinders (L7)
Firing on 8 Cylinders (L7)
Years of Membership: Leeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full years
Posts: 13730
Topics: 44
Images: 17
Joined: December 2008
Location: MD
Gender: Female
Alias (AKA):
Van Model Year: 2005
Van Make/Model: Chevrolet Astro
Extra Info: LS AWD

Re: PLEASE HELP. BAD GAS MILEAGE

Postby Astroplane » February 4th 2010, 10:02am

Were there any other services to the van at the time of the oil change? Any info on what weight oil they used? Was the van put on a lift for the oil change? You sound convinced that the poor fuel economy began right around the time of the service. Also, what do the Fuel Trims show in engine data?
User avatar
Astroplane
Blue Status (L2)
Blue Status (L2)
Years of Membership: Astroplane has been a member for 11 full yearsAstroplane has been a member for 11 full yearsAstroplane has been a member for 11 full yearsAstroplane has been a member for 11 full yearsAstroplane has been a member for 11 full yearsAstroplane has been a member for 11 full yearsAstroplane has been a member for 11 full yearsAstroplane has been a member for 11 full yearsAstroplane has been a member for 11 full yearsAstroplane has been a member for 11 full yearsAstroplane has been a member for 11 full years
Posts: 1048
Topics: 4
Joined: January 2010
Alias (AKA):
Van Make/Model: Chevrolet Astro
Extra Info: LT RWD

Re: PLEASE HELP. BAD GAS MILEAGE

Postby astro355 » February 4th 2010, 10:11am

I would clean your MAF sensor. I see your running a K&N filter. MAF sensors can get "covered" with the oil from a K&N filter and that will throw the readings off.

Also, the ECM needs a vehicle speed for its fuel maps. You should be able to hook a scan tool up to the drive and take a test drive to test what part of the speed isn't working. If the connect between the trans is ecm is at fault, you will not be able to see a vehicle speed reading on the scan tool. If you can, then something between the ecm and instrument cluster is at fault. And the lack of a VSS signal will not affect your idle. While you're stopping and the van idling, your speed is 0 mph. And once you start moving, the van will work at other inputs such as load (MAF, MAP, etc).
Diagnose 1st, never be a parts changer!

355 small block chevy w/ modified 700R4

Image
User avatar
astro355
V8 Swap Achievement
V8 Swap Achievement
Firing on 4 Cylinders (L6)
Firing on 4 Cylinders (L6)
Years of Membership: astro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full yearsastro355 has been a member for 12 full years
Posts: 5484
Topics: 57
Joined: May 2008
Location: Cleveland, OH
Gender: Male
Alias (AKA):
Van Model Year: 1989
Van Make/Model: Chevrolet Astro
Extra Info: 355 V8 700R4

Re: PLEASE HELP. BAD GAS MILEAGE

Postby 98-ASTRO-SS [OP] » February 4th 2010, 12:57pm

Leeann_93 wrote:
98-ASTRO-SS wrote:It comes up to operating temp just fine it has a low temp thermostat. I belive its 180 but it comes up to operating temp as it normally does. Thanks



180° isn't operating temp for these vehicles. 195° is. One of the side affects of running cool is reduced gas mileage.



It has had the low temp stat on it since I bought it
Original Poster [OP]
98-ASTRO-SS
Fueling (1/8 tank)
Fueling (1/8 tank)
Years of Membership: 98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years
Posts: 18
Topics: 4
Joined: July 2009
Alias (AKA):
Van Make/Model: Chevrolet Astro
Extra Info: 4.3L RWD

Re: PLEASE HELP. BAD GAS MILEAGE

Postby 98-ASTRO-SS [OP] » February 4th 2010, 1:00pm

Astroplane wrote:Were there any other services to the van at the time of the oil change? Any info on what weight oil they used? Was the van put on a lift for the oil change? You sound convinced that the poor fuel economy began right around the time of the service. Also, what do the Fuel Trims show in engine data?


It was only a oil change & it was not on a lift . I belive the oil was 5-30 or 10-30 Mobil 1 Synthetic. How do I even check the fuel trims in the engine data?
Original Poster [OP]
98-ASTRO-SS
Fueling (1/8 tank)
Fueling (1/8 tank)
Years of Membership: 98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years
Posts: 18
Topics: 4
Joined: July 2009
Alias (AKA):
Van Make/Model: Chevrolet Astro
Extra Info: 4.3L RWD

Re: PLEASE HELP. BAD GAS MILEAGE

Postby 98-ASTRO-SS [OP] » February 4th 2010, 1:04pm

astro355 wrote:I would clean your MAF sensor. I see your running a K&N filter. MAF sensors can get "covered" with the oil from a K&N filter and that will throw the readings off.

Also, the ECM needs a vehicle speed for its fuel maps. You should be able to hook a scan tool up to the drive and take a test drive to test what part of the speed isn't working. If the connect between the trans is ecm is at fault, you will not be able to see a vehicle speed reading on the scan tool. If you can, then something between the ecm and instrument cluster is at fault. And the lack of a VSS signal will not affect your idle. While you're stopping and the van idling, your speed is 0 mph. And once you start moving, the van will work at other inputs such as load (MAF, MAP, etc).



I will check that out. Thanks
Original Poster [OP]
98-ASTRO-SS
Fueling (1/8 tank)
Fueling (1/8 tank)
Years of Membership: 98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years98-ASTRO-SS has been a member for 11 full years
Posts: 18
Topics: 4
Joined: July 2009
Alias (AKA):
Van Make/Model: Chevrolet Astro
Extra Info: 4.3L RWD

Re: PLEASE HELP. BAD GAS MILEAGE

Postby Astroplane » February 5th 2010, 6:03am

98-ASTRO-SS wrote:How do I even check the fuel trims in the engine data?


Your mechanic will know how to read that on the scanner.
User avatar
Astroplane
Blue Status (L2)
Blue Status (L2)
Years of Membership: Astroplane has been a member for 11 full yearsAstroplane has been a member for 11 full yearsAstroplane has been a member for 11 full yearsAstroplane has been a member for 11 full yearsAstroplane has been a member for 11 full yearsAstroplane has been a member for 11 full yearsAstroplane has been a member for 11 full yearsAstroplane has been a member for 11 full yearsAstroplane has been a member for 11 full yearsAstroplane has been a member for 11 full yearsAstroplane has been a member for 11 full years
Posts: 1048
Topics: 4
Joined: January 2010
Alias (AKA):
Van Make/Model: Chevrolet Astro
Extra Info: LT RWD

Re: PLEASE HELP. BAD GAS MILEAGE

Postby [email protected] » August 3rd 2014, 3:21pm

I think this will help shed some light on gas mileage for the Astro vans.I Bought my 2002 Astro van in 2007 with 45000 miles and great shape. The van now has 248,000 miles and the fuel mileage has fallen off in the past year. 12-14 on the highway and about 10 MPG in the city. I drive A LOT of highway miles towing a small 5 X 8 trailer. Towing i am getting about 9-10 mpg.My gas mileage was 17-19 on the highway, 12- 14 in the city. I have replaced the tires 3times - the original tires were P215/75R15. I replaced the tires 2 time with P225/70R15 for a better ride and appearance. my gas mileage stayed 17-19 and 12-14 hwy/city. The 3 rd time i replaced the tires I bought tires on sale for a great deal. they were 235/75R15 all terrain tires. My gas mileage dropped to 11 on the highway and 8 when i was towing a trailer. additionally the transmission shifted back and forth from OD to 3rd and i notice the engine labored a lot more due the additional size of the tires. Thankfully the tire shop allowed my to exchange the tires for a different tire. the replacement tires are P225/78R15. I think this explains why my gas mileage has dropped to what it is now. My next tires will be P225/70R15 and hopefully the gas mileage will go back to normal.Sorry this is so lengthy but i wanted to explain my point and what I have experienced.
[email protected]
Fueling (Empty tank)
Fueling (Empty tank)
Years of Membership: chipnbud@yahoo.com has been a member for 6 full yearschipnbud@yahoo.com has been a member for 6 full yearschipnbud@yahoo.com has been a member for 6 full yearschipnbud@yahoo.com has been a member for 6 full yearschipnbud@yahoo.com has been a member for 6 full yearschipnbud@yahoo.com has been a member for 6 full years
Posts: 1
Joined: August 2014
Gender: Male
Alias (AKA): Chip
Van Model Year: 2002
Van Make/Model: Chevrolet Astro
Extra Info: LS 4.3 RWD

Re: PLEASE HELP. BAD GAS MILEAGE

Postby Leeann_93 » August 4th 2014, 1:52am

You did notice that the last post was 4 years ago, yes?
'05 Astro AWD vin X
'02 Astro LS AWD vin X
'00 Astro LS AWD - WIP
'99 Safari XLE AWD - broke
'93 AWD EXT vin W - real broke
User avatar
Leeann_93
Team Leader
Team Leader
Firing on 8 Cylinders (L7)
Firing on 8 Cylinders (L7)
Years of Membership: Leeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full years
Posts: 13730
Topics: 44
Images: 17
Joined: December 2008
Location: MD
Gender: Female
Alias (AKA):
Van Model Year: 2005
Van Make/Model: Chevrolet Astro
Extra Info: LS AWD

Re: PLEASE HELP. BAD GAS MILEAGE

Postby kmtechman1 » August 4th 2014, 2:26am

This problem should not be that hard to find. Drive the van for 20 minutes and see if you have a wheel hot from stuck, dragging brake caliper or rusty failure to release emengency brake. Change the fuel filter and drain the old one into a clear jar so you can see if it looks milky, it had water in it. I replaced a fuel pump one time and found 5 pounds of sugar in the gas tank. The guy had enemys, I guess. Ken
kmtechman1
Fueling (1/4 tank)
Fueling (1/4 tank)
Years of Membership: kmtechman1 has been a member for 6 full yearskmtechman1 has been a member for 6 full yearskmtechman1 has been a member for 6 full yearskmtechman1 has been a member for 6 full yearskmtechman1 has been a member for 6 full yearskmtechman1 has been a member for 6 full years
Posts: 30
Topics: 5
Joined: August 2014
Gender: Male
Alias (AKA): Ken
Van Model Year: 2005
Van Make/Model: GMC Safari

Re: PLEASE HELP. BAD GAS MILEAGE

Postby Leeann_93 » August 4th 2014, 2:28am

Again, this thread is 4 and a half years old. Please let it die.
'05 Astro AWD vin X
'02 Astro LS AWD vin X
'00 Astro LS AWD - WIP
'99 Safari XLE AWD - broke
'93 AWD EXT vin W - real broke
User avatar
Leeann_93
Team Leader
Team Leader
Firing on 8 Cylinders (L7)
Firing on 8 Cylinders (L7)
Years of Membership: Leeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full yearsLeeann_93 has been a member for 12 full years
Posts: 13730
Topics: 44
Images: 17
Joined: December 2008
Location: MD
Gender: Female
Alias (AKA):
Van Model Year: 2005
Van Make/Model: Chevrolet Astro
Extra Info: LS AWD

Re: PLEASE HELP. BAD GAS MILEAGE

Postby Grimspyder » September 29th 2014, 12:32pm

Don't let it die! This answered some questions and the last post, actually was good info.
97 AWD 4.3L V6 Discovery, Automatic Transmission, Seats 7, 167,000 miles.
Grimspyder
Fueling (Empty tank)
Fueling (Empty tank)
Years of Membership: Grimspyder has been a member for 9 full yearsGrimspyder has been a member for 9 full yearsGrimspyder has been a member for 9 full yearsGrimspyder has been a member for 9 full yearsGrimspyder has been a member for 9 full yearsGrimspyder has been a member for 9 full yearsGrimspyder has been a member for 9 full yearsGrimspyder has been a member for 9 full yearsGrimspyder has been a member for 9 full years
Posts: 4
Topics: 2
Joined: March 2011
Gender: Male
Alias (AKA):
Van Make/Model: Chevrolet Astro
Extra Info: AWD Discovery V6

Re: PLEASE HELP. BAD GAS MILEAGE

Postby catbones » September 29th 2014, 1:51pm

I've got 100 to 200 about 6 months ago and depending on a fill up when my fuel pump was going out of service. It didn't show any signs of being bad other then a bad mileage and then it took about 3 moths or so for it to get bad idle once in a long while.

After new fuel pump I was able to get 350 a tank. Maybe that will help.
catbones
Firing on 6 Cylinders (L1)
Firing on 6 Cylinders (L1)
Years of Membership: catbones has been a member for 7 full yearscatbones has been a member for 7 full yearscatbones has been a member for 7 full yearscatbones has been a member for 7 full yearscatbones has been a member for 7 full yearscatbones has been a member for 7 full yearscatbones has been a member for 7 full years
Posts: 633
Topics: 83
Joined: June 2013
Gender: Male
Alias (AKA): catbones
Van Model Year: 2004
Van Make/Model: Chevrolet Astro
Extra Info: Base 4.3L V6 AWD


 
  • Related topics
    Replies
    Views
    Last post

Return to Uncategorized

It is currently March 1st 2021, 2:36pm

Uncategorized Forum
UncategorizedAn all-purpose area for Astro/Safari van related discussion. These forums typically contain van-related but ill-assorted topics unfit for any other category. General questions and information relating to Astro and Safari Vans only.
Moderators: Leeann_93, icebrrg3rd
To create a new topic in Uncategorized, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
Attached by: icebrrg3rd
icebrrg3rd
in Uncategorized
Views: 175383
Comments: 2995
Date: Feb 23 '21
Time: 6:27pm
» Read last comment
Attached by:
Attached by: Mmusicman
MmusicmanMmusicman is online!
in Uncategorized
Views: 801073
Comments: 16419
Date: Feb 16 '21
Time: 8:08pm
» Read last comment
Attached by:
Coronavan
in Uncategorized
Views: 37263
Comments: 235
Date: Feb 14 '21
Time: 4:06am
» Read last comment
Attached by:
Upstatevanvibes
in Uncategorized
Views: 155
Comments: 8
Date: Feb 14 '21
Time: 3:20am
» Read last comment
Attached by:
Coronavan
in Uncategorized
Views: 237
Comments: 5
Date: Feb 14 '21
Time: 1:18am
» Read last comment
Sponsors

Who is online

Users browsing this forum: No registered users and 16 guests