Spark then, ... NO SPARK!!!

Spark then, ... NO SPARK!!!

Postby Definitive Arts [OP] » April 22nd 2020, 12:23am

HELP!
Helping my Dad get his 1995 GMC Safari back on the road. We put a new ICM, Coil, Cap and rotor in, reset the timing mark, and it turned over for us, twice. We ran it for a few moments then turned it off. Tried to restart it 5 minutes later and... no spark. Wouldn't start again. "?!?" Fuel pump is running, starter is turning over, but no spark. Went to investigate the electrical chain and the schematics in our Haynes manual shows a Crankshaft Position Sensor before the ICM and Coil, so I went to check it. ... no CPS, like my '98. Apparently, they switched over to CPSs mid '95 so this has the electrical system shown in the '94/'93' and earlier schematics. The only thing before the ICM and Coil is the ignition switch. We tested the pink power wire that goes to the Coil, from the ignition switch and ... no power. I dropped the steering column and checked the switch. ... the switch is good. "?" None of the schematics show a fuse in the fuse block or any inline fuses or fusible links. So, question is, ... why in the *&#@ did we suddenly lose spark and what failed on us?

Thanks!
Allen
Original Poster [OP]
Definitive Arts
Fueling (Empty tank)
Fueling (Empty tank)
Posts: 5
Topics: 1
Joined: April 2020
Location: Port Orchard, Washignton
Gender: Male
Alias (AKA): Allen
Van Model Year: 1999
Van Make/Model: GMC Safari
Extra Info: 4.3L V6 RWD

  • Similar topics
    Replies
    Views
    Author
  • sudden no start issue
    by 81SAFARIMATT » March 24th 2020, 6:43pm in Electrical
    3 Replies
    174 Views
    Last post by Leeann_93 View the latest post
    March 24th 2020, 11:26pm
  • Intermittentish no run electrical problem (presumably)
    by fx4m » May 28th 2020, 1:53am in Electrical
    7 Replies
    338 Views
    Last post by fx4m View the latest post
    June 8th 2020, 12:44am
  •  
    8
    73
    Last post by AstroSafari.com View the latest post
    August 12th 2020, 4:10am

Re: Spark then, ... NO SPARK!!!

Postby gman » April 22nd 2020, 3:55am

I'm far FAR from an electrical expert or even someone who knows auto problems extremely well, but you might want to check if your astro/safari has a passlock system.
It's just another variable that can cut off your ignition.
1999 Chevy Astro Van
gman
Firing on 2 Cylinders (L1)
Firing on 2 Cylinders (L1)
Posts: 281
Topics: 31
Images: 29
Joined: February 2020
Alias (AKA):
Van Model Year: 1999
Van Make/Model: Chevrolet Astro
Extra Info: Base 4.3 RWD

Re: Spark then, ... NO SPARK!!!

Postby sixsix » April 22nd 2020, 2:57pm

And... of course, you know brand new parts go bad in the box. :cry:
Well, after all... what would Banacek say ?... “AOC - her astonishing matryoshka-like ignorance, like the rest of The Squad is surpassed only by the relentless idiocy of the democrats, antifa & it’s attendant mass media, mayors & governors.”


.
User avatar
sixsix
Orange Status (L5)
Orange Status (L5)
Years of Membership: sixsix has been a member for 6 full yearssixsix has been a member for 6 full yearssixsix has been a member for 6 full yearssixsix has been a member for 6 full yearssixsix has been a member for 6 full yearssixsix has been a member for 6 full years
Posts: 4086
Topics: 36
Images: 1214
Joined: May 2014
Location: Edgewood, Northern Ky.
Gender: Male
Alias (AKA): Mike
Van Model Year: 1992
Van Make/Model: Chevrolet Astro
Extra Info: LT W CPI - RWD 200K

Re: Spark then, ... NO SPARK!!!

Postby Definitive Arts [OP] » April 22nd 2020, 9:16pm

This '95 does not have the Passlock System like my '98. :/
Original Poster [OP]
Definitive Arts
Fueling (Empty tank)
Fueling (Empty tank)
Posts: 5
Topics: 1
Joined: April 2020
Location: Port Orchard, Washignton
Gender: Male
Alias (AKA): Allen
Van Model Year: 1999
Van Make/Model: GMC Safari
Extra Info: 4.3L V6 RWD

Re: Spark then, ... NO SPARK!!!

Postby AstroWill » April 23rd 2020, 3:49am

Passlock, if equipped would have nothing to do with the spark, it only disables the injectors.


Definitive Arts wrote:We tested the pink power wire that goes to the Coil, from the ignition switch and ... no power. I dropped the steering column and checked the switch. ... the switch is good. "?" None of the schematics show a fuse in the fuse block or any inline fuses or fusible links.

I think you may have found why you have no spark. Every circuit other than the starter has some kind of circuit protection, fuse/circuit breaker/fusible link. This one would be fusible link B, 15cm from connector C198, behind the battery bolted to the passthrough.

Please post the first half of your VIN number.

Trolls take away from productive work, best to starve the troll of attention by ignoring it and going about your business.
User avatar
AstroWill
Technical Director
Technical Director
Firing on 8 Cylinders (L7)
Firing on 8 Cylinders (L7)
Years of Membership: AstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full years
Posts: 10701
Topics: 106
Images: 437
Joined: February 2009
Alias (AKA):
Van Make/Model: Chevrolet Astro

Re: Spark then, ... NO SPARK!!!

Postby gman » April 23rd 2020, 6:33am

AstroWill wrote:Passlock, if equipped would have nothing to do with the spark, it only disables the injectors.


Definitive Arts wrote:We tested the pink power wire that goes to the Coil, from the ignition switch and ... no power. I dropped the steering column and checked the switch. ... the switch is good. "?" None of the schematics show a fuse in the fuse block or any inline fuses or fusible links.

I think you may have found why you have no spark. Every circuit other than the starter has some kind of circuit protection, fuse/circuit breaker/fusible link. This one would be fusible link B, 15cm from connector C198, behind the battery bolted to the passthrough.

Please post the first half of your VIN number.


Are you getting all of this information from the vehicle wiring diagrams?
I really have to learn how to read those in depth.
1999 Chevy Astro Van
gman
Firing on 2 Cylinders (L1)
Firing on 2 Cylinders (L1)
Posts: 281
Topics: 31
Images: 29
Joined: February 2020
Alias (AKA):
Van Model Year: 1999
Van Make/Model: Chevrolet Astro
Extra Info: Base 4.3 RWD

Re: Spark then, ... NO SPARK!!!

Postby AstroWill » April 23rd 2020, 6:41am

Yes, comes directly from the FSM.

If it were for your 99, you could get the GM Techline eSI online and run it in virtualbox(check my sig/profile for links), but there are some full scanned FSMs out there floating around the web for some of the earlier years.

Trolls take away from productive work, best to starve the troll of attention by ignoring it and going about your business.
User avatar
AstroWill
Technical Director
Technical Director
Firing on 8 Cylinders (L7)
Firing on 8 Cylinders (L7)
Years of Membership: AstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full yearsAstroWill has been a member for 11 full years
Posts: 10701
Topics: 106
Images: 437
Joined: February 2009
Alias (AKA):
Van Make/Model: Chevrolet Astro

Re: Spark then, ... NO SPARK!!!

Postby MechBob » April 23rd 2020, 7:14am

YA, whatever, interesting posts.Without voltage and current tests, means nothing .Please check the plug in connector. behind the battery, where the circuits pass through the firewall.A very well known trouble spot.
User avatar
MechBob
250k+ Miles
250k+ Miles
Firing on 8 Cylinders (L1)
Firing on 8 Cylinders (L1)
Years of Membership: MechBob has been a member for 1 full year
Posts: 947
Topics: 11
Images: 12
Joined: August 2018
Gender: Male
Alias (AKA): Bob
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: 4x4

Re: Spark then, ... NO SPARK!!!

Postby Definitive Arts [OP] » June 18th 2020, 1:17am

Thank you for the help.
So, update. After having to work on other projects, we have returned to tackle this issue. There was a concern about the timing being out and the chain skipping a tooth, or something, so we removed the timing chain cover and found the chain was very worn out with a lot of slack but had not jumped a tooth. We replaced it with a new chain and mechanically set the timing. We also replaced the coil, ignition control module, cap and rotor, and wires, to be sure we had everything covered. Gave it a crank and it started up but had a hard time idling. It died, then, like before, would not start again. Checked spark off the coil and nothing. Hooked a meter to the pink wire coming to the coil and when the key is engaged, it shows power so, either the coil or the ICM went out again. Ugg... This is the 4th coil and the 4th ICM we have put in it and we still can't figure out what is killing it.
I looked behind the batter to check the pink wire going to the coil and the finance link is still good. Not soft and squishy (see attached photo).
We did just hook a code reader to it, just to see if it could point is in the right direction, and the only things coming up were:
- #59 (TTS)
- #67 (Cruise)
- #81 (QDM B)
- #82 (QDM A)

The 1st half of the VIN is:1GKDM19W
Attachments
IMG_20200617_163942.jpg
Original Poster [OP]
Definitive Arts
Fueling (Empty tank)
Fueling (Empty tank)
Posts: 5
Topics: 1
Joined: April 2020
Location: Port Orchard, Washignton
Gender: Male
Alias (AKA): Allen
Van Model Year: 1999
Van Make/Model: GMC Safari
Extra Info: 4.3L V6 RWD

Re: Spark then, ... NO SPARK!!!

Postby Definitive Arts [OP] » June 18th 2020, 1:26am

*clarification* we tested power coming to the coil as well as the pink wire going from the coil to the ICM, and we have power on both when the key is engaged.
Original Poster [OP]
Definitive Arts
Fueling (Empty tank)
Fueling (Empty tank)
Posts: 5
Topics: 1
Joined: April 2020
Location: Port Orchard, Washignton
Gender: Male
Alias (AKA): Allen
Van Model Year: 1999
Van Make/Model: GMC Safari
Extra Info: 4.3L V6 RWD

Re: Spark then, ... NO SPARK!!!

Postby Definitive Arts [OP] » June 18th 2020, 6:50pm

SOLVED!!!
Soooo, digging through eeeeeeverything possible in the signal routing... we found the culprit. It was the distributor. Mire specifically,the pickup coil inside the distributor. When inspecting it closer, we noticed it was lose. It would work at first but after a short amount of running,
it would wiggle and kill the spark. We took a matching distributor out of my old 87 Astro and *bam*, started up first try. Now to tune it and take it for a test drive.
Original Poster [OP]
Definitive Arts
Fueling (Empty tank)
Fueling (Empty tank)
Posts: 5
Topics: 1
Joined: April 2020
Location: Port Orchard, Washignton
Gender: Male
Alias (AKA): Allen
Van Model Year: 1999
Van Make/Model: GMC Safari
Extra Info: 4.3L V6 RWD

Re: Spark then, ... NO SPARK!!!

Postby sixsix » June 18th 2020, 10:23pm

Thanks for the Update - Glad you got it sorted.
Well, after all... what would Banacek say ?... “AOC - her astonishing matryoshka-like ignorance, like the rest of The Squad is surpassed only by the relentless idiocy of the democrats, antifa & it’s attendant mass media, mayors & governors.”


.
User avatar
sixsix
Orange Status (L5)
Orange Status (L5)
Years of Membership: sixsix has been a member for 6 full yearssixsix has been a member for 6 full yearssixsix has been a member for 6 full yearssixsix has been a member for 6 full yearssixsix has been a member for 6 full yearssixsix has been a member for 6 full years
Posts: 4086
Topics: 36
Images: 1214
Joined: May 2014
Location: Edgewood, Northern Ky.
Gender: Male
Alias (AKA): Mike
Van Model Year: 1992
Van Make/Model: Chevrolet Astro
Extra Info: LT W CPI - RWD 200K


 
  • Related topics
    Replies
    Views
    Last post

Return to Electrical

It is currently August 12th 2020, 4:10am

Electrical Forum
ElectricalDiscussion specific to electric components of vans. Category for alternators or batteries, starters and ignition parts, anything 12v and electrical issue like fuses, circuitry, wire, terminals, switches, connectors, bulbs, relays, and wiring. Voltage and amperage diagnosis.
To create a new topic in Electrical, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
Sailing_Faith
in Electrical
Views: 901
Comments: 17
Date: Aug 10 '20
Time: 2:17am
» Read last comment
Attached by:
doogaloo
in Electrical
Views: 901
Comments: 17
Date: Aug 09 '20
Time: 8:52pm
» Read last comment
Attached by:
Attached by: kittenflaps
kittenflaps
in Electrical
Views: 261
Comments: 18
Date: Aug 07 '20
Time: 12:46am
» Read last comment
Attached by:
Sailing_Faith
in Electrical
Views: 901
Comments: 17
Date: Aug 06 '20
Time: 4:48pm
» Read last comment
Attached by:
Attached by: bowtie262
bowtie262
in Electrical
Views: 190
Comments: 8
Date: Aug 02 '20
Time: 8:41pm
» Read last comment
Sponsors

Who is online

Users browsing this forum: No registered users and 6 guests