Power cut on freeway, but started right back up after?

Power cut on freeway, but started right back up after?

Postby kittenflaps [OP] » August 4th 2020, 10:04pm

My 1998 AWD Astro had a truly mystifying fit on Sunday. Was taking a victorious test drive after finally narrowing in on and fixing a long running issue with my brakes that was also screwing with my AWD (lesson learned, don't take the bait on the cheap parts...) and then...

PROBLEM: Got on the freeway at 51st st, and power cut right before the next exit to 27th (so made it roughly 20 blocks..) noticed the gas pedal suddenly wasn't doing anything, and felt the engine chuggling a little bit, noticed all my dash lights were out, hazards didn't work when I put them on. Thankfully, no one in the lane to the right of me and the exit was right there (no shoulder on this section) it's a funny little exit that is a little downhill, then has a slight grade up in the middle, then down again... was losing speed at the hump and tapped the gas hard for a few seconds which barely gave me the push I needed to crest over. Parked in a red zone right out of the mouth of the exit, turned ignition to off, and let my heart attack play out. Tried turning the car on, expecting it to not crank, but alas, started right up. I turned the van off again, checked battery connections, they are all tight. OK. Started again to cautiously take side streets home, after 2 blocks air bag light started flashing, then same thing happened again at about 3 blocks away. Checked battery connections again because I didn't know what else to do... yes they are still tight. Let it run for about ten minutes at idle, turning all the lights off and on, blasting radio, heat, whatever, didn't skip a beat... Drove the rest of the way home (about 2.5 miles) without error.

CONTEXT: https://www.astrosafari.com/viewtopic.php?f=76&t=142312 here is a previous post about somewhat similar issues that I thought had been resolved, and more context on other events that may or may not be related from the deeper past. This would be the 3rd and 4th time I've lost power while in motion, but the events are all very spaced out save the fact it happened twice in a row on Sunday.

I am really at a loss. I am inclined to think it's not the alternator since it came back on right away. My scope on that is limited, though. Leaning toward potential it's something spazzing in the ignition, but if my van thought I turned it off mid freeway I'm not sure why the lights wouldn't work, or why I would have gotten that weak little push from hitting the gas... :confused: Planning on taking it in for professional TLC soon, but it's been in and out of the mechanic for weird electrical business and would like to try and formulate a better idea of what even happened. It's been hard for them to narrow down, since its so intermittent, and of course tends to be on its best behavior when it's at the doctor...

Any thoughts or insight would be very kindly appreciated!
Last edited by kittenflaps on August 5th 2020, 1:42am, edited 1 time in total.
Original Poster [OP]
User avatar
kittenflaps
Fueling (1/8 tank)
Fueling (1/8 tank)
Posts: 16
Topics: 3
Joined: May 2020
Location: California
Alias (AKA):
Van Model Year: 1998
Van Make/Model: Chevrolet Astro
Extra Info: AWD 4.3L V6

  • Similar topics
    Replies
    Views
    Author
  • Engine stays revving after highway run
    by smokinjoe » May 30th 2020, 1:58am in Electrical
    1 Replies
    174 Views
    Last post by M_a_t_t View the latest post
    May 30th 2020, 3:06am
  • No Power to Tow Harness
    by SportsBoy » July 16th 2020, 8:10pm in Electrical
    23 Replies
    728 Views
    Last post by SportsBoy View the latest post
    July 26th 2020, 2:25am
  •  
    6
    96
    Last post by AstroSafari.com View the latest post
    October 27th 2020, 9:31am

Re: Power cut on freeway, but started right back up after?

Postby dcsleeperdcsleeper is online! » August 4th 2020, 10:21pm

The power wires/cables run close to the control arm.
Check and make sure they haven't rubbed through and are arcing out on them.
Please update your User Control Panel to include your location!!! it's in the upper right!
Profile | Edit signature

foxfire wrote:i have a thing for customizing slightly outdated vehicles.

yeah, don't we all....
User avatar
dcsleeperdcsleeper is online!
Firing on 2 Cylinders (L1)
Firing on 2 Cylinders (L1)
Posts: 234
Topics: 15
Images: 51
Joined: April 2020
Location: North Carolina
Gender: Male
Alias (AKA):
Van Model Year: 2004
Van Make/Model: Chevrolet Astro

Re: Power cut on freeway, but started right back up after?

Postby TPP » August 4th 2020, 10:31pm

Probably a bad battery, a rod is probably loose and hitting another one. Happened to my bro on his bike on I 95. When you jiggle the battery terminal connections it probably fixed it until you hit a bump or took a turn 3 blocks later.
User avatar
TPP
Fueling (1/4 tank)
Fueling (1/4 tank)
Posts: 26
Topics: 6
Joined: August 2020
Location: York County, PA
Gender: Male
Alias (AKA):
Van Model Year: 2004
Van Make/Model: GMC Safari
Extra Info: SLT AWD

Re: Power cut on freeway, but started right back up after?

Postby Sailing_Faith » August 5th 2020, 12:35am

kittenflaps wrote:....
QUICK QUESTION: Now noticing that odometer light and clock light dim when I turn the headlights on, but it doesn't happen under any other accessory load. I can't remember it's always done this or if it's actually new. Is that normal (like lowering the brightness at night when you would need headlights) or indicative of something? Can anyone check their Astro of a similar year and let me know?

...Any thoughts or insight would be very kindly appreciated!


Yes, it is normal for the odometer light (and PRNDL) to dim when the lights are on. They are both on a different ‘driver’ then the dash lights, and only have two modes, ‘bright’ and ‘dim’.... unless you count ‘dead’ if you get that one try this thread;

https://www.astrosafari.com/viewtopic.php?f=76&t=142526
Image
Sailing_Faith
U.S. Armed Forces
U.S. Armed Forces
Firing on 2 Cylinders (L2)
Firing on 2 Cylinders (L2)
Years of Membership: Sailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full years
Posts: 1285
Topics: 57
Images: 5
Joined: July 2012
Gender: Male
Alias (AKA): s/v Faith
Van Model Year: 1997
Van Make/Model: GMC Safari
Extra Info: SLT 4.3l RWD G80

Re: Power cut on freeway, but started right back up after?

Postby Sailing_Faith » August 5th 2020, 12:43am

As for the other problem, you have got a wire ing problem. Check the battery connections, and cables.... the fact that your emergency flashers would not work rules almost everything else out.
Image
Sailing_Faith
U.S. Armed Forces
U.S. Armed Forces
Firing on 2 Cylinders (L2)
Firing on 2 Cylinders (L2)
Years of Membership: Sailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full years
Posts: 1285
Topics: 57
Images: 5
Joined: July 2012
Gender: Male
Alias (AKA): s/v Faith
Van Model Year: 1997
Van Make/Model: GMC Safari
Extra Info: SLT 4.3l RWD G80

Re: Power cut on freeway, but started right back up after?

Postby kittenflaps [OP] » August 5th 2020, 1:32am

Battery is new, tests fine, redid negative battery cable a couple months ago because the post was stripped and I was having issues like this. Replaced wire 10g red wire between starter and alternator around then too, because it looked bad and the van was doing weird stuff while it was off. Distributor was replaced last year. So, those things are ruled out.
Original Poster [OP]
User avatar
kittenflaps
Fueling (1/8 tank)
Fueling (1/8 tank)
Posts: 16
Topics: 3
Joined: May 2020
Location: California
Alias (AKA):
Van Model Year: 1998
Van Make/Model: Chevrolet Astro
Extra Info: AWD 4.3L V6

Re: Power cut on freeway, but started right back up after?

Postby kittenflaps [OP] » August 5th 2020, 1:33am

Sailing_Faith wrote:
kittenflaps wrote:....
QUICK QUESTION: Now noticing that odometer light and clock light dim when I turn the headlights on, but it doesn't happen under any other accessory load. I can't remember it's always done this or if it's actually new. Is that normal (like lowering the brightness at night when you would need headlights) or indicative of something? Can anyone check their Astro of a similar year and let me know?

...Any thoughts or insight would be very kindly appreciated!


Yes, it is normal for the odometer light (and PRNDL) to dim when the lights are on. They are both on a different ‘driver’ then the dash lights, and only have two modes, ‘bright’ and ‘dim’.... unless you count ‘dead’ if you get that one try this thread;

https://www.astrosafari.com/viewtopic.php?f=76&t=142526


Thank you!! Couldn't remember for the life of me...
Original Poster [OP]
User avatar
kittenflaps
Fueling (1/8 tank)
Fueling (1/8 tank)
Posts: 16
Topics: 3
Joined: May 2020
Location: California
Alias (AKA):
Van Model Year: 1998
Van Make/Model: Chevrolet Astro
Extra Info: AWD 4.3L V6

Re: Power cut on freeway, but started right back up after?

Postby augidog » August 5th 2020, 6:49am

I'm just watching, but wanted to say you write a really good "help me" post.
Scanned original Chevrolet-GMC Dealer "Product Information Guides."
Detailed Options w/RPO's. Learn all about your Astro/Safari's first build.
https://www.astrosafari.com/viewtopic.php?f=27&t=142268
User avatar
augidog
Firing on 6 Cylinders (L1)
Firing on 6 Cylinders (L1)
Posts: 695
Topics: 16
Joined: January 2020
Location: Oregon Coast
Alias (AKA): Augie
Van Model Year: 1995
Van Make/Model: Chevrolet Astro
Extra Info: AWD High-Top

Re: Power cut on freeway, but started right back up after?

Postby MechBob » August 5th 2020, 12:52pm

I would check the underhood fuse box,where the power from battery comes into it.
User avatar
MechBob
Firing on 1 Cylinder (L2)
Firing on 1 Cylinder (L2)
Years of Membership: MechBob has been a member for 2 full yearsMechBob has been a member for 2 full years
Posts: 1144
Topics: 11
Images: 12
Joined: August 2018
Gender: Male
Alias (AKA): Bob
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: 4x4

Re: Power cut on freeway, but started right back up after?

Postby kittenflaps [OP] » August 6th 2020, 8:18pm

MechBob wrote:I would check the underhood fuse box,where the power from battery comes into it.


Thank you, I'll do this today and let you know what its lookin' like...
Original Poster [OP]
User avatar
kittenflaps
Fueling (1/8 tank)
Fueling (1/8 tank)
Posts: 16
Topics: 3
Joined: May 2020
Location: California
Alias (AKA):
Van Model Year: 1998
Van Make/Model: Chevrolet Astro
Extra Info: AWD 4.3L V6

Re: Power cut on freeway, but started right back up after?

Postby sixsix » August 6th 2020, 8:32pm

kittenflaps wrote:Battery is new, tests fine, redid negative battery cable a couple months ago because the post was stripped and I was having issues like this. Replaced wire 10g red wire between starter and alternator around then too, because it looked bad and the van was doing weird stuff while it was off. Distributor was replaced last year. So, those things are ruled out.

Extremely Famous Words Right There.

augidog wrote:I'm just watching, but wanted to say you write a really good "help me" post.

Extremely Honest And Correct Observation.

kittenflaps
So Cool.
.

Well, after all... what would Banacek say ?... “Everything needs to change except the asshole culture and stupid way of life of the avg. antifa, BLM follower - slobs, cowards, killers w/o any thought that they, IN FACT, are now the Racists.”

.
User avatar
sixsix
Firing on 3 Cylinders (L5)
Firing on 3 Cylinders (L5)
Years of Membership: sixsix has been a member for 6 full yearssixsix has been a member for 6 full yearssixsix has been a member for 6 full yearssixsix has been a member for 6 full yearssixsix has been a member for 6 full yearssixsix has been a member for 6 full years
Posts: 4349
Topics: 37
Images: 1280
Joined: May 2014
Location: Edgewood, Northern Ky.
Gender: Male
Alias (AKA): Mike
Van Model Year: 1992
Van Make/Model: Chevrolet Astro
Extra Info: LT W CPI - RWD 200K

Re: Power cut on freeway, but started right back up after?

Postby kittenflaps [OP] » August 7th 2020, 12:47am

0806201635.jpg
Original Poster [OP]
User avatar
kittenflaps
Fueling (1/8 tank)
Fueling (1/8 tank)
Posts: 16
Topics: 3
Joined: May 2020
Location: California
Alias (AKA):
Van Model Year: 1998
Van Make/Model: Chevrolet Astro
Extra Info: AWD 4.3L V6

Re: Power cut on freeway, but started right back up after?

Postby Sailing_Faith » August 7th 2020, 12:52am

kittenflaps wrote:
0806201635.jpg


Tap... ? Impact...? Breakfree... ? Something has to work, you need to clean those up. :banana:
Image
Sailing_Faith
U.S. Armed Forces
U.S. Armed Forces
Firing on 2 Cylinders (L2)
Firing on 2 Cylinders (L2)
Years of Membership: Sailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full yearsSailing_Faith has been a member for 8 full years
Posts: 1285
Topics: 57
Images: 5
Joined: July 2012
Gender: Male
Alias (AKA): s/v Faith
Van Model Year: 1997
Van Make/Model: GMC Safari
Extra Info: SLT 4.3l RWD G80

Re: Power cut on freeway, but started right back up after?

Postby kittenflaps [OP] » August 7th 2020, 1:42am

Maybe worth noting -longstanding thing where if I have it in accessory mode, using power windows will make the fuel gauge needle jump off the chart, when I stop screwing with the window it will rest but not back at its original position; likewise, the hazards will make it bounce back and forth at the same pace as the lights flashing... Since this event, that has stopped. Fun stuff :think:
Original Poster [OP]
User avatar
kittenflaps
Fueling (1/8 tank)
Fueling (1/8 tank)
Posts: 16
Topics: 3
Joined: May 2020
Location: California
Alias (AKA):
Van Model Year: 1998
Van Make/Model: Chevrolet Astro
Extra Info: AWD 4.3L V6

Re: Power cut on freeway, but started right back up after?

Postby kittenflaps [OP] » August 7th 2020, 2:10am

Sailing_Faith wrote:
kittenflaps wrote:
0806201635.jpg


Tap... ? Impact...? Breakfree... ? Something has to work, you need to clean those up. :banana:


It's a fear of breaking the 90's plastic that these are clipped into the fuse box with. Hard to get a grip on it from the side or underneath, so can't get much torque without really risking the whole piece snapping off. Any tips? Tried some "deep creep" lubricant, and scrubbing with lectric cleaner n wire brush. Haven't had much luck. Will try again tomorrow, maybe lubricant will penetrate further by then..
Original Poster [OP]
User avatar
kittenflaps
Fueling (1/8 tank)
Fueling (1/8 tank)
Posts: 16
Topics: 3
Joined: May 2020
Location: California
Alias (AKA):
Van Model Year: 1998
Van Make/Model: Chevrolet Astro
Extra Info: AWD 4.3L V6

Re: Power cut on freeway, but started right back up after?

Postby Rockridge » August 7th 2020, 2:11am

Can you slot the stud with a Dremel so you could put a flat head screwdriver in the stud to support it while you break the nut free?

PB Blaster will help
Rockridge
Firing on 8 Cylinders (L1)
Firing on 8 Cylinders (L1)
Years of Membership: Rockridge has been a member for 4 full yearsRockridge has been a member for 4 full yearsRockridge has been a member for 4 full yearsRockridge has been a member for 4 full years
Posts: 804
Topics: 46
Images: 0
Joined: May 2016
Location: New Hampshire
Gender: Male
Alias (AKA): Walker
Van Model Year: 2000
Van Make/Model: Chevrolet Astro
Extra Info: LS AWD

Re: Power cut on freeway, but started right back up after?

Postby Leeann_93 » August 7th 2020, 2:20am

PB Blaster, tap with something metal (helps the capillary action), a little bit of heat and, believe it or not, actually tightening the nut slightly will help break it free so you can remove.
'05 Astro AWD vin X
'02 Astro LS AWD vin X
'00 Astro LS AWD - WIP
'99 Safari XLE AWD - broke
'93 AWD EXT vin W - real broke
User avatar
Leeann_93
Team Leader
Team Leader
Firing on 8 Cylinders (L7)
Firing on 8 Cylinders (L7)
Years of Membership: Leeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full yearsLeeann_93 has been a member for 11 full years
Posts: 13499
Topics: 44
Images: 17
Joined: December 2008
Location: MD
Gender: Female
Alias (AKA):
Van Model Year: 2005
Van Make/Model: Chevrolet Astro
Extra Info: LS AWD

Re: Power cut on freeway, but started right back up after?

Postby dcsleeperdcsleeper is online! » August 7th 2020, 9:33am

This
WILL
break it free

http://www.freealloil.com/
Please update your User Control Panel to include your location!!! it's in the upper right!
Profile | Edit signature

foxfire wrote:i have a thing for customizing slightly outdated vehicles.

yeah, don't we all....
User avatar
dcsleeperdcsleeper is online!
Firing on 2 Cylinders (L1)
Firing on 2 Cylinders (L1)
Posts: 234
Topics: 15
Images: 51
Joined: April 2020
Location: North Carolina
Gender: Male
Alias (AKA):
Van Model Year: 2004
Van Make/Model: Chevrolet Astro

Re: Power cut on freeway, but started right back up after?

Postby MechBob » August 7th 2020, 1:28pm

Neither one of those studs could cause your problems, don't mess with them unless you really want to.Corrosion ior bad connection nside the fuse box could cause your problems.
User avatar
MechBob
Firing on 1 Cylinder (L2)
Firing on 1 Cylinder (L2)
Years of Membership: MechBob has been a member for 2 full yearsMechBob has been a member for 2 full years
Posts: 1144
Topics: 11
Images: 12
Joined: August 2018
Gender: Male
Alias (AKA): Bob
Van Model Year: 1994
Van Make/Model: Chevrolet Astro
Extra Info: 4x4

Re: Power cut on freeway, but started right back up after?

Postby unclemaui » August 17th 2020, 9:49pm

When I have an issue like that. I use penetrating oil. heat with a torch (small flame just to get the nut warm not the post or plastic. or use heat gun again try only the nut. it will expand a tad, enough to allow the penetrating oil to creep.

keep a wet towel by in case you get anything too hot you can cool it down quickly.
then with firm grip try to loosen tighten loosen tighten. little by little no jerking. just steady constant pressure. don't increase pressure too much. patience is your friend.
unclemaui
Fueling (1/8 tank)
Fueling (1/8 tank)
Years of Membership: unclemaui has been a member for 7 full yearsunclemaui has been a member for 7 full yearsunclemaui has been a member for 7 full yearsunclemaui has been a member for 7 full yearsunclemaui has been a member for 7 full yearsunclemaui has been a member for 7 full yearsunclemaui has been a member for 7 full years
Posts: 15
Topics: 5
Joined: July 2013
Alias (AKA):
Van Model Year: 1994
Van Make/Model: Chevrolet Astro

Next

 
  • Related topics
    Replies
    Views
    Last post

Return to Electrical

It is currently October 27th 2020, 9:31am

Electrical Forum
ElectricalDiscussion specific to electric components of vans. Category for alternators or batteries, starters and ignition parts, anything 12v and electrical issue like fuses, circuitry, wire, terminals, switches, connectors, bulbs, relays, and wiring. Voltage and amperage diagnosis.
To create a new topic in Electrical, click this button:
Previous topic Next topic
Recent Image Attachments
Attached by:
Attached by: stent
stent
in Electrical
Views: 279
Comments: 5
Date: Today
Time: 4:29am
» Read last comment
Attached by:
Attached by: Leeann_93
Leeann_93
in Electrical
Views: 137
Comments: 9
Date: Oct 24 '20
Time: 3:02pm
» Read last comment
Attached by:
donbenny1915
in Electrical
Views: 204
Comments: 4
Date: Oct 23 '20
Time: 1:44am
» Read last comment
Attached by:
nwisehart
in Electrical
Views: 123
Comments: 3
Date: Oct 21 '20
Time: 12:44am
» Read last comment
Attached by:
Olivier02
in Electrical
Views: 117
Comments: 3
Date: Oct 11 '20
Time: 8:34pm
» Read last comment
Sponsors

Who is online

Users browsing this forum: No registered users and 10 guests